Newbie Questions

Hello all. I am a MAC user, new to RM and have been entering my research into RM8 since March. I have some questions that I am hoping someone can answer for me.

  1. Is there a “how to” resource geared to the beginner of RM8? I find the Wiki and the vidoes are more geared toward users of previous versions of RM. I feel there are features and shortcuts that I am missing as a newbie and therefore not taking full advantage of the program.

  2. Are the backups full or incremental? I had contacted Support asking why some of my daily backups are large and some are small for which they had no answer. It was suggested that I rename my current file and then upload a backup to see what happens. I am too new and therefore reluctant to do this fearing loss of months of work.

  3. When I check off “backup media files” for my backup, does the backup include all of the media from the RM media file I have set up on my HD? Or, is it only the media thumbnails and/or media filenames from the program?

  4. How long do you keep your backup files? I was thinking of keeping a backup for a month and then clearing up space on my HD, external drive and USB thumb drive.

  5. Is there a way to print media along with a report? The scrapbook only includes the thumbnails which are illegible. I had asked Support and was told that media would have to be printed manually.

  6. In the Media section, my media hardly ever opens and I constantly have to re-provide the link from my HD. I had contacted Support about this and they double checked that my “media type” was correct. They could not provide an answer as to why this is occurring.

  7. Some of my footnotes and some events are not in order. I have transcription and translation footnotes that come before the footnote to the original document. Is there a
    quick way to rearrange footnotes and events without taking them out completely and re-
    entering them in the order I would like them to be?

Thank you in advance for any help you provide!

Backups are full. They are actually a zip file with an RMBACKUP extension. The zip file contains a zipped version of your RM database. If you wish to prove this to yourself, you can rename an RM backup file to have a ZIP extension and use your zip utility to look inside the file.

Backups can include media files or not, and it’s an option that’s the user’s choice for each backup. Media files that are backed up are zipped into the backup file in the same manner is the RM database itself. That choice would make the backups larger or smaller. I cannot think of any other factor that would affect the size of backup files as you describe.

It is a backup of the actual JPG or other image file that is backed up, not just the thumbnail. It is only files that are linked into RM’s Media gallery that are backed up. If other files are in the same folder but they are not linked into RM, then they are not backed up. Except for the thumbnails, RM does not store media files within its own database. It only stores links to the media files.

The only media that can be printed along with a printed report is the one photo that you link to an individual’s main person record. The only way to print any other media file is via a scrapbook report. My experience is that scrapbook reports contain printed images of the actual media files, not images created from the thumbnails. I can’t explain the poor resolution you are getting from scrapbook reports. What kind of image files are you trying to print in scrapbook reports? JPG’s? PNG’s? Etc. Are they entered into RM as type Image or type File?

It has also amazed me that the number of kB has a decreasing tendency the more people I register. I have mostly worked all the time on RM 8 on FamilySearch Central to get more people transferred to RM. Therefore, the number of people in my tree will increase all the time. However, I have to pursue people outside of RM who also make the tree bigger.

Below is a screenshot of the backups.

Thank you, theJerrybryan, for your responses!

The backup issue is perplexing. I always check off “backup media files” and backup daily to my HD, external drive and a USB thumb. I also use Time Machine.

I shared my screen with tech support and they did not know why this occurs and suggested I rename my current file and upload a backup to see what happens.

As an example, here are the sizes of my last backups:
July 1 528.2 MB
July 5 20.9 MB
July 6 33.3 MB
July 7 46 MB

Again, thanks for the response!

I have JPG’s and PDF’s. The JPG’s are type Image and the PDF’s are type File.

I had shared my screen with tech support and he did not know why I was only getting the thumbnails and not the actual media files in scrapbook. The solution was to print the media manually.

I also have an issue with having to constantly re-enter the links to my media files in order to be able to pull them up.

Actually, I haven’t been able to print a scrapbook report lately—access violations!

RM was recommended to me by someone I highly respect in the field of genealogy. So, I continue to enter in my research hoping these issues will get resolved.

You could make copies of these backup files, rename the copies with the .ZIP extension, and then open the .ZIP extension files to see what’s inside. I use Windows, and Windows itself includes a very basic .ZIP viewer and unzipper, plus I have a license to WinZip. Surely, your Mac system has the ability also to look at .ZIP files. If you looked inside the RM backup file in this way it might provide a clue as to what is going on. Of course, it might not provide a clue, but I think it probably will.

That describes basically an impossible situation. Are you certain that you are linking your media files all into the same RM database? Have you changed the default folder for media files since you entered the media files into RM? Are the media files that you have to re-enter being displayed with a red X in the RM media gallery?

No red X’s and I have not changed the default folder for my media files. Also, all the links are into the same RM database.

The path for all my media links is:
Users>myname>Documents>RootsMagic>Backups>mynameMedia>name of the image or file with a .pdf or .jpg depending on the file type.

If there are no red x’s, then you don’t need to relink them every time. Can you give more detail on what you are doing that makes you think they need to be relinked? Screenshots of what you see would be helpful.

I would infer that the small ones contain only the .rmtree database file while the 1/2GB one includes the media files. As Jerry has suggested, change the extensions from .rmbackup to .zip and open with a Zip utility to see what files are inside.

I’m confused by these sizes because none correspond to the backup file sizes in your initial screenshot (~90MB).

A contributor to non-proportionality of file size relative to number of people is that the impact of one person can have a very wide range, depending on the number of facts, sources, media linked to them. Deletions do not return formerly needed space to the operating system until the Compact tool is run.

  1. RM8 has no manual. This is a serious gap not filled by an evolving wiki. You can buy a 2015 RM7 print manual on amazon, a pdf version from rootsmagic or find it on the web. It would give you an overview of how rootsmagic works even though for a previous different version. RM8 is unfortunately still a work in progress as shown by the mac access violation crashes never before seen on macs.

  2. Try using the Tools menu to clean up and compact your database prior to saving and backups. If the media is checked then media (jpgs/pdfs/pages docs) will be included IF linked in your database file. Unlinked media would not.

  3. Backups are for disasters so keep only long enough to cover that need. Are you are a klutz and delete your database or botch it daily or careful and prudent? That will tell you how much to keep (weeks of daily vs perhaps 1 a week for a month back).

  4. RM8 handles media poorly based on file type. PDFs and pages files will open nicely in the parent mac app and be easy to read and use. JPGs will open inside RM8 in a small awkward window when you really want to see them in Preview. Most of my media are PDFs except for portraits for this reason.

Truly very puzzling. As kfunk said, can you give more details? What exactly are your symptoms? For example, can you see the files in the Media Gallery but you can’t print them in a scrapbook? Can you see the files in the Media Gallery when you click on the Looking Glass icon (the View Media Item icon)? Can you see the files in the Media Gallery when you click on the Crayon icon (the Edit Media Item icon, and it’s probably supposed to be a pencil but it looks like a crayon to me)?

Kfunk, I can’t do a screen shot due to privacy issues with the project I am working on. Wish I could—would be much easier than a written description!

thejerrybryan, I can see all of my media files on the Multimedia and in the Edit Media screens. When I click on the pencil (crayon) icon, I get a popup that states:

The file “____” couldn’t be opened because you don’t have permission to view it. To view or change permissions, select the item in the Finder and choose File > Get Info.

When I go to Finder and choose File>Get Info, I have permission to “read and write.” There is no option available to grant permission to “View.” However, the “open with:” pulldown is set to “Preview” as the default.

When I click on the Looking Glass icon, I get a popup that states:

The file “_____” couldn’t be opened because you don’t have permission to view it.

After clicking “ok” on this popup, RM takes me to “View Image” that appears on the left-side of my screen and has nothing in it. On the right-side of my screen is a thumbnail of the image and the same pulldowns as Edit media where I can then re-link. If I don’t re-link, I can click OK and RM takes me back to the Multimedia and Edit Media screens.

Consequently, I cannot print them in scrapbook.

Rooty—thank you for your responses, I will look for the book! Under “Get Info,” “Preview” is the stated default for opening my media files. I would convert all of my JPG’s to PDF’s if that would solve the issue, but I can’t open and view PDF’s either without re-linking!

So you don’t know how to redact the person’s names? Most image editing software allows you to mark out sections using a brush…

Those error messages are not Rootsmagic problems. Those are specific to your computer. There isn’t much that we, or RM support, can do in regards to your computer. You may want to examine access rights to the folder that the media is stored in, or even access rights to the drive. I am assuming these photos are not on some form of removable drive, or stuck out in the cloud? They are locally copies of the files?

I do think the errors are permission issues with the folders. If you have not been merging and running the database tools to compact the file, then I think you maybe opening and using different databases. Go to File, Open a RootsMagic file and then let it search the computer for all the database files on there. Add the Date Edited column to the People List by customizing it. Then sort by clicking on the column header to see the last time you worked in that database.

Being a Windows person rather than a Mac person, I’m at or beyond my limit of any ideas to help. But I agree with kfunk that it really does seem like some sort of Mac configuration or permission problem rather than an RM problem. So I agree with the suggestion to examine the access rights that RM has to the files. And it looks as if the files may be on a removable disk of some kind? I don’t really know how access rights to such files work on a Mac.

Here is one more thought. If you link a single new file into RM totally manually, is it immediately available to RM in the Media Gallery and to be printed as part of a scrapbook? I suspect the answer is yes. But if the answer is no, then I would focus just on getting that one file to work.

So let’s suppose the answer is yes that you can get just get one file to work if you link it into RM manually. How did all those other files that don’t work become linked into RM? Did you enter each one manually? Or did they become linked into RM in some bulk or automated way? For example, did they come into RM via GEDCOM import? Did they come into RM via download from FamilySearch? Did they come into RM via download from Ancestry using TreeShare? Did you bulk load them into your RM from the Mac file system using drag and drop of files? Etc.

Even though you can’t post screen shots for privacy reasons, can you describe where you are seeing these items in the incorrect order? I can’t picture what you are seeing.

In the case of events, RM places them in order by their date. A birth in 1900 comes before a death in 1910. And if you had something crazy like a birth for a person in 1910 and a death for a person in 1900. The death would come before the birth.

If this order of events does not meet your needs, you can override the order by adding sort dates to individual events. In particular, sort dates may be necessary for events that happened on the same date. For example, if a person was born on 12 Jan 1900 and died on 12 Jan 1900, RM may put the death before the birth. The solution to this problem is the use of sort dates.

For sort dates, you can use dummy dates. For example, for a birth date of 12 Jan 1900 you could use a dummy sort date of 11 Jan 1900 and for a death date of 12 Jan 1900 you could use a dummy sort date of 13 Jan 1900. A better way most of the time is to add suffixes to sort dates but not the actual dates. For example, the birth date could be 12 Jan 1900 with a sort date of 12 Jan 1900-1 and the death date could be 12 Jan 1900 with a sort date of 12 Jan 1900-2.

RM does not provide any controls for ordering citations. Prior to RM4, citations were listed in alphabetic order. In RM4 and all subsequent versions they are listed in the order in which you enter them.

Hello rzamor1, thank you for jumping in. I too think this looks like a folders permission issue.

I currently have only one database (rm.tree) in RM8 and my files are local, not in the cloud or external (good question kfunk). I use an external for backups only.

In my Finder (I think that is Mac’s version of File), I added the column “Date Last Opened.”

My folders are set up like this: I have one folder named RootsMagic. Under this folder I have two subfolders, Backups and Data. Media is a subfolder under Backups.

My RootsMagic folder correctly shows the “Date Last Opened” as today’s date and the time.

The subfolder named Backups correctly shows “Date Modified” as yesterday and time (my last backup) but the “Date Last Opened” is March 30, 2022 (I think that is the date of purchase).

The subfolder under Backups named Media correctly shows “Date Modified” and “Date Last Opened” as today’s date and time. Also the individual files listed under Media are correctly dated as to both modification and when last opened.

The Data subfolder has my one database, rm.tree. It has the correct “Date Modified” as today but like the Backups, the “Date Last Opened” is March 30, 2022.

The size of the RM and Backup folders is 4.87 GB; the Media folder is 646.7 MB; and the Data folder is 5.5 MB. Each folder grants me permission to read and write (view is not an option in Mac permissions, my media files open in Preview as the default).

In RM8 itself, my People window has the “Date Edited” on the bottom of the screen and correctly shows the dates of these past two days for those people I edited.

I have not been running Tools before backing up and closing. I will be sure to do so from now on.

thejerrybryan, thanks for the tip on adding a suffix to the date for ordering. As for my citations, it looks like I have some work to do in terms of removing and re-entering. I do link each new file into RM totally manually—no bulk via GEDCOM, Ancestry of FamilySearch—but its a no go for printing as part of a scrapbook (the access violation pops up).