Using Dropbox to connect imac and ipad

Has anyone tried using dropbox to share a database from a imac to an ipad?
I have created a dropbox account purely to do this and I can see that dropbox has a copy of the database but it will not apparently let me open it as I seem to need my ipad roots app to see a database which I cannot link. I am not needing to pay for Dropbox for the size of the file in question.Nor do I need Dropbox for anything else. Seems a poor app to me but?? Can I connect my mac to my ipad pro by cable and would that work? Sorry to be so stupid.

Have you read the wiki on how to use Dropbox for the app?


The wiki article doesn’t really tell you very much about how to do it. I wonder if your missing piece is that you need to install the Dropbox app on your iPad. The RM mobile app for the iPad is designed to gain access to the file via the Dropbox app on your iPad.

It’s been many years since I installed the Dropbox app on my iPad and iPhone. But my best recollection is that having done so, you have to give the Dropbox app your Dropbox username and password just once. Ever after, the RM mobile app communicates with the Dropbox mobile app to gain access your RM file in the Dropbox cloud. You don’t have to provide your Dropbox logon information every time you use the RM mobile app. In other words, the wiki article tells you how to put your RM file in the Dropbox cloud from your iMac, but it really doesn’t tell you how to get your RM file from the Dropbox cloud while you are on your iPad.

If you can get the RM mobile app working, you will see that you can get your RM file “From Dropbox” or “On Device”. You will have to get the RM file “From Dropbox” just the once and thereafter you can get the RM file from “On Device”. Essentially, the RM mobile app moves your RM file “From Dropbox” to “On Device” for you and once the file is “On Device” it stays there and you don’t have to use Dropbox again in the mobile app. The exception is that if you make changes to your RM database that you wish to be able to see on your iPad, you will need to do the File => Export => Dropbox process again from RM on your iMac and then get your RM file again “From Dropbox” on your iPad.

I do not know why there is not a process available to transfer your RM file from your iMac to your iPad to the location on iPad where the RM mobile app can see the file as “On Device” without going through Dropbox. You would think that Mac and IOS would be well enough integrated to handle the data transfer just fine. I’m a Windows user rather than a Mac user, but even on Windows it would seem like iTunes should be able to transfer my RM file from my PC to where the RM mobile app needs to see it in my iPad and iPhone. But that’s not the way the RM mobile app is designed to work. The iPad and iPhone file system is a mystery to me. It seems like the user can’t see the iPad and iPhone file system directly and can access the file system only through apps.

RM is a computer program and does not run on iOS.
the RM ios app is 7 years out of date and not updated and read only via dropbox.
Just upload your tree to ancestry and use the excellent free ancestry ios app to see and edit your tree on your ipad. Ignore dropbox.

Jerry; apple mobile devices use a separate operating system different from apple computers. Apps can be designed to use files transferred directly from mac to pad or shared through iCloud. Older cruder apps used a klutzy approach like dropbox.

Uploading from RM to Ancestry can entail considerable data loss or very little data loss. Downloading from Ancestry to RM can entail considerable data loss or very little data loss. The data model used by Ancestry is very different that the data model used by RM. The difference in the data model is the chief cause of any data loss, not software bugs per se.

If all you want to do is to see your RM data on your iPad, uploading from RM to Ancestry and using the Ancestry IOS app on the iPad is probably sufficient for your needs. But if you want to update your Ancestry data via the Ancestry app on the iPad and then copy the data back down to RM via TreeShare, you would need to consider the data incompatibilities that will be involved.

1 Like

Agree with data structure issues. However the ancestry ios app does provide hints, shows your tree data and is editable.

For FTM this is less of an issue since the FTM data structure is a better match to Ancestry’s where it was the in-house software program until dropped in 2015.

Thanks. Whilst I had not read it I now see I had done all of this and the file shows on Dropbox but my RM8 on the ipad will not open it. I will try looking at all of it when I next have time.Thanks for rapid reply.

Thanks for the thoughts. As other reply I will study it all again. However just a word of caution about family trees. My most serious and respected Family History friends would council great caution about use of any sites for uploading FT data for reasons of security but also due to uncorrected data errors. Much on line is rubbish, sadly, as one person puts in errors and another copies it into their FT etc etc.I have seen FTs with people baptised before they were conceived, dead before born etc. Ok review but always confirm from the actual and real data sources. Getting before 1700 and proving it seems impossible for my lot yet people using the same records as me claim ancestors in 1500s. I suppose we all came from a couple of folk but. Enjoy the season.

1 Like

the important bit here seems to be that you may not have the RM App, which isn’t RM8, on your iPad.
The App is old but does a perfectly good job of having a read only snapshot of your data quickly availble to you on your ipad.
Mine is still working on IOS 15.7 but I do expect later IOS versions to break it sometime soon (The Android version wont work any more apparently.)
There are several threads here on the community about the iPad app that may offer you additional clues.

Are you using the / / option in RM8?
You cannot just copy/save the RM8 DB to Dropbox


Thanks again to all replies. To Steambuff and LornaHen it has apparently solved my problem but maybe quite why I know not. Anyway not understanding the //option thing but got the message that maybe my ipad had not got a correct or ? full download of the app I deleted it on the ipad and started again and also carefully made a new copy on RM8 at the imac desktop to Dropbox. It worked virtually instantly. Thanks to all for the ideas and suggestions that led me to it. I only want to have a portable copy when history hunting in churches and record offices not actually do recording so I am now made for life it seems.

The posting should read … the File - Export Data - Dropbox option…

I enclosed the menu option in Less-Than and Greater-Than characters, they got changed