Upgrading to MacOS Sonoma

With the official release of MacOS Sonoma, there have been some reported issues with RootsMagic (and other programs as well), not displaying correctly on some systems.

While we continue to look into this to determine if it is an issue with Sonoma, our development tools, or our own software (or some combination of the 3), we recommend holding off upgrading to Sonoma for a bit if that is an option for you. The issue appears with certain screen resolutions, but we so far have been unable to determine what those resolutions have in common.

If you do need to upgrade to Sonoma (or already have), here are some steps you can take for now:

  1. Start RootsMagic on your Mac

  2. Go into your Mac settings and chose “Display”

  3. Click the “Advanced” button

  4. Select “Show resolutions as a list”, then click Done

  5. Select “Show all resolutions”

  6. Step through the various resolutions and look at the RootsMagic window to see if that resolution fixes the issue (and is a good text size for you).

We will continue to work on this and will issue an update when we have a permanent solution.


Thanks for advising this.

We have just bought a new Macbook with Sonoma, loaded RM onto it but as yet not tried it.

It is the same thing that happened with the beta. I upgraded to Sonoma and it has the maximize font problem upon opening. Please let me know when this gets resolved b/c I have to use another machine just to run the program effectively.

OK, I did all the above and set the resolution to 1920x1200 and now have a useable desktop with RM9

I did all of the suggested steps, which help to provide a smaller text, but I cannot scroll down or access the rest of the app.

It means I cannot exit the app or even see the backup options.

For mac users EasyRes (free on the app store) could be a temporary helper. It lets you easily switch between screen resolutions. Also Option-F1 or F2 will open system settings at the display resolution pane. The advanced tab has a choice to show available resolutions as a list.

I have to switch resolutions for FTM 2019’s tiny text and then switch back for everything else. RM9 on Ventura has a good text size and contrast. No one should be using Sonoma at this point unless you enjoy being a guinea pig for bugs like this. Always wait for the #2 or 3 bug fix (OS.2/3) in a few months.

1 Like

Any of the resolutions tagged as “Low Resolution” worked for me.

It’s not a macOS bug, it is a RootsMagic bug.


Concerning a possible update fix: When opening RM8 on MacOS Sonoma, it is zoomed in to the lower left portion of the window and there is no way to scroll around or tab through. There are only two options in the drop down menu, neither of which allow you to go to an update option. Since the app doesn’t come from the Apple Store, it can’t be updated there either. Even if you can fix this with an update, how do you recommend we resolve this under these circumstances? Thanks for any thoughts on the issue.

If an update needs to be released by RM we will only update RM9. For RM8 you would need to use the steps given above to adjust your resolution to something that works better.

The steps above do not resolve the issue on my computer. It sounds like your saying that RM8 is essentially bricked for use on Sonoma.


Thank you for that very specific walk-through. Unfortunately, what I end up with for plist in the text editor doesn’t look like your description. I’ll try to upload a screenshot for you…

You opened the file in TextEdit which is not intended for your venture. Download

from the App Store and open the file in that application.

Thanks again for the advice, however, using BBEdit I opened info.plist, changed the NSHighResolutionCapable to ‘false’ and saved the file. Now RM immediately crashes when I try to open it. I changed it back to ‘true’ just to see if that somehow was the source of the crashing but it only crashes now.

Sorry, it worked for me and others.

Replace the RootMagic app from your TimeMachine backup. You’ll be, unfortunately, at the mercy of the RootsMagic team’s glacial code review, but you can lower the resolution as outlined above to compensate for the coding.

Hang in there, they rarely take more than a few months to fix their code.

I restored my last version, then went in and made the HiRes change and it worked this time (yay!). I compared the previous plist text to my changed text and nothing was missing or different aside from the true to false change so not sure what happened but all is well now. Thank you for the instructions and patience.

I spoke too soon. It’s back to crashing again from ‘Invalid Code Signature’. I read that if you use the Xcode program (rather then BBEdit) it automatically corrects some common mistakes/errors one might make or run into when editing. I think I’m gonna give up on this program for the Mac but I hope all this advice helps others out there looking for a fix.