Fix for RootsMagic 9's poor UI rendering on Sonoma

The developers set a flag that their software wasn’t capable of performing at.

The solution is to right click on RootsMagic, choose “Show Package Contents”, then click the “Contents” folder. Right click on “info.plist” and open with your editor. Search the string “key>NSHighResolutionCapable</key” currently set at “true” and set the flag to “false” as this program is not actually capable of high resolution. The corrected entry will read as: “key>NSHighResolutionCapable</key” “false”. Save the file, reset your screen resolution to something reasonable, I suggest the default on a Mac, and start RM9. Be sure to change only the text “true” to “false”.

I don’t have the time right now to test RM 8, but it’s my guess the same flag is incorrectly set.


Not to be recommended and waiting for RootsMagic to publish an update should be the way to go. Your efforts are appreciated but editing a plist is a no…no.

Suit yourself, but this simply sets the flag in the exact same method as the old “Use Low Resolution” checkmark that was present on previous versions of OSX through the Get Info page.

What about a backup and use a decent text editor e.g. BBEdit before jumping in?

If one needs to be told those rudimentary suggestions, it’s not likely one could open the file in the first place.

But again, suit yourself. And don’t run with scissors.

This is an inclusive community with all levels of expertise. Your suggestion does not work as is and requires that those people launching RM9 from the dock replace with a link to the modified RM9. The Forum is here to help.

This issue has been resolved with the latest RM9 update after admitting that the Mac OS was not the issue and the RM team finally manned up and did the correct thing. Even the betas for Mac OS play nice with the new RM9 release.