Unable to paste in Notes with v. 8.0.4 -- 'Unexpected error' - and how to revert to 8.0.1?

I know it sounds mundane, but did you run database tools and restart after updating? I did and I didn’t have an issue when I ran through a few tests. I am using Windows, so I can’t speak for Mac.


@Terry Sounds like you’re running the same OS and version I am (Win10 Pro). Good to know that it works for someone.

@alainemk Thanks for the suggestion; that hadn’t occurred to me. Will try that.

Reboot Windows?

If that doesn’t clear it, reset RM CTRL+SHIFT+U. Restart RM.

If still persistent, Uninstall RM, re-download, reinstall.

1 Like

Thanks @TomH, gonna have to try that. I was getting the dread Access Violation error, so I ran through the entire procedure to clear that. Still having the problem, so time to uninstall and reinstall… Still love RM8, but looking forward to getting past the bleeding edge! :grinning:

I’ve been getting the Access Violation error. You mentioned a procedure to clear that. Can you let me know what that procedure is, please.

I am finding CTRL+SHIFT+V will work even after the CTRL+V access violation. I seem to get the access violation more often when adding new records rather than updating existing ones.

1 Like

I’ll try that. I’m at my wits’ end at this point…

EDIT: @klmeagher Thank you thank you thank you!!! That worked!!! I’ve been getting the error consistently while updating existing records, and I’ve tried everything else suggested in this thread.

Thank you everyone!


I upgraded today and started getting these errors, it became annoying so I wanted to see if others were getting the same issue. When I saw this thread I decided to try restarting as suggested and have discovered that my database has lost all my work from today - I had been adding a new family group so I am missing people, facts, sources, media and notes 4 hours of work gone. I tried to restore from the backup but the data isn’t on that either.

This is worrying since I can’t trust RM8 is saving the data I am adding, since until you exit it seems to be fine.

Definitely more random errors where copying and pasting in Notes fields, particularly when using key combinations like Ctrl+V or the Paste icon. Usually find that using ‘Paste as Plain Text’ from the Menu will do the trick.

I used a CTRL+V to copy text in RM 8.0.4, then clicked on a separate utility to strip the special formatting, and then the paste worked. The CTRL+SHIFT+V is supposed to do the same by striping the special formatting in a copy but for some reason it did not work for me in WIN10. I think the issue must be with formatting in the text being copied.

I see the same when I have plain txt in the notes, select it with ctrl-A and then try to paste using ctrl-V with plain text in the clipboard copied from another note…
If I use the menu- paste as plain text, it works as expected. *I’m running RM 8.0.4 on Win 10.

This doesn’t sound right. In my version of Win10 (home), CTRL-A selects everything; to copy, I use CTRL-C, and CTRL-X to Cut. Would you care to explain?

It seems like if you copy and paste within certain areas of RM, I get the access violation error.
Copying from Notes maybe?
Seems to work when I copy the first name and paste it into the first name of an alternate name fact.

I do not get any access violation error when I paste into RM something that was copied from outside RootsMagic.

I am getting the error too… I also noticed that I was also pasting the formating when I copied and pasted from Ancestry to RM8 notes.

Like many of the users I use copy and paste ALOT so it is very frustrating to have to tidy up every time.

1 Like

Having the same issue. In the Webinar on Editing people, Bruce mentioned that it is a known issue involving a library provided by a 3rd party and that a fix is on the way.

Till then, click the 3-dot menu and select ‘paste as plain text’ and she’ll paste just fine.

Hope this helps!


@medman53 Thanks for the update, and welcome to the forum!

Thanks! Appreciate the welcome.

Call me nosey (and veering off topic) but I noticed you’re a retired Pharmacist. That makes two of us. Bailed in 2009 after 37 years. Enjoyed the work, but like retirement ever so much better!

I left practice in late 1998 after burning out; went back to school & got a Masters in Library and Information Science and worked as a medical librarian for several years, and spent my last 10 years as a medical writer writing CE lessons on drugs for nurses. Retired in late 2018, and loving it!

1 Like

Correction: CTRL+C was used to copy instead of CTRL+V