Note editor issues?

Are these just issues for me in the note editor?
Ctrl+Z doesn’t work
It would be rather good if the note editor was a tad more standard during normal edits between saves of the note.
Ctrl+Z doesn’t seem work for me to undo the immediate last change you’ve made in the edit screen between saves of the note
(and yes it did in RM7)
It does appear that RM8 is saving to the database only when you leave the note editor or choose to save where you’ve got to, so why this non-standard edit behaviour?
The 3 dot menu has an undo command, but that wipes the whole text you’ve typed into the note, unlike in RM7 where it does the last word, not the whole text, ie works like the keyboard command

Cursor positioning erratic?
I also have issues with the cursor movement jumping around when using the, to me, standard commands to jump to end of line, but this one is more likely me / my keyboard, although there is one spot on a regular paste / edit sequence I do that from a certain position down the pasted text where it frequently jumps to the end of the first line instead of the current line for some to me obscure reason.

I have also found myself highlighting text to replace where the paste ends up unexpectedly placed further along the text.
My first guess - beyond straight user error of course :slight_smile: - was that the position counter had not taken into account the removed text placing the paste where the replaced text used to end but therefore in the middle of the following text.

Missing Search/Replace function from RM7
And yes I miss the search / replace functionality of RM7 given I hate having to switch tools just to achieve something where I’m currently working.

Just trying to gauge if these are just issues for me, or general ones. I’ve not yet reported any of these beyond this post.

To which I’ll add that while editing a pasted note, eg census household, I frequently find that the view on the screen does not word wrap, so I think I’ve inadvertently deleted something when it has just done an “exit stage right”.

No, they are not issues for just yourself. (I’m on a Mac.)

I have repeatedly reported, going back well over a year, that paste (Insert) puts the first character where the cursor is positioned, and the rest of the text after all existing text. I also have trouble where the cursor seems to position one character after where it should. Paste (replace also has the same problem.

And, just try pasting in several lines of text repeatedly. It gets slower and slower, and the CPU usage is, to me, incredible.

All reported, all accepted, but no change. To my mind, the note editor needs a complete rework.

Missing Search/Replace function from RM7
And yes I miss the search / replace functionality of RM7 given I hate having to switch tools just to achieve something where I’m currently working.

Search/Replace is sort of hidden in RM8

  1. Click Search
  2. On the top right are 2 vertical lines. The lower one says “More Options” when you hover over it. Click it.
  3. Click “Search and Replace”

You can go back to People without losing your place.

@mapleleaf
thanks, but that’s a different search and replace
The one you are describing sounds like this one which is searching the entire database
RM8


The RM7 one I was referring to is this one for working within the open text edit window

very handy for tidying up pasted census transcriptions
Under the Search menu is both Find and Replace with a range of options

I agree that the note editor feels very unnatural. Expected right clicks and hot keys often don’t work. It’s very unclear when your changes are really saved or cancelled. The editor can be very sluggish.

I think a part of the problem is that the editor is really an HTML editor under the covers, and the editor feels like it has been repurposed into a plain text editor.

Another issue with the editor is that it won’t insert tabs. In RM7 you could insert tabs and make aligned tables ( e.g. in census reports). RM8 convert tabs to spaces, and hav made all my census tables difficult to read.
Keld

I do have to ask, how did your tab aligned census reports actually look in reports?

I tried and tried in RM7 and its predecessors to make tab aligned reports. Even though they would look ok in the RM7 Note Editor, I could never get them to look right in printed reports. I think the underlying problem is that there is not a universal way that various software handles tabs.

The modern way to produce the equivalent of tab aligned data is to store it in columns and the columns are created by using tables. For example, that’s the way Web pages do it and that’s the way one of RM’s competitors does it. But for genealogy writ large, there is no standard way to produce data in columns such that the columns will survive when data is transferred from one software to another.

On the other hand, one of my several complaints about RM8’s Note Editor is that it doesn’t allow you to store a carriage return or newline at the end of a note.RM7 would actually allow you to store a carriage return or newline at the end of a note but then it would lose the carriage return or newline on GEDCOM transfer or Drag and Drop. RM8 “solved” that problem by not allowing the carriage return or newline at the end of a note in the first place.

Ok, I’m not using RM reports, but use copy paste a lot into my own writing. I copy census data into a simple editor, and align columns with tabs, and copy/paste it into RM. The table looked ok in RM7, and was easy to check and cross reference to the children mentioned in the census record. Now the data is more difficult to read, and you have to look hard to find the birth years (necessary because there is an awful lot of Hansen, Jensen and Pedersen’s in DK). This is even more important in RM8, as there is no easy way to find the children. Each one has to be looked up by a separate search ( in RM7 you could find all the children with a single lookup)
Keld

I’ll expand on the wordwrap part of my original post above and have just sent this part of it in as a ticket.

I guess this is a feature request to RM rather than a bug (to me)

Yes I can see that there are scroll bars at the bottom of the note edit screen, AND an option to click on a sort of full screen view on the right above the text box, but why on earth is the default for display not to automatically wordwrap the text?
Especially as even in supposedly full screen view the text still needs scrolling right!

It is both very disconcerting to think you’ve missed inputting something (as I did in a recent editor ticket sent where my typing simply disappeared, not even having kept the focus of the view where I was actually positioned and typing)

And annoying not to see everything at a glance when opening a note.
Unless you click at least twice more (either using the scroll bar or using the screen box icon then scroll bar ) for this apparently wide note, whiich means you still cannot see the whole note at once.
It is much more usual to see the full width, and only have to scroll down to continue reading

Update: RM (Renee) has acknowledged this has been reported. She added
…Try resizing the panel by moving the divider between the edit note panel and the details panel. It should trigger all the text to display. …

Which unfortunately didn’t work for me but might for someone

Lorna - you are correct and it’s not your fault at all. The notes editor seems a very “young” piece of code that hasn’t got all the bugs ironed out of it yet PLUS the apparent desire of RM to “roll their own” versions of things means that they have not taken simple advantage of the conventional and commonplace and familiar ways of working with a keyboard. This is very frustrating to ANYONE who has ever used a Windows program before.

Continuing to have trouble with the text editor for Notes. I’ve learned some of it’s annoying behaviours and tried to adapt but it still messes me up. I’ve lost track of the times I have typed part of a note, switched apps to check something or copy some text and come back to find … nothing. I’m now hitting the “save” check mark (annoying non-standard convention) every time I think of it and I still find the Note has disappeared when all I did after saving was go to add a new fact to the person then back to check the text I had just typed. Had to type it ALL OVER again. Has happened LOTS.

Why can’t you just buy a normal standard text editor package and integrate that in to RM8? Rolling your own may be fun for the programming staff but it’s a royal pain in the keyboard for the user community.

This could well be why when I copied from a note in RM to paste back into TMG I was told unrecognized format

This is just one of many frustrating “features” of RootsMagic 8. I don’t have much hope that it will be improved.