Treeshare with Ancestry no longer Works

This has been going on for a couple of months. I simply can’t get Treeshare to work anymore with RM8. It is my main reason for using RM8. I am thinking of ditching RM8 if it can’t be solved.

Has anyone had this problem? Has ayone had success in solving it?


CTRL+Shift+U will reset RM. My TreeShare works fine now.

Thanks MadDog but No, that does not work. I still get the same screen per screenshot above after having done CNTRL+Shift+U and selecting reset, then exiting and relaunching RM8 and going to Publish and try login to Ancestry. Any other options?

Can you access Ancestry directly rather than through RM, if so, are your credentials for signing in through RM the same?
Do you use two-step verification?

Take your database out of MyCloud. RM will not work with NAS. SQLite is not a network database. It needs the database on a local drive.

I can access Ancestry directly but the same credentials do not work with RM8. I do not use 2 step verification.

My database has been on my MyCloud for several years with no previous problems.

It works fine with FindMyPast hints, FamilySearch and MyHeritage just not Ancestry (for the last couple of months).
I will copy the database to local disk and try that.

I put a support request in but they were useless, they told me Ancestry were having problems and I should try again later. After 50 or more retries over a couple of months, no go.

Just to compound things Ancestry Treeshare works OK with RM7, but of course all my work over the last year is in RM8 and I don’t think the database is backward compatible.

I copied the database to the local drive and tried again. Same result for RM8. I show screenshot that also shows I can logindirectly to Ancestry.

I show a second screenshot that shows that Ancestry Treeshare is working fine with RM7 (same computer and login).

Check that you have update installed under Home, Updates or the 3 dot menu, About RootsMagic.

Have you tried Ctrl+Shift+U , Reset Program Settings to clear it?

If you don’t have two-factor verification turned on then the issue is somewhere in your security software. RM8 is looked at as a separate program from RM7 in your security software.

Yes I have installed. I tried CNTRL+Shift+U to reset program as stated above. It made no difference. I have had Norton 360 for almost a year, but this suddenly happened a couple of months back.

I’ve contacted Norton and they got me to disable the Smart Firewall and try again. No difference. They claim their firewall cannot be causing the problem. I looked at the detail settings in the firewall for both RM7 and RM8 and they are both identical with “Allow all traffic to and from internet”. Plus of course no issue with FindMypast, My Heritage or FamilySearch from RM8.

I don’t know where to go from here. I tried uninstalling RM8 and reinstalling but that made no difference.
Is there a way to interrogate the database or something to see if it has “switched off” treeshare or link to Ancestry?

I looked at Ancestry help and they don’t even acknowledge existence of RootsMagic or Treeshare.

Have you tried creating a small test database in RM8 and then using Treeshare to create an Ancestry Tree?

What other security software do you have installed on the computer?

John, I can’t login to Treeshare so there is no way to create an ancestry tree from any database.

rzamort, there is no other security software installed on the computer. The Windows Firewall says it is controlled by Norton 360.

Here is my attempt to create a new file from an Ancestry Download:

Do you have anything else like Malwarebytes or BitDefender on the computer?

When chat opens again this week get on and we can have an agent remotely check what maybe blocking RM8 access to the internet. Chat’s are open Mon-Fri 8:00-4:00 (MT).

No I don’t use BitDefender. I have run Malwarbytes as standalone from time to time in the past, but it is not in the Programs list anymore as I uninstalled it. I’m thinking this “Ancestry API” which I have heard about may be a problem, but only for RM8. As I said RM7 works with Ancestry. But funnily enough since the last time I did a Reset of Treeshare, I no longer see MyHeritage hints either, despite Enable MyHeritage hints being ticked

. Only FamilySearch and FindMyPast which both work fine.

This is probably nothing to do with the Ancestry API, otherwise a lot of people would have the same issue.

As for MyHeritage, noone is seeing hints and haven’t been for some time now.

Thanks for clarifying MyHeritage hints missing and Ancestry API.

The problem I have been having is on my laptop (everythig above).

Now I’ve set up RM8 on my Desktop (same version Win10) and **it works with Ancestry, both Ancestry Hints and Treeshare

.** Now I’ve checked and I am using a copy of the same Database (on my WD NAS Drive, which I was told above would not work). Laptop has a local disk copy of the same Database. Same size, no of people, records etc. I have vigorously checked every setting in RM8 and they are identical Desktop to Laptop. On the Desktop I have not installed version of RM8 (too scared) whereas Laptop has version

Both machines have Norton 360 same version. I did not have to disable firewall for Desktop. Laptop has no Malwarebytes. Desktop has Malwarbytes, but only runs when specifically invoked (no automatic scans).

Now I am even more confused. See screenshot from my Desktop:

This is baffling. My Laptop has a lot of other software (photograpy and video mainly), but I am stumped why I can’t get RM8 and Ancestry working on it.

I have discovered one difference. My Laptop is running Win10 Home 22H2 19045.2251 whereas my Desktop is running Win10 Home 21H2 19044.2132 (Older version).

Off topic, but is it wise to disregard the developer of the SQLite database engine who has warned against using network storage? Yes, it can work but at greatly increased risk.

1 Like