TreeShare broken

I’m confused why Ancestry TreeShare isn’t working with RootsMagic 9 on Mac. For example, I’ve made changes in an Ancestry tree today, and then gone to TreeShare. The software says it’s syncing with Ancestry, but it doesn’t pick up on any of the changes that I’ve made there. Is anyone else having this problem?

I’ve also been having issues with media being correctly associated and downloaded from Ancestry.

Family Tree Maker is having issues as well.

They say they are preparing an update to ‘handle the changes made on Ancestry’s side’. This was almost a couple of weeks ago, and they said it would be ‘a couple of days’. Yet update is still not available, and sync is still entirely broken.

The developers are in Ukraine, so we may cut them some slack as things are far from normal there. And even seemingly simple fixes can prove more challenging than expected.

I will also check to see if I have TreeShare issues (also on Mac), though I find the feature cumbersome and usually just make changes on Ancestry and then periodically create a new tree in RM when I want to check for errors or generate a report.

Are the Ancestry developers in Ukraine? Or the ones for Family Tree Maker? The RootsMagic developers seem to be US-based, as far as I can tell.

FTM developers are in Ukraine. Ancestry developers are US based.

I only ever TreeShare up to Ancestry. I’ve done so several times today without any problems.
I’m on a Mac, using RM 9.0.7

I wonder if I’ll have the same issue, if I try the reverse. I’m off to do that now.

I just tried doing the reverse, sending data to Ancestry, instead of downloading data from it with TreeShare. The following is what happened:

  1. The whole program froze and I had to Force Quit out of it.
  2. When I restarted the program, it chose to connect to TreeShare this time, but alas, did not recognize any changes in Ancestry or in RootsMagic. It then gave me the following database error: “SQLite Error 1 - no such database: RMDB.”

I’ve verified that the family tree I’m trying to connect to, which is the same one I always use, is indeed in Ancestry.

I’m using RootsMagic on Ventura 13.2.1.

ETA: Although the database integrity tool tells me that my database is fine in RootsMagic, I do worry that the frequent crashes of the program in a Mac environment are not good for the overall database.

Your os is not current ventura 13.5.1 with .6 coming. Look at Macupdater free/paid which automatically checks for updates to all your software.

FTM/Mackiev is in the Ukraine but when they annouce an update or print manual, etc in 2 days it usually means 2 months. FTM sync has been broken 5 months but RM9 sync has worked “normally”.

Considering that 13.5.1 fixes a location permission in System Settings, and my RootsMagic was working fine about a day ago, I’m not sure it will fix the issue. But I’m happy to update to it and try.

After updating, I’m sorry to report that updating did literally nothing towards fixing TreeShare.

Go to File, Tools and run all the Database Tools. Then go to Settings, WebHints and click on “Reset TreeShare” and see if that helps.

Resetting TreeShare seems to have gotten it to connect to Ancestry again, but now, it’s only showing me the changes that occurred to people in RootsMagic. Although the people who changed in RootsMagic exist in my Ancestry tree, they are not being matched against their corresponding Ancestry person. When I click on “Show Matches”, it shows no one available as a match. This is frustrating, to say the least.

If you have “Only show changed people” checked at the top remove it so it shows everyone. Then check if you have matched duplicates which would cause no matches to appear for the unmatched person.

I was able to update FTM today. I think they are pacing the email notification to avoid everybody synching to Ancestry on the same day.

From what I can see TreeShare doesn’t work on Mac OS Ventura, even the latest. Works fine on earlier Mac OS versions. I can sync the same database on Mac Pro 2013 in a few minutes (At least the gather changes part, not the hours of clicking). The same database on some hefty Macbook Pros running Ventura stalls about 35%.

Works for me. Running MacbookPro M1 with latest Ventura, I just downloaded a 600 person/600 image tree with no issues. From what I have observed, the problem of Treeshare hanging has pretty much been proven to be an ancestry API issue related to load on their servers. A person’s slow internet connection is also a possibility, though less so these days. I suspect there’s something else going on if your Ventura system is having problems.

How are you making sure its the same database? Have you checked the security software to make sure its not blocking RM’s access?

Yes, exact same database. Literally. It’s the same iCloud directory. And before all the cloud storage haters jump in and say that’s the problem I’ve been running this configuration for YEARS. Worked fine on 7. Worked fine on RM9. The only change is the OS version on the MBP, and now of course the new MBP.
All three are on the same network so it’s not internet speed. (gigabit fiber BTW)
I need to do a loom video to show the speed difference.
Obviously since the bulk of my work is on the older Mac Pro I’m not crippled by this issue , but it stalls on the MBP at 35% like clockwork. Sometimes a few retries will get it to 50%.

1 Like

I do think it’s good news it’s working for some. That said, 600 is an average merge for me with adds/ changes out of the now 20k some odds have in my db. It seems to stall at roughly 7000 so I’d really be interested in people successfully using TreeShare on Ventura with a db that size or greater.
My assumption is some libraries need to be updated, since it works fine on earlier OS’s.

1 Like

Right. All kinds of strange things get introduced at scale.

I use a iMac desktop running vers 11.6.5 Big Sur and I haven’t yet been able to get RM9 to download my 26000 people and media file from Ancestry or to complete the TreeShare. I can download and sync all my smaller files from Ancestry of hundreds of people fine. I can also download and sync to relatives Ancestry files (who have given me Edit status). They all work fine. Just the large file. RM9 process bar always reaches around 90 something percent and then jams up. I have just downloaded the new update for the Mac and the sync bar reached 99% and jammed.
My windows laptop and desktop go through the downloads and sync far faster than the Mac and complete everything correctly.
I can only load up my 26000 people file on the Mac by using a backup from the Windows machine - then I can use the database fine.
The 26000 people file is a copy of my cousin’s tree on Ancestry and I have exactly the same problems downloading or syncing to his tree on the Mac.
Does the Mac software run in a container or is it fully compiled for the Mac. The slow speed to me indicates that it runs in a container.