TreeShare of large file on Mac causes RM9 to hang

I’m trying to download a 20,000+ person tree from Ancestry. I either get a spinning beach ball or the download will start, get some percentage of the way through and then pop a message that Ancestry is not responding. Clicking Retry cause RM9 to hang and need a force quit to exit.

Open a support ticket and share your tree with an agent. They will test if they have the same issue with the download.

Hi LarryD, I’m experiencing the same problem(s), so please do post your progress to this thread. I have 12 Ancestry trees and, when trying to set up TreeShare, I’m getting the following.
a) Four trees with fewer than 100 people, fewer than 250 media items, all complete TreeShare OK.
b) Seven trees each with 400 to 900 people and 800 to 1,700 media items, all stall while “Downloading media items”. However, when I close that window, TreeShare has worked and I can see people, places, etc. but WITHOUT about 50% of the media items that are on Ancestry for that tree.
c) My final tree with 4384 people and 9048 Media items won’t complete TreeShare at all. It stalls at Downloading tree and doesn’t even reach Media items. Even after RootsMagic accessing my tree on Ancestry and sending me a BackUp to try. They say they can get TreeShare to work on a Mac mini for this tree, so I’m confused why it won’t work on my MacBook with either Ventura or Sonoma. They’ve suggested I divide the tree to see which sub-branch(es) will work with TreeShare.
I’ll post again here once I’ve done that.

1 Like

Hi John,
It appears that RM spins off the media download, so you may have access to your tree before all media has been downloaded. That is not saying there still isn’t an issue where it doesn’t complete.

I suspect I will do as Rene has asked, but I had an issue with citations under RM8, gave access to my Ancestry Tree to an RM agent and then never heard back from them again. I don’t have high expectations for the process.

Unfortunately, my MacBook Pro is 5 years old. It has a fast Intel processor, but perhaps it’s not fast enough to keep the connection active. RM9 is slow to load and runs slowly on my MacBook. I fear that whatever tool RM uses to generate both the PC and Mac codebase does not create efficient code for the Mac. I’m ready to give up on RM.

I’m using a nearly new MacBook Air - now running Sonoma - with a Cat6 cable coming straight from a new Virgin Media Hub 5 serving Gig1. I’m curious that the stalling happens at the same % point each time, on a given tree. As if the download is being impeded in some way. Which might support your inefficient code for Mac theory. And it’s been the same at a relative’s house (so not exclusive to my Internet connection). There does appear to be something in the download process (if not the code, is it to do with Media Item Type? File size(s)? or something else in each database?) that causes the stall. But that wouldn’t explain why my largest tree doesn’t even get to “Downloading media items”. Hopefully someone at RM (or another user) has worked out what’s causing these stalls and can share the resolution.

1 Like


I contacted support. They said the Windows version works when the Mac fails and offered to download my tree and send me a link to the file. While that is appreciated, it doesn’t resolve the issue.

1 Like

I gave RM support editor access to my largest tree on Ancestry and they sent me a .rmbackup of it. I could use it to “create a new RootsMagic file” but TreeShare still stalled consistently. They said they could get TreeShare to work with that database on a Mac Mini, so couldn’t replicate my issue. So that still doesn’t explain why I’m (we’re) having the issue.

1 Like

On an M2 Macbook Pro with a 400 person 1GB media tree FTM would sync down/up with no problems while RM8…9 would stall on the same 1GB connection. Smaller trees would usually work.
RM uses Intel only code requiring Rosetta translation on current macs and the code to port to mac was done in-house by windows people. I think RM has a timeout issue and drops the process after a certain time.
The macs tech support are using may be older intel models and not behave like more recent macs.

1 Like

Rooty, Mine is an older Intel Mac and has the problem with larger file sets. Also, RM runs extremely slow. I suspect the tool used to generate the MAC code (even for Intel based systems) does not create very efficient code.

1 Like

I’m sorry LarryD but that was sloppy support. They needed to test the download on the Mac to see what is happening. Obviously, the Mac download works for many of our users. The issue isn’t Windows or Mac its something that is setup differently between computers. One may work where the other won’t. What the exact issue is on one computer over the other has been extremely hard for us to determine.

What I need for development is a small Ancestry tree that will fail when downloading on one of our computers. That is one reason we are testing the downloads. That’s been very hard to find since it will fail on one and not the other.

1 Like

Hi Renee, I have smaller trees on Ancestry, but they all download fine. I have 2 trees around 20,000 people that both fail on my MacBook Pro. I am happy to give you access to either or both if that will help resolve the issue.

Open the support ticket back up and share the tree with the agent so they can do the download.

Ticket reopened and invite sent.


1 Like

I’m having a similar problem, look at my thread on an earlier message about Treeshare. RM had an issue creating a database (separate one from your .r tree). I have all the details in that thread. Once you have that file on your machine Treeshare will work. Why RM closed my ticket I have no idea, but they have a real issue with large trees and TreeShare on a Mac. I had the same tree would work on one Mac, but not any others. One I copied that tracking DB to the new MC everything worked.

Hi Keith, are you referring to the “TreeShare broken” thread? I posted there too. Other than several of my smaller trees for which I can’t get RM to download all of the media, the only solution I’ve been offered for my largest tree (for which I can’t get TreeShare to work at all) is to split it into parts and see which will complete TreeShare. I haven’t had time to do that yet. RM accessing my tree on Ancestry and sending me a .rmbackup didn’t result in TreeShare working on it - for me.

Look at “Need quick login to Ancestry”

I have two tickets you can reference 129070 and 129790

1 Like

I’m also having problems with TreeShare. I have the DB captured on OneDrive and recently switched from Windows to Mac (MacBook Air, Sonoma 14.1, M2 chip). Even after the MFA login challenges are over, I get to 94% sync and it freezes. According to monitor, using <1% CPU, 20 threads, etc.
This time I got the popup “Ancestry not responding” but the TreeShare window stays open.
When it hangs, I see about 504 open ports. Is it possible it’s not recycling the connections efficiently causing Ancestry infrastructure to hang up?

Is there any way to enable debug logging so we can see where it hangs? I’m happy to capture the Sampling or Open Files & Ports if that will help.

If “monitor” means activity monitor that app does not combine threads to show real cpu usage. istatistica and similar apps show RM9 uses 10-20 %cpu at idle (MBA 15 M2 24G Ram). RM9 hangs for me on my 400 person file while FTM zips along just fine.

Apple begs to differ with you.