RootsMagic 9 not showing any Ancestry hints

RootsMagic 9 can’t find my TreeShare file in Ancestry. I have gone to Publish->Ancestry TreeShare then get a message saying connected tree not found with further information: “This file is linked to an Ancestry Tree, but your login doesn’t have access to that tree. There are a number of possible reasons: 1. The tree has been deleted from Ancestry 2. The tree is owned by someone else and isn’t shared with you anymore 3. You are logged into the wrong Ancestry account 4. You are not connected to the internet” I have loaded my tree to Ancestry (before ver. 9) the name is slightly different than my RootsMagic file name, is that the problem? Thanks for any help you can give.

Renaming the database or Ancestry tree will not cause it to be disconnected. Have you check the other possibilities listed yet?

As I understand, your tree was loaded to Ancestry before version 9-- was it from RM 8, RM 7 or another program?
@rzamor1 would it make a difference IF it was a RM 7 version tree ( a rmgc file instead of a rmtree file ) or a tree imported from another program?

If you have more than one database on Ancestry, I would check to see if that is the one you are in or if you are in another sent by a friend…

Check your settings in your RM 9 database for web hint settings under the light bulb to see if everything is checked and you have the correct domain-- if so, then click on RESET TREESHARE and then try Ancestry again
Let us know either way if any of these work…

The error ‘questions’:"
1.) my family tree is still in Ancestry
2.) the tree is owned by me
3.) How do I know what tree RM 9 is looking at? Maybe I don’t have one linked to it? I have a couple of self-owned trees and a couple trees owned by others in my account.
4.) Internet is working

I have checked the boxes as you show. I am pretty sure that the Ancestry tree that I want used was uploaded as a GedCom. I don’t know where to link RM 9 to the proper Ancestry tree. I have saved things to both trees (not necessarily the same items however) so don’t want to mess things up in my Ancestry tree. (I use RM and, mostly, use Ancestry as a place for hints on my family - then enter data & sources into RM and not always into Ancestry. I hope this makes sense.)

If you go to Ancestry, look at your home page and you will see this box at the top

you can change that to any tree you have access to BUT not sure that is going to make a difference in this case…

I had your exact same problem the 1st time I tried to use Treeshare–I had NEVER USED TREESHARE EVER-- let me repeat that NEVER TRIED IT BEFORE…
I think the reason I couldn’t access treeshare by way of RM 9 was because the files on Ancestry were from other people ( but I did have the ability to make changes or add info on some) – none of these were in my RM 9 file–and I had one of my databases on Ancestry BUT it was NOT in RM 9…
My solution was drastic and I doubt you want to do it based on what you said
@rzamor1 – would SUPPORT be able to help her link RM 9 and Ancestry?

Hello nkess, I don’t have the same view at all on my home screen of Ancestry. This is mine. I did click on “Go to tree” and it does go to the file I want RM to use. Like you, I have never used TreeShare. Maybe that is my problem too!

You said you had other trees on Ancestry–some from others, so I am surprised, you don’t show a drop down menu BUT maybe the difference is that I have editor permission on my other ones…

IF you have NEVER used treeshare before then that is indeed the problem— perhaps try making a test database in RM 9-- just drop and drag a few of the individual into a new database-- MAKE SURE YOU NAME IT TEST!!!

Make a gedcom of the test database ( save to desktop for easy access)- upload it to Ancestry by way of gedcom-- this will at least give you a RM 9 file on Ancestry-- make sure you are viewing this test gedcom on Ancestry— and that you have your test database open in RM 9—then hit RESET Ancestry in SETTINGS and see IF it will let you into treeshare…
Doubt if it works and even if it does, it may NOT let you access the file you want BUT the 1st thing you need to solve in my opinion is access to treeshare.

To upload/download and connect RM to Ancestry use TreeShare by going to Home>Download A Tree>Ancestry.

OR if a RM file is open … hit the Ancestry Icon at bottom and Upload

Thank you. This is what I have tried, then gotten the four question error message that I typed in my original post.

I see I left out the part to Rename RM database and Upload with the New name to Ancestry.

If she renamed it with the exact same name as the database, then would that let her connect to the database already on Ancestry-- @rockeman has 2 problems

the 1st problem is that she does NOT want to lose the Ancestry database now online-- nor the RM database she now has as each has info the other doesn’t have in it…

the 2nd problem is that she has never used tree share before and the database that is now on Ancestry was uploaded as a gedcom NOT AN RM 9 file–so she is locked out of treeshare which was my problem the 1st time I tried to use treeshare and nobody could tell me a way around it.

No, nothing is going to let her connect her current database to the Ancestry database, unless she can figure out where in the database the link to an Ancestry tree is, then figure out what exactly that link looks like, and then manually add that to her database. I don’t think anyone has ever tried this.

About the only choice here is to Treeshare down her Ancestry tree, do a side by side comparison with her local tree, dragging and dropping as much as she can into the newly downloaded DB from Ancestry, the using Treeshare to update the Ancestry tree.

This is the only thing that will work. Forget about the gedcom nonsense and use Treeshare. Watch the RM video on how to Treeshare.

I click on Publish then Ancestry TreeShare then I get the error in the original post. I can’t even download a new treeshare. I am signed into Ancestry. Any other ideas?

I am not sure what tree RM is looking for in Ancestry. I am logged into Ancestry (in RM), go to Publish, then Ancestry TreeShare. I then get the original list of possible errors. I have no idea what tree RM is looking for as I don’t think I have ever used TreeShare. BUT, I can’t do TreeShare because I get these errors.
ERROR possibility reasons (as listed on the error message):

  1. I don’t think I have deleted a tree from Ancestry, but I don’t even know what tree RM is looking for.

  2. The tree should have been one that I own.

  3. I don’t think that I have more than one ancestry account.

  4. I am connected to the internet.

I was so looking forward to the hints but this is frustrating me. Thank you in advance for any help you can give. Annette

Re: #3 - When RM connects successfully you’ll see a “Connect To Tree: <Ancestry tree name>” message in the top left corner of Treeshare. There is no way for you to determine what Ancestry tree your RM file is trying to connect to when it’s unable to connect.

Basically, if the answers to 1,2,3,4 don’t identify the issue then some corruption has occurred. Since RM is your main program and your goal is to get ancestry hints again, the path forward is to break the existing treeshare connection and establish a new one. (Note: this will forever break the connection between your RM db and the ancestry tree that it used to be connected to … so be sure to do step 1. That way you can restore your RM database with the current connection (albeit broken) if you are not happy with results.)

  1. Backup your RM database from within RM (File, Backup)
  2. Disconnect your RM file from ancestry (go to Settings, Webhint Settings (lightbulb), and select “Disconnect from Ancestry Tree”
  3. Connect to ancestry via Treeshare and Select “Upload and Connect” to Upload your RM db to a new ancestry Tree. You can make this tree private and use it for hints only or make it public if you are sharing it with others.
  4. When you use RM, log in to ancestry via treeshare to get hints flowing.

Note that the status of your prior hints (rejected, accepted, etc) has been wiped out by the disconnect process so you may see hints that you’ve rejected in the past.

The Ancestry Tree information comes from Ancestry, so RM cannot show it until you are logged into TreeShare. Restoring a backup made before the disconnect will establish it again.

1 Like

Thank you. I did this so will now wait to see if I get any ancestry hints in RM.