Ancestry TreeShare Error

Hello All,
For the very first time I have tried to use Tree Share and when I enter my login information it gives me this error: Rootsmagic this file is linked to an ancestry tree but your login doesn’t have access to that tree.
I only have one account at Ancestry; anyone have any ideas about why the program won’t connect to my account?
Warm regards, Robyn

TreeShare for Ancestry - Connected Tree Not Found - RootsMagic - RootsMagic Community

If you login with the wrong account from what the tree is connected to it will give that message. If there is a chance it’s connected to your Ancestry tree then try switching from using either the username or email when logging in.

The connection to an Ancestry database is preserved in drag n drop, GEDCOM and backups. If you received the database (or part of it) from another RM user the connection to their Ancestry account/tree may still remain. That is why you cannot login with your account in that database. Go to Settings, WebHints and click on “Disconnect from Ancestry Tree” to remove the link to that account and tree.

Thanks to you both for your responses. It was a completely newly named tree I created (within the software), and it was also using a RM file saved to OneDrive. It still never worked. Could either of those be the reason why?

When I disconnected from Ancestry with no tree opened from within RM, it connected to my Ancestry account and presented me with the choices of the trees I have there.

Also, if we import a tree from Ancestry, I notice RM did not download the attached census and other images. It does download anything in the Media gallery. I thought it would also import the images themselves–is that inaccurate?

Reading some of the threads here is making me rethink even utilizing this feature.
Appreciate all the knowledge and wisdom you folks have.

Did you try the login switching between the username and email address? If you had an Ancestry guest account using one or the other and then got a paid account it maybe struggling to log you into the paid account. Downloading a tree and receiving no media could be an indication you are on a guest login.

The only problem with that is that I am unaware of any other account that I have ever had. I have only ever logged in with a username, but perhaps I had one years ago that I have forgotten about? I will do more sleuthing.
BUt the fact that it works just fine as long as I don’t select a tree first in RM–wouldnt that suggest it’s not the account name but something else? No matter what I do it only downloads media items, not attached census records.
I thank you again for your suggestions.

Assuming that by “attached census records” you mean the census images, I wonder if you have looked at media used by the Citation. You won’t see a checkmark or count in the Media column by the Census or Residence event. You have to open up the Citation itself and slide in the Media panel to see the attached census image.

You should also be able to see all downloaded census images in the Media main view.

Hi Robyn, You’ve gotten some good feedback already. I will focus on a few things that you mentioned that have not been covered.

The recommendation from RM is to save your RM database file on your local drive. You can store backups on OneDrive. It’s possible that your database could become corrupted if you store it directly in the cloud. There are many other posts that discuss this topic of local vs cloud storage and it doesn’t appear to be a factor in your current issue, so I’ll leave it at that.

As I read your posts it seems as though Treeshare is working as it is supposed to and, since you only had 1 ancestry login, the issue is most likely that your RM file was somehow connected to an ancestry tree that you no longer have edit rights to.

If you know which ancestry tree you want to import and you now have that option, then I suspect that your issue will be solved with Tom’s suggestion. You should find census media attached (or tagged) to the citation. Typically Ancestry considers census data a “Residence” event so that’s the way it will appear in your rootsmagic file.

Also, you cannot connect an existing RM file to an existing Ancestry file. Rather, you need to export (upload) your RM database to a new ancestry tree or import (download) your Ancestry Tree into a new RM database file. If your Rootsmagic file is more complete then you will want to push a new tree up to ancestry. If your ancestry tree is more complete then the new RM file you created should be the one you use going forward. I hope that makes sense.

Finally, when you create a new RM file by importing a tree from Ancestry via treeshare, media gets download into a single folder in the same directory as your RM file. The folder is named <your RM file name>_media. If you end up downloading multiple attempts make sure you name the RM files differently or you’ll end up with multiple versions of your media files. It’s quite possible to end up with multiple versions of media files over time just by the way that treeshare works. I’ll leave the discussion of handling media downloaded via treeshare for a future discussion. Again, hopefully Tom’s suggestion will solve this one.