Ancestry TreeShare failure

Firstly I would explain that I am new to RM9, but I have loaded into RM9 two databases from mu Ancestry account without problem.
I have been happily dealing with the “Problem” facility and updating Ancestry as appropriate. I have also been able to use TreeShare to sync Ancestry with RM9, but all of a sudden TreeShare has stopped working for one of my databases. Each time a go to TreeShare it comes up with the twin screen “Upload and Connect”/“Download and Connect”. I can’t use this option as the tree already exists in Ancestry and RM9.
The other database works fine with TreeShare and connects with Ancestry without problem.
Is there a way I can overcome this problem short of deleting this database in RM9 and downloading again from scratch from Ancestry?

Thanks fro any help offered.

Have you tried Settings>Web Hints>Reset Treeshare?

It’s been suggested to Restore a backup that will re-link. Haven’t tried it but …

I’m sort of summarizing what others have already said, but something has happened that has disconnected the RM database from the Ancestry tree. I don’t know what that something is.

The only two solutions are to download again from Ancestry to a new RM database, or to restore the RM database from a recent backup when it was still connected. In other words, an existing RM database and an existing Ancestry tree that are not currently connected cannot be connected in the future. The only way to connect is to download an existing Ancestry tree to a new and empty RM database or to upload an existing RM database to a new and empty Ancestry tree.

1 Like

Thank you, yes. I should have mentioned that in by original post.
It had no effect.

Sadly, I hadn’t at that point taken a copy.

Thank you for your summary. That was something I was trying to avoid as I am on a slow ADSL link and it takes hours to download, but it looks as though that’s the only option.
No very encouraging though when one tries a new piece of software.

I have been whinging about Tree Share for years.

If Ancestry is your main tree, just use RM as a backup.

Download Ancestry tree to a new project after you have made changes to your Ancestry tree.

If you do not and use Tree Share you end up with a whole mass of changes, each requiring a painful acceptance process.

I have given up trying to Tree Share, it is useless

I should explain, most of my research is via my iPad, I do not want to spend hours sat at a PC, I want to research in comfort.