Unable to Download and Connect Ancestry Tree using TreeShare in RM9

I have attempted three times now to download and connect my family tree from Ancestry to RM9 using TreeShare. The download occurs (after many connection errors and retrys throughout the process) and saves the file to my computer, but it isn’t found or connected to my selected file within RM9. I am wanting to be able to add and match people from my RM file to my family tree in Ancestry. What’s wrong?

When you download via TreeShare, you now have a new database. It is not connected to your existing database. Hopefully you have 2 different names for them. Use the Compare feature between the 2 for adding/matching.

I was expecting it to work similarly to the FamilySearch match/add icon. When I click the Ancestry icon it simply asks if I wish to upload or download from Ancestry. This is obviously something I’ve already done. Originally I had selected to upload my RM file to Ancestry before I realized that wasn’t really what I was wanting to do, but at least when I did that I was told that my RM file was connected to a tree in Ancestry until I deleted it to try and download instead. I have been successful in past RM versions to create a GEDCOM of my Ancestry tree and upload, I assumed TreeShare worked different from that approach and would allow me to match and add more easily between the two applications.

Ah. Treeshare kinda works like FS in so much as when you add to either the downloaded file or on Ancestry, you will get the “changes” when you Treeshare. You find a census for someone on Ancestry, Treeshare and you can add it to what is on your computer. Check out the video on Treeshare.

I am still left with the fact that I have attempted multiple times to download my Ancestry tree into RM9 without success. I have followed the steps given in RootsMagic help. I was able to select the tree from Ancestry that I want to download and have gone through the whole download process. Each time it has been saved to my computer rather than a file in RM. According to the help screen, when the download is complete, I will see the TreeShare window. This has not happened.

It doesn’t download into your existing tree. It will download as a new tree/file. You will have to do a compare as @MadDog said to see any differences. If you want to download what you want to coordinate between Ancestry and your tree, you will have to be in the downloaded file. Go to Publish, and click.click on Ancestry Treeshare. The changes between the online tree and your download will show.

Unless you are downloading a GEDCOM from Ancestry, then it absolutely is NOT saving to your computer instead of Rootsmagic. This simply is not possible. To use TreeShare, you have to create a blank RM database and institute TreeShare from RM. When done, you will have a RM database file somewhere on your computer (specifically where ever you designated it to go when you created the blank RM file).

If you are indeed downloading the Ancestry tree via GEDCOM, then this will need to be imported into a RM database otherwise it will just be a file living somewhere on your computer. If you are downloading a GEDCOM file, you will lose any media attached to the Ancestry tree, which is why you really need to learn to use TreeShare as it will bring down the media to you local machine.

My 4th attempt at downloading my ancestry tree using TreeShare was finally successful. I didn’t do anything differently so I’m not sure why it finally worked. I then just deleted the other three files that had saved to my designated computer file.

1 Like

Great. I’d recommend you watch the video on Treeshare.