Log in to FamilySearch and Ancestry

Sign in to Ancestry does not work from RM8. Login to FamilySearch does not work.
Both are buttons i Family Search central and TreeShare for Ancestry.com but pressing these buttons (for Log in and Signin) do not give any response - at all.
How can I log on to both?

2 Likes

Both FamilySearch and Ancestry works fine on their websites but I cannot connect from rm8. Any suggestions? Does it work for others?

2 Likes

Using RM8 I’m able to login to FamilySearch and access matches without an issue. However I too am having problems with TreeShare. It logs me into Ancestry and just sits and sits and finally begins to work on matches, hitting anywhere from 11% to 18% before it errors out with a Runtime error 217.

I was using RM7 early this week and TreeShare was not working at all – attempts to login resulted in Ancestry Not Responding.

I have the same issue with TreeShare for Ancestry.com.
I have reported this more than once and could really use this feature.
I also noticed that the Mac version of RM8 is 64 bit and Win version is 32 bit.

For FamilySearch, the Log in button should produce a pop-up, like this:

afbeelding

But I have no idea why that one does not appear on your system. You may try Alt-Tab, or clicking the RootsMagic icon in the taskbar, to see whether the window may be hiding behind another one.

For Ancestry, the behavior should be similar, with subtle changes in the pop-up, of course.

I am having the same issue with trying to login in to Ancestry. Initialy the sign in button would open, but it would never accept my login details for Ancestry even though they worked when I signed in directly to Ancestry out of RM8. After several attempts to sign in the sign in button became a dead link with no response at all.

1 Like

I’m able to connect to share information with Family Search, but it doesn’t always transfer correctly. I haven’t even tried Ancestry yet, because of the issues the 2nd poster mentioned.

Sometimes copying ordinance dates from FamilySearch into RM8 works, and sometimes I get an error message about the mouse pointer being incorrect, or something like that. On the Share Data tab, I can transfer information from my file to FamilySearch, but it doesn’t refresh immediately and show up in the correlation window; if I go to the FamilySearch website, I can see that it did in fact transfer. I have not been able to get information to transfer from FamilySearch to my file in RM8.

I am also having the problem with Ancestry and FamilySearch. I tried both suggestions (Alt-Tab and RootsMagic icon on the taskbar) and neither worked, but also I found that neither showed the Ancestry window nor the FamilySearch window.

Publish> Family Search Central> Log in and nothing. No pop up box, no ability to sign in, nothing

I can log in to TreeShare from RM8 by providing my Ancestry login credentials, but it compares my RM8 people to the people on the WRONG Ancestry tree. And I can’t figure out how to switch which Ancestry tree gets used.

I’ve looked in Settings with no luck, and when I click on the ‘View tutorial videos and help on using TreeShare and WebHints for Ancestry’ link, it takes me to a 404 error page.

UPDATE - I fiddled around a bit more and then discovered that if I completely unlink my TreeShare tree and Ancestry account in the Settings, and then re-create a new tree, I can connect to a new tree. Odd way to do it, but it worked.

1 Like

Please clarify: are you saying that you can unlink your current tree (assuming it is the correct one) and relink the same tree and now you have access to Ancestry including web links?

For me, I’ve been able to access Ancestry by logging in via RM8 ever since I installed it this morning. My problem was that it was bringing in data from an old tree that I no longer use. In order to connect to the tree I wanted (and actually what I ended up doing was just straight-up creating a new tree from my RM DB), what I had to do was, in the WebHint area of Settings, choose these two things.

image

Once I had disconnected from the old Ancestry tree I didn’t want, and reset TreeShare, I was able to re-login to Ancestry and do what I wanted. I think it would have allowed me to connect to any of my trees if I wanted to do that, but tbh I wasn’t paying attention because what I really wanted to do was create a net-new tree. So unfortunately I have no experience with what happens when you disconnect everything and then try to link again to the same tree.

Does this help at all?

I attempted to Login to Ancestry, from RootsMagic8, but it failed. I think the cause is the 2 Part Authentication, that I have turned on. No place to Enter the Code in RM8

There is a new version. Does that help?

I just noticed that on a new install on an other PC, when I instruct RM 8.0.1 to create a new file with data from FamilySearch, it also starts the same dialog. There may be more tricks, like entering name and password in the Webhints settings, for FamilySearch.

What looks quite odd to me is, that I’ve taken part in the public preview, and never had this problem, testing on all sorts of systems, all running Dutch Windows 10.

Here’s another trick. When I click Share data in the FamilySearch Central window, the program also shows the Log in dialog when I am not yet logged in.

RM 8.0.1 resolved the problem I was having.

3 Likes

Today I tried again to use TreeShare and this time, after logging me in and sitting for a while, I received an “out of memory” and RootsMagic closed. I attempted this again, monitoring memory usage in Task Manager and had the same thing happen when RM8 hit a little over 1500 MB of memory usage. At this point my PC’s total memory usage was at 37%.

This program closing affected only RM8. I had Firefox (with 4 tabs) and an Excel file open and these continued to run after the message. I do not want to modify the registry to attempt to resolve this issue so I’m hoping RM and Ancestry can get together to resolve whatever is causing the problems.

I upgraded to 8.0.1 and now it works perfectly. Thanks for the fix

1 Like

Just updated to 8.0.1.0 and still no success with logging into Ancestry.

I had the 217 error. I ran sfc /scannow which found some errors, and dism /online /Cleanup-image /restorehealth, but for Rootsmagic there was still no joy on trying to connect to Ancestry. The thing I did that seems to have fixed it is repair Microsoft Visual C++ You just go to control panel and choose programs and features, where it says to install/uninstall programs. You are NOT going to uninstall anything. Scroll down to the one that says Microsoft Visual C++ 2015-2019. Right click on it and choose “change” from the menu. On the next menu choose “repair.” Wait for it to finish (I then rebooted). Then try it and see if that fixes it. It did on mine. Good luck.