Text problem when transferring copied and then pasted text from an iMac to a Windows laptop

When I was running version 8 and earlier versions I would take information in Word documents from my Mac and copy that information into my Roots Magic database. This no longer works version 9.

What I get now are lines of font information text before and after each line or paragraph of pasted text. See image. I thought this might be a Mac thing. So I copied then pasted the text into a word processing app on my Windows laptop and switch then font to Segoe UI and saved.

I still get the same thing, lines of font information text before and after each line or paragraph of pasted text.

How can I fix this?

Have you tried Paste As Plain Text? I don’t know for sure if that will fix it, but it’s the first thing to try. Either Shift+Ctrl+V or Right Click and choose Paste As Plain Text from the dropdown menu.

To clarify, how are you copying text from one computer to another? Presumably, you have Word on both computers and share the documents between the two via iCloud or Dropbox or a shared drive… So what you are really doing is opening the document with Word on the Windows machine and copy/pasting from Word via Windows to the RootsMagic Note Editor on the same Windows computer. Therefore, it has nothing to do with the document having been created by Word on a Mac.

Between RM7, 8, and 9, there have been major changes in the Note Editor software resulting in the unwanted appearance of normally hidden document codes. Jerry’s advice about pasting as plain text is your best hope.

Well done guys, Plain Text worked! Thank you Jerry and Tom for taking the time to respond and giving me an option to solve my problem.


Didn’t we have a setting in RM7 to make the default ‘paste as plain text’? Maybe we need that re-introduced in RM9.