When will the HTML markups be fixed?

Once again I did a copy and paste from a Word document and this appeared in front of every line that was already in the Notes section:

It will take many minutes to locate them all and delete them.
I know that this ALWAYS happens if you do a Backspace above the top line of any note. But it also happens randomly by cut and paste - either off a web document or one on my desktop.
RootsMagic8 has been out long enough that this aggravating bug should have been fixed. I hope it is addressed!


Are you pasting with Ctrl+Shift+V -or- using the Edit Note dropdown menu option → Paste as plaintext ? Keyboard Shortcuts - RootsMagic Wiki

Using Ctrl-V as in almost every program known to man…
What is beyond weird is that if I past in a blank email in Mailbird - then copy and paste into RM8 the HTML code doesn’t appear
Using the drop down menu is beyond awkward - the usual shortcuts should be available. It’s a work around not a solution.

1 Like

I have seen sililar issues when cut/paste from MS Word to other applications (Even other MS applications). The Ctrl-C and Ctrl-V Cut-Paste option will try and copy the formatting as well as the text … I always tend to use Paste-Plain Text.

This has been an issue since Beta.
I’m guessing that RM is using a third party editor component and perhaps it’s the only one available for their development platform. What else can explain it?
I never trust what I’m going to get after pasting, even the paste plain. And Undo very often doesn’t undo.
And remember, it is still deleting blank lines at the end of the note whenever the note is saved.

I keep a text editor running, paste into it, then copy paste the stuff in the text editor