SQLite Error 10


Running Windows 10 and RM 9 now had the attached error a couple of times. Happens when trying to back up. Then have to use Task manager to close RM.

Then when trying to reopen, I get an error and have to resort to a previous backup, thereby loosing work completed.

Annoying it has to be said, and advice appreciated.

Per Renee on Facebook;

The SQLite 10 error is a “disk I/O error”, which could be a couple of things.

  1. You could have a corrupt database. Go to File>Database Tools and run all options there in consecutive order after a fresh restart of RM.

  2. You could have a program which is locking the RM database keeping RM from being able to access it. This is usually a program which runs in the background and does things like indexing, or backing up of files. Check if you have a program running in the background which may be accessing RM’s data files while RM is using them. Make sure database is not inside a folder syncing to cloud storage like Dropbox, iCloud or OneDrive.

  3. It could be an indication there is an issue with your operating system or hard drive. It could indicate your hard drive is failing and is working in a bad sector. You would want your computer specialist to test the hard drive.


Thanks Bob, I will certainly run all the Database tools.

Mind, I think you have hit the nail on the head with point 2. The database and backups are in a folder that syncs to Nextcloud. Having just tried to close and backup and it works fine. Is there a way around the occasional issue?

I have never heard of Nextcloud. But if it is anything like any of the other cloud services, it probably has a Pause option and if so you should Pause it while you are using RM.

Another option is to move your RM database to a folder on your disk that is not synced to Nextcloud. You can (and probably should) still keep your RM backup files in a folder that is synced to NextCloud so that they are backed up, if backup is your primary purpose in using Nextcloud.

Added: a quick Google search identified the following information with regard to pausing Nextcloud: Pausing Nextcloud

1 Like

Always pause Nextcloud before opening RM and then re-enable after closing RM. Nextcloud is what is causing the problem. I suggest moving your database out of the Nextcloud folder and telling RM to put your backups in the Nextcloud folder so that they are automatically moved. RM recommends that you do not put your database in any location that is automatically accessed by software such as Dropbox, etc, because of this issue.

1 Like

Many thanks, Bob and JerryBryan, sorted.