RM10 SQLite Error 6 - database table is locked

I have been getting an SQLite Error 6 - database is locked error code when I try to add a health condition to ancestors in my database. Interestingly, after I log out of RootsMagic 10 and then log back in I can add a health condition. The SQLite Error 6 - database table is locked box appears again, but I can click OK and then add the health condition. After I close that person’s edit box, I get another error code box that says “Access violation at address 00886473 in module ‘Rootsmagic.exe’. Read of address 00000000.”

I cannot add any health condition for anyone else after that.

Any thoughts on how to correct this issue? Thank you!


Where is your database stored? Is it inside of any folder syncing with the cloud like OneDrive, Dropbox or GoogleDrive. If so, move it out of that location. Then run the Database Tools under File, Tools.

Hi Renee, thanks for responding. My database is stored on my desktop computer. I use IDrive to backup my desktop files.


Does that mean that you are using IDrive for backup or is it a sync? It may seem like a distinction without a difference, but there potentially is a huge difference. For example, here are my current file properties which say that my RM10 database is stored in OneDrive. Exactly what does your file properties say?


Thank you for your reply. I checked the location of my file and it’s on my desktop’s D drive. I use IDrive as a backup.

I’m still trying to understand if iDrive is syncing your RM database while it’s in use or if it’s backing up your RM database when it’s not in use. Could you post the full file path. As I indicated, mine is C:\Users\jbryan\OneDrive\rm10. Yours is going to start with D:\ but there may be more to it than that.

From the idrive website:

IDrive automatically recognizes the modified parts of files and backs them up

What @thejerrybryan is trying to get at is that idrive is likely chasing the frequent changes RM makes to the database file as you use it and sometimes they collide. Unless you can suspend iDrive while using RM, you should try moving your database file out of any folder that is backed up by it. Save your RM backups to an iDrive folder but keep the .rmtree files out.

Here is the location - D:\Documents. IDrive is set up to backup once per day, overnight, when my computer is not in use. Thank you!

So, is this happening even though IDrive is set up to backup once per day? I have it set to backup overnight when I’m not using my computer. Also, I haven’t had this problem with my previous version of RootsMagic, which was RootsMagic 7. And I haven’t had this problem while using my Legacy Family Tree genealogy program.

Thank you!

I don’t have iDrive and do not know what control you have over what it does but this feature is included in all plans (except maybe for the Free one):

Continuous data backup

Automatically recognizes the changes made to the files in the backup set and starts the backup operation in near real-time

Thank you so much. I’ll check it out and see if that’s the problem. I appreciate your help!

I just checked my IDrive settings and Continuous Data Protection has not been on. I had the setting set to Off already.

This is all very puzzling. Given that Continuous Data Protection is off and that IDrive is set up to backup once a day, overnight, when you computer is not in use, there really shouldn’t be any locked RM database problems caused by IDrive. But apparently there are. By the way, do you actually shutdown RM when you are not using your computer?

The only solution I can think of is to store your RM database somewhere that is not being backed up by IDrive and to store your RM backup files somewhere that is being backed by IDrive. For example, if the only thing IDrive is backing up is your D drive, then store your RM database on your C drive and store your RM backups on your D drive.

1 Like

Pedantic question but just to be sure: do you close RM before running SQLite queries?

I ask because I had the opposite problem when I first started using the combo. I was making some changes in SQL queries with RM open, and when I went to close RM I got the DB locked message from RM.

It wasn’t a problem for a while when I began using the health database on RM10. I tried closing RM10 to see if that would solve the problem and it does, sort of, as in I can add a health condition for one person. But then it won’t let me do that for anyone else.

I have been shutting down RM when not using it. I tried that to see if it would solve the SQLite problem but it didn’t. I backup every drive on my desktop to IDrive. I can manually uncheck a file on my desktop so it doesn’t back it up. I will try that and see if it helps. Thanks!

Hi, I went to my IDrive folder and excluded my RM10 database and RM10 backup on both C and D drives. After I did that I tried to add Health conditions again and have the same issue as before. I can add a health condition to one person and then I’m locked out with the same SQLite error code. Sigh… Thank you!

It sounds like your actions pretty much rule out iDrive as the cause but have we seen similar reports that indicate it is a systemic issue?

Are you a speedy operator? There were issues in RM8, iirc, where users learned to go slow so as not to get ahead of RM. Try repeating each step while watching RM’s utilisation of computer resources in Task Manager. Wait for it to die down between each step to see if that avoids the problem.

@jmlast are you using more than 1 monitor-- @markwhidby and Mark when you got the error were you using more than 1 monitor?

Reason I ask is that I have not had any problems entering health ( or DNA) BUT I am only on one monitor-- there is another thread by @MKGT where he has the same problem on the DNA entry-- and he says he is using 2 monitors–so just wondering if it MIGHT be a 2nd monitor problem??

I too have been experiencing this, specifically on the Health features. I only upgraded from RM9 today…

My database is also not ‘cloud based’ and is located at Macintosh HD/Users/emma/Documents/Rootsmagic Version 10

I am using Mac Version, on a MacBook Air, with Ventura 13.4

Only ONE monitor.

It works for a short time then…BAM… Locks!
Shutting down and restarting the database is the only fix, until it happens again!