Rootsmagic 10 DNA Entry SQLite Error 6 - database table is locked

Rootsmagic 10 Windows 11 Desktop, database on C Drive.
Edit person screen - press the DNA button to add a match. Previous entry (for previous person) “Ancestry” was selected, this time I select “MyHeritage” receive message SQLite Error 6 -database is locked. Able to complete entry and then close - receive error

Press OK get error
Close Rootsmagic - error message

1st-- when you receive the SQLite Error 6 , you need to close RM completely and reopen it Because if you don’t ( even though you was able to enter info after the error occurred), it will just keep giving you all these other errors

2nd and you have to pause any cloud service you are using while using RM…

You MIGHT want to check this thread out as the only difference is that you are using DNA and they are using the health condition…

Thanks, I don’t use any cloud services or back up automatically. I am using a laptop for RM10 and an additional screen which I am looking at Ancestry on (Microsoft Edge). Only one database open and all RM10 windows only on the laptop. Never previously had any issues. Agree appears to be the same issue with health condition. If I stick to the provider that is already pre-selected from the last entry works fine. It is only when I change the DNA provider that is occurs.

Tried without using 2nd screen - exactly the same. Real nuisance and definitely a bug!

posted this on the other thread–so I see what you are saying— just don’t know what the difference is between my 2 databases

Are you using 32 or 64 bit on RM 10?

I am having the same issue. Previous Ancestry DNA entries were fine. Added a MyHeritage DNA entry and received the SQLite Error 6, was able to enter the info, and then the Access Violation error appeared.

I tried to add a second MyHeritage DNA entry and wasn’t able to enter it. Instead this error message appeared: A component named AddDNAForm already exists.

In my case 64 bit - will give 32 a try!

Have just tried 32bit version and seems Ok. Will test again tomorrow.

I’m sure there is some step or pattern here I’m not getting. I have not been able to recreate the SQLite Error 6 yet. Can you give me details step my step instructions. What you click on and where in each step.

Renee, Windows 11 Laptop, 64-bit operating system, x64-based processor, RM10 64 bit version. Just the laptop display.
Display people list, select individual - open persons edit screen. Using mouse select DNA button, select the add + button, form pops up with “Provider” pre-filled from last entry (in this case MyHeritage). Changed provider to Ancestry - SQLite Error 6 appears.
Only appears to happen when the provider that is pre-filled from last entry is MyHeritage, although it doesn’t do it every time! Have tried the same with RM 32 bit version and doesn’t seem to happen.

Latest - has now also occurred in 32bit version. This time going from a number of Ancestry entries and then entering a MyHeritage entry.

As @MKGT said-- the error only occurs on the DNA when you try to CHANGE TO A DIFFERENT PROVIDER–I can enter all I want from one provider and have no problems…

I really suspect @rzamor1 that you are NOT going to duplicate the error on your current database–the reason I say that is because I moved my 1st database to RM 10 on the very first day RM 10 was available ( June 19 )–I have absolutely no problems with that database–I can add all the DNA facts I want -changing back and forth between providers multiple times–I can also add all the health issues I want— multiple health issues for 1 person and health issues to multiple people…
Then I moved my 2nd database to RM 10 on Sat June 22–I can add all the DNA I want AS LONG AS I DO NOT CHANGE PROVIDERS–once I try to change the provider, I get the SQLite Error 6 and basically every time I try to add any health issue I get the SQLite Error 6 …
The databases were imported to RM 10 the same way ( even deleted the 2nd one and tried again and tried a drag and drop–still get the errors)–only visible difference is date of import and size of database ( similar in size though)…

So what’s the difference?

I downloaded RM10 (UK Version) on 22nd June. Have now tried all the versions 32/64 bit UK & general version etc. All do the same.

I have periodically been getting the same problem when adding DNA matches. It seems to happen more if i have Ancestry open at the same time. If i close both Ancestry and Roots Magic and start again it seems to clear it, but i’m also getting a problem when adding shared matches, whereby the box disappears off the screen as soon as i move the mouse to save the matches.

I have just downloaded and started to use RM10 on a Windows 11 laptop. First I downloaded my Ancestry tree into RM10 to see how it looked, it didn’t have my DNA match fields so I created a copy of my RM7 database and imported it into RM10.
In both cases I made sure that the RM10 directory was outside of my OneDrive file structure due to other comments about this being a possible problem. The media directory is within onedrive but I am not doing anything with it and I paused syncing just in case.

The first problem I got was adding a shared match which created the “unknown” provider as has been previously mentioned. After changing that to Ancestry adding in the cm data which was missing and moving on to the next match I got the SQLite 10 “disk I/O error” I tried everything to try to close the database but couldn’t do it so I had to use the task manager to close the application.

Going back in and trying to edit caused the same SQLite 10 error to appear almost immediately forcing me to close using the task manager again.

After reopening the program it occurred to me that the problem could be that I was working on Ancestry and maybe there was a connection with the file I downloaded from Ancestry but when I switched to that one to close it I then encountered the SQLite Error 6.

I closed everything down, shut down the machine restarted with only the RM7 converted file and ran the database tools as suggested they found nothing.

Opened the database this morning ran the database tools just to be sure and went into the DNA screen and immediately got the SQLite 10 error. What do I do now?

I got an access error after experimenting with some DNA entries.
Not sure what was caused – I rebooted and it has not appeared since in my case.
Not sure if related to MKGT (issues) and I have not been able to repeat it happening.


Yep also getting the error, only and always, when changing DNA provider.

a work around is to create a new match with the default provider, then change the DNA provider in the side window on the right rather than in a separate window. that seems to work OK

Thanks - good for the time being until they fix the bug, hopefully soon.

@MKGT @LilyB @KaitlinB @paulbrock wanted to ask you all how you moved your databases into RM 10-- Did you go to CREATE A NEW RM FILE and use one of these options?

or did you go to OPEN FILE and click on the database you wanted?