Strange message when shutting down

When I close RootsMagic9 with the usual backup - I get the following message.
SQ Lite Error 1 - no such table PlaceTable
and there is a “ghost” window left.
If I close that window - reopen RootsMagic and close down with backup again, the program closes properly with no message and no leftover window.
Anybody know what might be causing this? Has only been happening the past couple of weeks.

@khaden Seems like I had a ghost window after closing my database not long ago BUT do NOT remember if there was an error associated with it…think Tom H MIGHT BE ABLE to tell you abt the
SQ Lite Error 1 - no such table PlaceTable

So did you have more than one file open-- if so this thread will explain WHAT causes it

Basically what the thread is saying is that if you have multiple windows open— then minimize them to the task bar, a ghost window appears after that…

Would suggest if it happens again that you open a support ticket BEFORE reopening RM and doing another backup IF the one that just caused the error was saved – check the time and date on the file to see IF it was saved…

No I had only one file open.

1 Like

Does this happen every time? If you remove the setting “Ask for backup” under Settings, Program Settings does it continue to happen?

It does not happen every time. And happens either way I back up when it does. The backup exists even when I get the warning and ghost window. I have also received this message from Dropbox which is new since this started happening. I keep my file on Dropbox but backup to my desktop - has worked just fine for literally years. The message from Dropbox was “haden9revised.rmtree-journal - do you want to delete?” Have never before seen a file with the “journal” part since that wasn’t part of the file name and don’t find any such file in Dropbox when it reports that whether I accept the message or not. Beyond weird. I compacted my database, rebuilt the indexes & did an integrity check so the database would be as clean as possible - than changed the file name just as an experiment which also changed the backup file name - for whatever reason it hasn’t happened since then but I have done little work in the program so far today. Just will have to see what happens next.

Do you pause Dropbox before starting RM and to resume Dropbox after closing down RM.

Have never paused Dropbox for any reason - never been a problem. I’m still getting the SQ error on backup - not when I tried from the File selections - but when I just shut down in the normal.

My understanding from reading many threads on here is that you should ALWAYS pause Dropbox while working in RM and to resume Dropbox after closing down RM and that goes for any other program that SYNCING TO A CLOUD SERVICE ETC…

Not sure if that is the reason for your strange messages BUT there are many threads on here abt Dropbox and others cloud services–here is one from the many different ones

.Moving from Dropbox - #9 by thejerrybryan

It sort of depends on what you mean by “any other program”. Dropbox and its competitors all seem to work well with programs such as Microsoft Word and Microsoft Excel and Notepad and Microsoft Paint. In other words, Dropbox and its competitors all seem to work well with programs that do a File => Open at the beginning and a File => Save at the end. The sync occurs only after the final Save. Dropbox and its competitors seem not to work well with programs that use databases that “save as they go” such as SQLite and Microsoft Access. RM’s database is SQLite. For databases, the sync seems to try to be continuous rather than just being at the end, and therein lies the problem.

You may have noticed that RM doesn’t have a File=>Save at the end. That’s because it saves as you go, and it saves as you go because it’s using an SQLite database.

1 Like

Sorry @thejerrybryan --WHAT I meant to say was that you shouldn’t be synching to ANY cloud service while using RM

Move the database out of Dropbox. Run your database tools under File, Tools to rule out that Dropbox hasn’t caused some corruption. Then test to see if your issue has now gone away.

Funny that I’ve done this same routine (file in Dropbox) for years - so the database is available on my iPad when I travel, without a problem. Downloaded RM9 the first day it was available and have received all updates ever since - has backed up just fine until the problem started about two weeks ago, although nothing I know of had changed in either RM9 or Dropbox.
So I took the file completely out of Dropbox and guess what - I still get the error
SQ Lite Error 1 - no such table PlaceTable
and the ghost window.
Did the file actually backup anyway - yes, it did.

Open a support ticket with a copy of the database.

That you get this error only on backup and not while working in your database suggests that your database file does have PlaceTable and that RM has issued a sql command to a database file other than your working one. One that is a valid sqlite3 database but does not have PlaceTable.

We have detected that RM does create temporary database files on the drive for certain operations and it’s possible it also does so exclusively in memory which we cannot (or don’t know how to) detect. That might be the case for the backup with media but I don’t see any reason to for the backup without media.

So the warning about working on an actively synced or backed up database file finally caught up with you. Not only does the database file change at high frequency thus causing Dropbox er al to chase its tail but every time the change takes place a temporary rollback journal file is created and then deleted on successful completion of the change. It exists fleetingly, a few seconds, but Dropbox may catch it. If it persists, then RM may have crashed out incomplete and the next time it accesses the database it should rollback to the state it was in before attempting to make the changes. If the rollback was ok, the journal file is also deleted. If not ok, the journal file remains and I think different sqlite error(s) may be reported.

1 Like

You make more sense than anyone else. I’ve moved my database out of Dropbox but the error continues. Now - how do I get rid of it……

I’m always reluctant to suggest a drag and drop of your database to a new database, or a GEDCOM export from your database and a GEDCOM import into a new database. The reason for the reluctance is that there can be a certain amount of data loss in such an operation. But a small amount of data loss that may be negligible in many cases and you may need to consider it in this case if it’s the only way to get your database up and running again. If I ran into a need to do this myself, I would use GEDCOM export/import rather than drag and drop because that would allow me to specify options for both the export and import.

See the following link for more information on data loss on drag and drop and GEDCOM export/import: Data Losses on Drag and Drop and GEDCOM Export/Import

I fixed it. I removed RM9 and downloaded it again and reinstalled. Had also removed datafile from Dropbox before removing RM9 Error messages gone.

1 Like

Congrats! That the RM exe itself was faulty in this peculiar way is very strange, especially if you reinstalled the same version. There’s something different every day…