SQL Lite Error 14 - unable to open database file


Since downloading RM10, I have got this message at least 10 times.

I have used the program on at least 6 occasions and had no problem at all. This involves the normal loading my database, making changes including uploading media files and saving my work.

However while doing exactly the same today I have received this message again and lost over an hour’s work.

I am losing faith in this program now.

I don’t have multiple databases open, and everything is behaving normally and then bang I get this message. I can see the RM screen that I am in but cant do anything and the only way I can get out of the program is to Quit it on my Macbook.

Has anyone got any ideas?


PS if you cant see the image all it says is in the Subject line above.

One reason a database won’t open is if something else is using the file. The other is permissions and where the file is located, and you don’t have access.

Exactly where is the RM database stored on your Mac? By that I mean, what file path does RM show for the database, not just that it’s stored on your hard disk.

Not sure about the MAC vs PC differences. This may be troubling to hear but it is almost certain to be something specific to your computer and/or configuration and not the program itself. As @thejerrybryan mentioned – is it

I redacted some of the path but this is what it looks like (from PC version)

Also check folder settings ( also partially redacted)

Don’t know if this helps at all, but using a Mac my pathname formats are:

/Users/[my Mac username]/Documents/RM10 Files
/Users/[my Mac username]/Documents/RM10 Files/ BACKUPS
/Users/[my Mac Username/Documents/RM10 Files/MEDIA


That’s actually much more helpful information that you might imagine. That means that your RM files are stored in a totally standard location. The files can be accessed by RM and they are not being synced by an addon product such as Dropbox. Nevertheless, the symptoms suggest that some program other than RM is accessing your files.

I am not a Mac user and here is where my lack of knowledge of a Mac comes into play…I don’t know exactly how either Time Machine or iCloud work on a Mac. Is it possible that you are using either one of these tools and that one of them might be accessing your RM files at the same time as RM? For example, I don’t think Time Machine requires a special folder in order for it to backup your files. I don’t know about iCloud needing a special folder or not.

1 Like

It would be helpful to know what version/level of MacOS you are using. And is your Time Machine backup, if you use it, using APFS or HFS+.

I don’t think Time Machine will be causing the error, based on the way it works - if MacOS is using APFS, it just copies the file system metadata at an instant in time, creating a static checkpoint of the full file system. Subsequent additions and changes are written to new areas of the disk and the previous frozen data is still present and the checkpoint still points to it.

There don’t seem to be any/many Mac users suffering from this problem - I’m certainly not, so there must be something about your setup that is different. However, spotting it may be difficult.

Looking back at your error description, you seem to be saying that you are working away and then you suddenly get the error. Is that so? This seems to suggest that RM is trying to update/save a change to your data file and it is detecting the error.

What do you do next? Are you quitting or force quitting RM and then starting it again and opening the same data file and finding that a significant amount of your recently added changes are no longer there?

What does a Getinfo against the data file show - can you attach a screen capture of what it shows (though you might wish to block out some of your username in the image).


I have now setup my RM10 folders like you within my Documents folder and managed to open my files.

Thanks for your message. I will see if this works better.


1 Like


Thanks for your reply. I had my file in
/Users/[my Mac username]/Documents/
I have now set it up as the above but added RM10 Files with Backups and Media within as one of the other people suggested.
This has allowed me to recover my database, so I will see if this works.

Thanks for your response.
I have been able to recover my database by changing my folders to those setup by ftipple. Lets see if this works.

Hi, thanks for your suggestions. I have recovered my database using the folder settings that ftipple suggested.
I have an M2 Macbook Air with 8GB of Ram. I have been running Lightroom Mobile Desktop in the background and wonder if this may have caused the issue.
When I received the error message, I was unable to close Roots Magic and had to use the Option/Command/Esc command like Control/Alt/Delete on windows to close the program.
Then when I tried to reload the file Roots Magic gave me the same error message.
I will now continue with my updates but save my data more regularly.

Time machine backup and icloud synching do not use a specific folder like Dropbox and are an integral part of the mac OS.

RM is still an intel code only program requiring rosetta translation and uses an excessive amount of CPU (15-20% vs <1% any other program). On a mac with only 8GB ram and a program like lightroom that could be a problem. M series macs use ram very efficiently but really work best with 16GB or more .

I think you are right. I will ensure I close Lightroom while I am using Roots Magic in future and hopefully I wont have any more issues.

Hope it works OK for you. I normally don’t have any problems.

Incidentally I copy my backup files to iCloud as well, and of course I also have the TimeMachine copy, so hopefully I’ll always have a safe copy