Sources copy paste function

After updating yesterday to version 9.03.0
By trying to mark the footnote to be copied this function is not working anymore. Not with right mouseclick or with CTRL C.

If I am understanding you correctly, nothing has changed in 9.03.0 Memorizing citations in RM8 and RM9 has never worked with right click or Ctrl-C. Instead, it has always worked by clicking on a Memorize icon.

On this screenshot I marked the text of the footnote by first one click in this window and than I can mark it (this still works with the actual version upgraded yesterday). Than I can copy it with ctrl ‘c’ and paste the text in another field, this functionality doesn’t work after update.

Copy hasn’t worked for me on macos inRM8 or RM9 on this pane. I can highlight text but right-click does not bring up any options and ‘select all’ and ‘copy’ keystrokes produce a single beep response indicating that the action is not supported. I have to go one screen deeper to edit the citation and then customize the footnote in order to copy footnote text. It would be nice to have ‘select all’ and ‘copy’ functionality on the Details screen.

Aha! We were talking about two different things. I was talking about something like Memorizing an entire citation and then Pasting it to a totally different fact. You were talking about the standard copy and paste of text that’s supposed to be pretty much the same for any text inside of RM and for pretty much any text outside of RM.

I tried your test just now. The Copy part works. For example, I could paste the copied text outside of RM9, for example into Notepad on Windows. As you said, the Paste part doesn’t seem to work inside of RM9, neither via Ctrl-V nor by Right Click and Paste. But it does seem to work inside of RM9 if instead I use Shift-Ctrl-V or Right Click and Paste As Plain Text.

There is definitely something funny going on. The text you have copied should inherently already be plain text and therefore you should not need to specify plain text in order to paste it. If I copy the text you are talking about, paste it into Notepad, copy it from Notepad, and then paste it into RM with just Ctrl-V or Right Click and Paste, it works. So problem in RM9 seems to be in the Copy. Even though you are copying what should be plain text, it is trying and failing to paste it. But to tell you the truth, even though it is copying the text as rich text, I don’t see why it’s failing to paste anything at all.

I do agree with kevinm, I need to go one screen deeper. And thanks for the additional info from thejerrybryan - it works with Shift-Ctrl-V. This shift was not required in the version before last update.


Confirming this has been reported to development.