RM App on iPhone 13 crashing

Having a problem with RootsMagic App on iPhone 13. I am new to the RM community but I have been using RM on desktop and on I-Phones for many years. Have always enjoyed the RM app when I am away from my computer. In the last month or so the RM App crashes when I try to do anything. This is what occurs:
Touch the RM App icon
“On Device” screen shows up displaying this:
iTunes: 1) - 9) list

Dropbox: 1) – 9) list

Then when I Touch “File”, I see On Device, Dropbox, Help
Then if I touch Dropbox the RM app crashes and the screen goes back showing all of my app icons
Touching any of the other 4 icons at the bottom it also crashes.

RM tech support recommended deleting the app and reinstalling. I have done that 3 times and the RM app still crashes. Would appreciate any good suggestion.

1 Like

Same issue. There is a quick popup about logging into Dropbox. There is nowhere to login to DropBox from within the app. Help says to select the Dropbox tab??? There is no tab?

The “RM app” is a very old 2015 3rd party ios app that no longer works.
Use the free ancestry ios app which is great provided you have trees on ancestry website.

I’m not a Mac user, but this has been reported to still work as recently the end of 2023.

Strictly from the point of view of an iPhone or an iPad, the RM mobile app still works. It is the Android app that no longer works.

There are two remaining questions. 1) Can RM9 create an *.rmgc file that can be used by the iPhone/iPad mobile app? It can. 2) Can RM9 transfer the *.rmgc file to the iPhone/iPad? On Windows, it can. On a Mac, I assume so but I don’t know for sure.

I didn’t respond originally because I’m a Windows user. I can therefore vouch for RM9’s process of File => Export => Dropbox working on Windows. I was pretty sure it also still works on a Mac, but I couldn’t vouch for it without being a Mac user.

I just installed the RM iOS app (v1.4) on my iPhone (iOS 17.3.1) and I used File > Export > Dropbox from my Mac (RM and Sonoma 14.3.1) and it worked ok for me.

Appreciate you suggestion on using Ancestry App. I currently only have a small part of my RootsMagic on Ancestry but that sounds like a workable plan. I really liked having the RM app when traveling only with my phone. It’s pretty sad that RM will not update the app or redo it as I would be willing to pay an app charge.

RM app was by a 3rd party not rootsmagic and was only a viewer. The ancestry app allows full editing, hints, etd and is kept currently updated. Good luck.

Please open a support ticket with RM.
I opened a ticket and have been going round and round with them to the point they actually said “Sorry you are switching to Family Tree Maker!!! Of course they tell me I’m the only person having the problem. I’ve screen recorded everything to show them there is an app issue but they still tell me to uninstall the RM app and reinstall. The support person I’m dealing with doesn’t have a clue about iPhones. When I told her I was running iOS 17.4 she replied “I don’t have that new of an iPhone. I only have an iPhone 13. I’ve asked several times to escalate the ticket to the next level or to put me in contact with a manager but all I get back is basically reinstall the app.
Let’s see how today goes but I’m not holding my breath.

Yeah, that isn’t going to happen for an app that Rootsmagic did not write and that has long since had anything passing for development come to a complete stop. The android version of the mobile app has been put to bed. The only reason the Apple version still works is because Apple updates have not yet broken it, but they will eventually.

You do not log into Dropbox from the RM app, you do so through the Dropbox app.

Solved! - Quick fix on iPhone or iPad, go to Settings → Display & Brightness → Text Size and ratchet it down to where it works, maybe about 5 notches from full. Try going up till it starts crashing. Done