RM App for iPhone and iPad not working

For many years I have been using the RM App on my iPhone 8 (iOS 16.1.1) and iPad (iPadOS 16.1.1

16.1.1 is a recent update and the issue I have predates the OS update.
Starting about 2 weeks ago the RM app would open and immediately close down when I chose either ‘Files on device or files on Dropbox’. This happens on both iPhone and iPad.
For months I have been exporting my RM data to Dropbox mostly without issue - that is until now.
I have tried uninstalling and reinstalling the App on both devices, but the same problem happens with the App closing instantly I try to choose a source. I am aware that RM8 requires an Export of data to a (.rmgc) file extension and have been doing this for some time problem free.

Is anyone else using the RM App on Apple kit? I’ve searched the help files but to no avail.
Help solving this would be much appreciated.
I posted this on RM Facebook and had a reply from Jackson Andersen (Tech support) who doesn’t have this problem with his iPhone.

Thank you

1 Like

I’ve just opened some ‘on device’ files on both an iPhone and an iPad, both at 16.1.1. BUT these are relatively old RM7 files, not files ‘exported’ from RM8. (I haven’t been able to find a way to transfer the latter as I don’t want to involve Dropbox.)

ios RM app is read only, very old (2015), unsupported and requires dropbox to get data files.

Use the current supported and much better ancestry ios app which accesses any trees you have uploaded on ancestry and can edit those files.

That only works if people use ancestry and many don’t. When someone posts a question asking for help, telling them to use another piece of software isn’t a very helpful response.


If asked how to get to the other side of a brick wall a valid response is to go around and stop trying to smash through it. Those not using ancestry may not be aware of it’s utility and are overlooking a useful tool.

Thank you Recrooks, you’re correct, I was looking for a solution to the problem with RM app and my iOS devices which were fine with iOS 15.xx. I do not use or want to share my tree on Ancestry . Others use iOS 16.xx devices without issue - it can’t be just me, or can it?
ps. I’ve updated to iOS 16.1.2 today but still have the problem.


Open a support ticket with the file you are uploading to Dropbox to use with the app and we will test it out.

1 Like

An update for you Renee… I decided to do a factory reset on my iPad and then reinstated apps and data from a backup on iCloud but the problem persisted. I did a second factory reset but didn’t reinstate all apps, just the apps that came with iOS 16, now 16.2. I then installed the RM app from the App store and pointed it to my Dropbox RM data file and guess what, the RM app is working fine.
I reasoned that the issue I had was probably a rogue app and as I had far too many apps I’ve started to install just my favourite apps. So far the RM app continues to work ok. As and when I install any further App store apps I will run the RM app to check that all is well.
I’m now going to go through the same process with my iPhone. It would be satisfying to know which app is the rogue - if that is the case but I’m happy to cull my apps and have a clean iPhone.
Thanks for your help and Happy New Year.

1 Like

Darth, Any luck with your iPhone RM app accessing RM8 data?

I also have an iPhone at iOS 16.2 and the RM App crashes every time I select the RM8 the rgmc file on dropbox. I reinstalled the app on the iPhone, reset the Dropbox account, restarted my iPhone, downloaded a new rgmc file to dropbox, and it still crashes all the time. Maybe I need to change the order of these steps. I will not do a factory reset of my iPhone.

1 Like

Hello jdog, I haven’t yet cured the problem with my iPhone and like you, want to avoid a factory reset. What I’ve started doing I’d deleting apps from my iPhone and noting down a list on old fashioned pen and paper the name of each app as I delete it. Once deleted I try the RM app to see if it works - so far it still fails as you describe. This approach is a bit tedious and time consuming but I’m hoping that it will perhaps identify a rogue app.
On my iPad I have reinstalled several of the apps I had before and so far the RM app is behaving. There were a number of apps I didn’t use so I won’t be installing them again.
In a way I’m pleased that someone else has the problem - I thought I was all alone in the forest!
If I do spot a rogue app I’ll let you know.
PS. I’ve captured screen shots of my iPhone apps to help identify those I’m deleting.
Good luck.

1 Like

Does roots magic 9 work with the rm iPhone app w/o having to use ancestry?

RootsMagic has the ability to save your database to Dropbox to use with the RootsMagic IOS app.

Saving a Database to Dropbox (for Apps) - RootsMagic Wiki

Just asking since I haven’t been able to get the app working with RM 8. Presumably the app interface has been tested with RM 9.

That’s a question for Tech Support (RM 9 testing), but presumably it worked/works in RM8 and is not reported to have had fixes nor feature changes. Have you availed yourself of a RootsMagic support request for help?Submit a request – RootsMagic Support. It’s part of the purchase, just saying.

I wanted to chime in on this thread, since I have not had a chance to try out RM9 data on my iPad. I’m a long time user of RM7 which is my production app. I tried out RM8, but as most have found, it was not meeting my needs. I have install RM9.0, but not RM9.0.1.
Anyway, I run all of these on a Win 10 laptop at current Windows patch level. On my iPad I am running the current iOS 16.3.1. After I saw this thread I decided to copy over my RM9 data file and found it is working fine.
My method of transferring the file is very antiquated, but it meets my need of updating only once a calendar quarter. First, I copy the *.rmtree file to a *.rmgc file extension. I then connect my iPad via a USB cable to my laptop and startup iTunes on my laptop. I then use iTunes to transfer the file over to my laptop. Like I said before, very antiquated. I used the same method on all RM7-9.0 and seems to work fine as long as I have changed the file extension. Haven’t gotten around to installing RM 9.0.1, but when I do I will try this again.
I’m sure RM has a new iOS on their to do list, but until then this is my work around.

Have you even looked at citations on the app since you started transferring them with a fake extension? I’m certain not one person has any.

However, it is a little surprising that the app can show the tree but that just shows that that part of the database structure is unchanged.

RM 2015 ancient ios app was not from RM and is not being updated. Simply put a private tree up on ancestry and use the free updated ancestry ios app which allows editing. The RM app was read only.

I’m not a fan of Ancestry.

1 Like

Darth wrote: “I’m not a fan of Ancestry.”
From my point of view in Norway, very many Americans use this as a family program. My view on this is that Ancestry is more of a database where you can store your information. The same also applies to FamilySearch and MyHeritage. There isn’t much else you can do there. If you are to really develop yourself, you must have a genealogy program and then transfer your data to that program. I think that there are very few compared to the total who do that.
We are lucky users of RM who have the option to transfer directly from Ancestry (although it costs a lot of money) and FamilySearch.
I mean, when it comes to MyHeritage, it’s hard to trust a lot of what’s stored there, and it’s amazing that so many people waste lots and lots of money to get a place to store their