QuickGroups (RM7) - Groups (RM8)

Having a quite large Database (455’000 people) I am working with different (quick-)groups.
Selecting one of my largest groups it takes with RM7 50 mins. My first attempt selecting a group (the same selection as in RM7) in RM8 was running 4.5 hours - than I stopped the process.
So I am using RM7 although I do like quite a few new features of RM8.

My database is a lot smaller than yours at about 60,000, but I have never done anything with groups in either RM7 or RM8 that takes more than a few seconds, certainly less than a minute. So can’t picture what you are doing when you “select one of your largest groups” and it takes so long. Could you describe your process in a little more detail?

Like thejerrybryan I’m not noticing any particular delay in selecting a group, at least not for display in the index panel (some 75000 people and some 250+ groups - I use groups to keep track of groups of shared DNA matches, as well as assorted place related and project related analyses++).

However,
not exactly related to the initial problem, but definitely speed and group related.

If I use the arrow key to navigate down the left panel ) of an edit screen from the person name (as I do in RM7 to reach a fact) it takes an appreciable time to get past the group list as it populates the quick groups in the right panel.
And seems not to keep the list in memory until you finish editing, as arrowing down past it from name for one I timed took about 9 secs to populate my group list in the right pane (and I presume mark those the person belonged too (2 of the ?250?)
When I experimented by arrowing back up the left panel, the same happened, not that I expect to do that often.

I too am still using RM7 for my main work as RM8 is simply not suited to my input processes, nor speed and involves too much swapping between keyboard and scrolling given the lack of workable keyboard shortcuts. But that doesn’t mean I don’t use RM8 for other purposes

Quick access to the group list functionality to create new groups, with the same new filtering option to give ability to quickly jump to an existing or create a new (usually by Data fields) for me) are high on my wish list.

I am testing the groups. I selected a group with 2000 people and can open this group in the People List Screen. I also selected a group with 28000 people and this doesn’t show up in the People List Screen. Well just not within a few seconds or minutes.
Although the count shows the number of people, it seams that the persons are not allocated to the group, except for the smaller group.
In RM7 I get the same count and the persons are allocated to the group independent of the group size.
I am also still using RM7 for the faster workflow. RM8 is fine to get an overview, but editing the people is faster using RM7.

After rereading all the messages in this thread, I can now partially replicate the slow behavior. I created a group containing everybody in my 60,000 person database. I went into People View which came up more or less instantly showing everybody because there was not yet a group filter. I filtered in turn by several of my small groups, each of which contains a few dozen people. They all came up more or less instantly. Then I filtered by my “everybody” group. It took about 15 seconds to come up. That’s very slow, but still nowhere near as slow as other reports. That’s why said I could only partially replicate the slow behavior.

I tried the same experiment in RM7. My “everybody” group of 60,000 people was visibly slower coming up than my smaller groups which came up instantly. But it still came up in one to two seconds in RM7 instead of the fifteen seconds in RM8.

To find out all my relatives in my database I have to select my ancestors and all their descendents.
So I made a new try: in the Groups feature I selected myself and than ancestors 15 generations back and 16 generations forward. The selection in RM7 took 2 mins 9 secs. Result a bit more than 170’000 people.
The identical selection in RM8 took 28 mins 4 secs.
This selection is useful for export. I have about half of the people in my database which are not related to me, but a result of research for friends and also for screening all genealogical data in a certian village or region.
Of course I would prefer an easier way, but by setting relationships (which is really a fast process), only the related people are involved without their partners. Further I did not find a way to make a group of all people which are related to the root person.

I have never posted a wish list request to make “related to the root person” a search criterion. But such a search criterion would be very useful. It would be very easy to implement because of the way the data is stored in the RM database. And it would be very fast to process because of the way the data is stored in the RM database.

Well, there would possibly be one little glitch. For the most part, RM does not store information about spouses of your relatives. So something like “spouse of your second cousin once removed” is not stored in the RM database and therefore could not be searched. But a spouse of your aunt or uncle does get stored as your uncle or aunt, respectively. I don’t know if that’s a good thing or a bad thing, but it’s a thing. So if RM did have a “related to the root person” search criterion, it would pick up such unrelated people.

Thank you for your support!
The search criterion ‘related to the root person’ would be very useful. As addition ‘add spouses’ like the color coding option when coloring the descendents of a certain person.
In the group selection by data fields the field ‘related’ is available - but I never succeeded to get someone selected.

me neither. (mark everyone in highlighted person’s tree)
It always sounded most useful for GED exports too, but I too, never could get it to work.
The RM8 selection screen behaves most strangely when you try to search for the person to select, doesn’t seem to filter nor does mine position at the person requested but somewhere only very very approximately close to the filtered for name, where scrolling basically doesn’t.
Yes I eventually realised that the searched for person was clearly visible in the rhs, and selected him/her, but to no avail.
Even when you do manage to select the required person, it doesn’t seem to “stick” and my GED is always empty.
I’d always put my inability to do this as user error and found other ways!

In the dialog for color coding or making a group, I don’t see an option for “related”. Maybe I’m failing to see it. I do see an option for Everyone In Highlighted Person’s Tree. That does work, but it’s not the same thing at all as “related”.

I hope “related” is really there and that I have missed it somehow or other.

So I think the field ‘related’ in the Group selection by Data Fields should be offered after marking a person in the group selection as an additional option to family, evreyone, ascendents, descendents etc.
Alternative (maybe easier) in the Color Coding: Related to the current person (generations xx) and the option include spouses.
I expect color coding could be faster.

I was obviously missing something obvious here in the selection process, for either colour coding or creating a group of “everyone in highlighted person’s tree” but the following experiments did eventually make me figure out how to make it work, albeit not smoothly.

When I tried via the right click colour coding to bring up the
Colour coding dialog box


having selected a colour and people selected from list, then OK
The chap I started from is on the rhs

If I click Select, assuming it has selected him given nothing else connected to him is visible, I get my colour spinning wheel, and returned to where I started, but nothing changed on his fact summary or pedigree view box

If intead of simply clicking Select, I search for someone in the search box, even though the person I started from is in the rhs


(I’ve reduced the screen width to hide some details here)
the person searched for isn’t the one I actually wanted, just the first of the name, but as the lhs isn’t filtered, or positioned at the surname, I couldn’t seem to reach the one I do want.

I did eventually find that an arrow down changes the focus on the rhs to the next of that surname, - once I’ve actually clicked into the list on the lhs
but I cannot easily confirm that he is selected, nor see the other candidates matching the filter to get the right one.

If I then click Mark and “everyone in highlighted person’s tree”
image
then try scrolling up/down the lhs to see who got marked, there seems to be no logic at all to the results of a scroll down (seems to sort in descending order all of a sudden, Ross was on the screen a scroll down is now Roos > Roper > Rorie, next scroll , same direction, rogers… so it is really jumping around)
Thnking about this latter, the scroll issue might be a Mac trackpad peculiarity* but the visibility of the person, or the results of a search not positioning you anywhere near the person in the rhs pane still exists.
And clicking in the box above or below the scroll box position only moves one line, not a page view, which latter is, I believed, expected behaviour

  • There are Mac settings for scrolling in a trackpad

    to me it is logical that if I use the gesture moving my fingers down the trackpad, I want my focus on a list to move down.
    This appears to be the OFF position for content tracking finger movements
    (MacBookPro, Catalina)
    and may be reversing the list scroll results?

Hope this helps someone - it did end up making me figure out what I needed to do to create a group of related people for eg GEDCOM export (or colour coding)

I tried to do a selection the way you proposed.
The result is all people in the tree independent of the person I highlighted before…
But I learned to color a group in one step which is very useful. I always selected a group and than in a second step colored that group.
I think to select all relatives an additional option is the solution:

  • Relatives of current person
    • Include spouses
      • Include parents of spouses

With this selection one can have an ideal GEDCOM for export