Media not showing up after downloading tree from ancestry "file not found"

nw to RM. Have RM 9. Finally got my tree downloaded using tree share, but none of my pictures downloaded. It’s downloaded into a brand new tree or file in RM.
I don’t see this particular problem addressed in the help section. Can someone please point me in the right direction?

thank you.

There should be a folder in same place your database dowloaded that will be database_media. It should contain your media. The names will just be numbers for most. If you look at the media on the database is it showing broken links?

I found the folder with the media. My rootsmagic shows little red x in the bottem corner of every file. There’s a pink line on the far right under edit media that says “file not found”.

In the Media screen, click on the three dots. Lick “Fix broken meia links” You can click on “A selected drive or folder” Browse to the folder with your media (click on folder icon on search box) then sele lct folder and then “Searrch” it may take a little while but that should connect your media to the database

Okay. I did it. It’s searching. I’ll let you know. Thank you for trying to help!

Well, I did it and it didn’t work. Says zero links fixed.
I followed your instructions below.
3 dots on the media screen
fix broken media links
clicked on “A selected drive or folder”
went to the open folder on the right in the white bar under “A selected drive or folder” and clicked on the open folder
This to me to my documents folder, where there is a new folder there called My Whole Tree_media (the name of my tree is My Whole Tree).

Clicked on the folder
Clicked “open” bottem right of documents folder
then clicked “Search for Missing Files” on the Fix Broken Media Links Dialog box

Started “Searching/Users/roseenney/Documents?my Whole Tree-Media”

Took about 3 minutes.
Says “Fixing Complete”
0 broken media links fixed. 64371 links not fixed."''Any other ideas?

Thank you again!

Not sure. There shouldn’t be any lost links right after a Treeshare

1 Like

I just don’t know what to do? Tried it twice.
I have a message into techical support. Hopefully they can get it fixed.

thank you again

go to Settings and fill in these fields with what you’d like - since you have downloaded the media, enter that folder name. should be good to go (strange it didn’t Fix them)

Thank you for the info. I think I’m learning more than I thought I would. I found the Folder SEttings, and I found where the folder is on my mac.
So do I type exactly what you did? Except for the user is me, then Documents/My Whole Tree_ Media\ ? My file is in the documents, in the icloud, and named My Whole Tree_Media. so

icloud/myusername/Documents\My Whole Tree-Media (with spaces?)
Sorry to ask so many quesitons.
Appreciate your help

Here are my RM9 folder settings on a MAC. Just my examples.

I’m running Sonoma, and I think you also need to grant RM access to your Documents folder - at least, that is what I have set in System Settings at some time in the past.

I suggest you check both these areas.

The default media folder setting inside has nothing to do with where your media is stored or helping you find it. It’s only purpose is to open that specific folder when you are trying to add new media. I wish you could test taking your media out of iCloud but I see its at the root of your pathname. Check what the media filenames are inside RM, including file extension, and then manually look for that media on your computer and make sure they match.

1 Like

Let’s start with something even more basic than media files. If the media files downloaded via TreeShare are in iCloud, that means that the RM database itself is also in iCloud. This should not be happening. A query of SQLite and iCloud reveals the following. I do not know if RM uses Core Data to manage its database on a Mac, but I would doubt it.

The short answer is that you shouldn’t use SQLite and iCloud, the tutorials are right. From the iOS App Programming Guide,

Using iCloud with a SQLite database is possible only if your app uses Core Data to manage that database. Accessing live database files in iCloud using the SQLite interfaces is not supported and will likely corrupt your database.

Have you ever tried to download a tree with media from Ancestry? I tried that in Linux, in Wine, where Wine simlates a Windows environment by presenting paths like C:\users\enno\Documents to the program. And in that case, when it downloads a tree named ancestry.rmtree, it creates a folder named ancestry_media, so that every media file can be accessed with a path like


This works in Wine, because RM 9 can safely add a backslash (\) between the media folder and the name of the downloaded media file, and Wine translates that path to where the files actually are in Linux, meaning that for RM 9 everything looks like real Windows.

When RM 9 runs on macOS, there doesn’t seem to be such a translation, so RM 9 must probably add a forward slash (/) between the media folder and the downloaded media file. Does it do that? Can you see such a path, with forward slashes, when you check your own media files, downloaded from Ancestry?

Putting aside the SQLite issue, this is an extremely puzzling thread.

  • Immediately after a fresh TreeShare download, the number of broken links should be zero.
  • The Media Folder setting is completely irrelevant to this issue because the Media Folder setting only applies to media files that are not downloaded via TreeShare. Media files that downloaded by TreeShare have their own media folder that’s established by RM and there is no user setting for where it goes.

Despite my concern about the RM database itself being in iCloud, there is generally no concern in the Windows world about media files being stored in a folder which is synced with the cloud. I’m a Windows user rather than a Mac user, so I don’t know if that same generality applies to a Mac or not.

With the caveat of how little I know about a Mac, it certainly seems suspicious that the files with the broken links are all in iCloud. So here are a couple of questions.

  • You said you found the folder where TreeShare had downloaded the media files. Did you try opening any of the media files from outside of RM? If so, what happened?
  • iCloud appears to have a mechanism to pause the sync with the cloud and to resume the sync with the cloud. I can’t check it out, but apparently there is a button for pause and resume in Finder. Have you tried pausing iCloud while you are using RM and resuming iCloud while not using RM?

In another message, you wrote that you had about 93,000 persons and 6,000 media files. And here you report that 64371 links were not fixed. Does that mean that you really have over 60,000 media files?

I’m sorry, but that really isn’t correct. The media folder setting is not really a “default”. Rather, the media paths in RM8 and RM9 are relative paths. The media folder setting is the base folder for the relative paths for all media files except those downloaded by TreeShare and the media folder setting does not affect the relative paths at all for media files downloaded by TreeShare. That’s why changing the media folder setting after linking media files into RM typically will cause all media links to be broken except for media files downloaded via Ancestry. So the media folder setting has everything to do with how RM finds media files after they have been linked into RM.

The media folder setting does have the additional function of being the default place where RM opens when you are linking new media files into RM. But that is of minuscule importance as compared to the function of being the base folder for relative media paths.

Not sure I understand this statement. That would seem to mean that any change to the Media folder setting would immediately make “some” media files become unlinked. That is not the case. It appears to be just as Renee states, with the proviso that if left blank, File Explorer opens to the last visited folder.

For example, one can media in many disparate and not “relative-pathed” folders without any resultant “not found”.

I need to amend the “all” part of my statement. Changing the Media Folder setting would immediately break all media links that are homed relative to the Media Folder setting. And not all media links are homed relative the Media Folder setting.

  • If you established a Media Folder setting prior to linking any media files into RM, and if all your media files are stored in that folder or any if its subfolders, then then all your media links will immediately be broken when you change the Media Folder setting, I think this situation could affect a lot of RM users which is why I said it would break “all” media links. But my error was oversimplifying and assuming this would affect all RM users. It would not.
  • If you established a Media Folder setting prior to linking any media files into RM, and if some of your media files are in that folder or any of its subfolders, then all your media links for files in that folder and any of its subfolders will be broken and all your other media links will be fine when you change the Media Folder setting.
  • If you did not establish a Media Folder setting at all prior to linking in media files into RM and if you then establish a Media Folder setting, the links for all existing files will be fine and the new setting will only apply to media files you link in the future when you change the Media Folder setting.

In other words,it’s complicated. My recommendation is to set the Media Folder setting before you link in any files, or else just leave it blank and keep leaving it blank.

There’s even one further complication. If the Media Folder setting is blank or if you do have a Media folder setting and if you are linking in a new file that’s not in that folder, RM will try to establish a relative path that is homed to your “my documents” folder. I put “my documents” in quotes because software such as OneDrive and Dropbox can take over your normal My Documents folder and make it into a different “my documents” folder that they control. Finally, if all that fails a newly added media file will be homed back to the C:\ folder on Windows and back I think to the /Users folder on a Mac (but Mac users should correct me if I’m wrong).

1 Like

This is not really true, unless you mean the word ‘should’ to indicate that it should happen this way if there were no bugs.

This thread reported on a systematic bug in Treeshare in which links to all HMTL files are lost, and the links are not fixed by the ‘fix broken links’ tool. I am not aware that the bug has yet been fixed. The bug is that text files created in Ancestry are stored there as .html files, passed to RM as such and stored by Treeshare as such, but the links are all created as if they were .jpg files.

As I reported in the earlier post, I found JillV’s tip very useful in fixing my broken links.

However, I doubt that that is the problem here, as it would be an unusual Ancestry tree that only had text files in its gallery.