Downloading from into RM7 - is media included?

I recently launched a new computer and successfully installed a fresh version of RM7 with my reg key. I transferred my RM files to the new computer (Win10) from the old (Win7) but the media files are not being detected in RM, even though the file path looks correct. I was wondering if I downloaded a new copy of my tree to RM if the media items would be included.

Did you transfer the media files to the new computer when you transferred your RM files?

Yes I did and they’re in the same folder on the new computer as the old one. But RM isn’t recognizing them for some reason when I attempt to repair the link. The file path looks correct, so I’m quite puzzled. With so many to ‘repair’ I thought perhaps downloading a fresh copy of my tree would be an easy option. Thanks!

Is your RM database in the same folder on the new computer as the old one? Believe it or not, this has an effect on where RM finds media files that initially were downloaded from Ancestry.

Is your Windows userid the same on the new computer as it was on the old one?

Thanks for writing! My RM dBase was not in the same folder on the new computer, but it is now thanks to you.

As for my Windows userid, I’m not sure it’s the same as I never paid much attention to it before and still don’t.

Now that RM is back in the same folder, I’ll check the media files and hope for the best.


Moving RM files to the same folder did allow the ‘fix broken media links’ to work except for those attached to records like census reports imported during tree sync. With 4545 people, 3621 multimedia items and 11,247 multimedia links in the dBase, it would take ‘forever’ to relink them all! So I’ll try renaming the current dBase to xyzOLD, back-up and close it, then import the tree again from ancestry with my fingers crossed.

To those who may read this for tips on how to repair their own similar/same situation, please note that when moving my RM7 files to the same folder as what they were in on the old computer, when I opened RM, my dBase wasn’t there. I had to redirect RM to find it in its new location. No big deal, but commenting for others behalf.

Thanks again TheJerryBryan!

RM expects to find your media files that were downloaded via TreeShare in a subfolder of the folder where your RMTREE file is located. If you can put them there on your new computer with the same folder name, then RM should be able to find them on the new computer without having to do anything else.

In the case of your other media files, you have already solved the problem. But now that I know how you had things set up, there might have been a simpler solution. RM8 supports relative media links. Assuming you had your default media folder on your old machine set to where your media files really were, you could have set your default media files option on the new computer to where they really were on the new computer and that should have fixed the problem on the new computer.

The reason I asked about the Windows userid on the old and new computers is that the Windows userid is part of the file path for most of your files. In RM7, that file path was hardwired into the location that RM7 stored for each media file. In RM8, the userid would be part of the the path for your default media folder option.

Thanks again. I fixed it by selecting List in the top banner, then chose media files, then Tools, then repair. Hooray!