Empty Ancestry Gallery

I’m using Rootsmagic 7 with Ancestry and finding the program really useful.

However today I hit a problem.

I had cause to upload an archived Tree to Ancestry.
Everything went fine, except that the media items which had been in the Ancestry Gallery for various Profiles were missing.
I downloaded the Tree back to my PC and the Gallery items were all there in the downloaded media folder.

So they are obviously there in the uploaded Tree, but I can’t see them!

Does anyone recognise this problem ?
Or know where the ‘missing’ media items are ?


I think I can provide a partial answer, but not a complete answer.

Let’s suppose you work completely in Ancestry and never use RM. You can use Ancestry to build a tree. You can use Ancestry to find images in Ancestry’s collections of images and you can link those images to people and facts in your Ancestry tree. Those linked images become your Ancestry media gallery.

When you upload your RM database plus images, your images are stored separately from the images in Ancestry’s collections and they do not show up in Ancestry’s media gallery. You can access your images from your Ancestry tree and other Ancestry users can access your images from your Ancestry tree if you make your Ancestry tree public.

I do not make my Ancestry tree public, and I no longer upload my images to Ancestry. That’s why my answer is only partial. I know that if I upload my images to ancestry I can access them from ancestry, but I don’t remember how to do so. I just know that they are stored separately from Ancestry’s own Media gallery.

Thanks for getting back to me.

All the Ancestry content is there as expected. What are missing are the photographs, newspaper cuttings, etc. put on the site by other Ancestry Users. These appear in the Gallery of each Profile page.

Except that they don’t! :wink:

Though they are all still there.

It gets worse!

There are 315 media items (Ancestry + User) associated with this Tree.

I just downloaded the Tree to RootsMagic again and there are only 230 in the Media folder.
So all the user-added media files have been stripped.

This is terrible - I can’t continue using the program is it’s going to lose data!

I’ve isolated the error process.

Fortunately, I have a backup of the RootsMagic version of this Tree.
If I upload this to Ancestry, everything works fine.
I download it, and there are 315 items in the Media folder. Great.

If I then change anything on the Tree in Ancestry, however.
All the user media items get stripped.

Any ideas ?

Many people use the database on their computer as the master file, upload that to ancestry for hints with or without media but manually add any new finds to the computer file not to ancestry. Then you can sync up and not mess up your master file. It sounds like you worked mainly in the ancestry website and only recently started using a genealogy program on your computer which may change how best to work.

Thanks Rooty, but, sorry, don’t buy that one.

RootsMagic doesn’t work correctly with Ancestry (as it advertises that it does) so I should change how I work?

Tail wagging dog, I think.

I really just want to know: (1) is this a bug with Rootsmagic ? (2) is it something I am doing wrong ? (3) how do I make it work ?

So far I don’t seem to have found anyone else with this problem, so perhaps it’s (2).
However I contacted the Rootsmagic Helpdesk and my experience doesn’t fill me with confidence.
I got asked a couple of obvious questions - are any of the media files marked as errored (red cross in the corner in Gallery) ? Are any of the files not picture format ?
When the answer to both these was ‘no’ I got told to try the HelpChat !!

Sounds more like Ancestry isn’t working correctly with Rootsmagic. Rootsmagic can’t get what Ancestry doesn’t send. Why Ancestry is not making the file available, your guess is as good as mine.

RM7 has only one field for Person and General Media, Ancestry has two. There is an issue with the upload of media marked primary on the person row uploading to Ancestry. It should upload with a new tree, but won’t if you try to add it later. I can’t recall now if any general media will upload after the fact or if its just what’s marked primary. I know you have to at least uncheck it as primary. You may need to move it temporarily to another fact to upload it. This issue was resolved in RM8.

Thanks for the replies, and sorry not to get back to you sooner.

Could you please elaborate, rzamor1 ?

<RM7 has only one field for Person and General Media, Ancestry has two.>
So presumably this is a change that Ancestry has just made ?
Hence RM7 no longer working correctly ?
What is the extra data field used for?

<There is an issue with the upload of media marked primary on the person row uploading to Ancestry. It should upload with a new tree, but won’t if you try to add it later. I can’t recall now if any general media will upload after the fact or if its just what’s marked primary. I know you have to at least uncheck it as primary.>
What is ‘Primary Data’ and how do I ‘uncheck it’ ?

Looking online, there appear to be multiple problems with RM8 so I was reluctant to upgrade. Do you think that it is now stable enough ?

Thanks again, you seem to know a lot more about the inner workings of RM than I do !


There’s a reason for that. She is an employee.

Note the shield icon to the right of her username (hovering over that icon with a mouse pointer reveals her role as a Moderator here)

RM7 always had the issue of mismatch fields to support all the fields in the Ancestry API. This Magic Guide written for RM7 explains the differences. With RM8 we wrote it to resolve this issue. RM8 is very stable now.

Thanks again, rzamor1.

I bought RM7only months before RM8 was released, so I was reluctant to basically have to pay twice for the software. But it looks like I have no choice.

Is there a working group between RM and Ancestry ? RM seems to get caught out repeatedly when Ancestry rolls things forward and introduces a disconnect between the two.

Sorry to be a nuisance, but one problem leads on to another.

I bit the bullet and upgraded to RM8.
I loaded my Tree into RM8, converted it to the new format, and fixed the broken links to the media (only 308 media items found rather than 311 in the Media folder, but I can live with that).

I deleted the Tree causing the problems in Ancestry.
And tried to upload from RM8.
But I now get the following error message:
“This file is linked to an Ancestry Tree, but your login doesn’t have access to that tree.
There are a number of possible reasons …”

On RM7 there was a button to break the link between a RM Tree and Ancestry.
I can’t see any way of doing this on RM8.


You wouldn’t have bought it twice. There were plenty of offers out there to buy RM7 and get the key for RM8 when it was released.

Settings (gear icon on the left side) → WebHint Settings (Light bulb icon on the top) - Disconnect from Ancestry Tree (at the bottom of the Ancestry section).

Where did you buy RM7 from? Under your name I can see registrations for RM7 and RM8 but not the purchase through us. You can email sales@rootsmagic.com to have them check if you were entitled to a free upgrade to RM8.

I bought RM7 through S&N Genealogy in September 2020 - so not as recent as I thought. Then bought an update key through the same today.

So please forget my moaning about paying twice. :wink:

Thanks Kenneth - found it !

I still have a problem, though. :wink:

I converted my archived Tree to RM8 format - 308 media items all linked correctly.
Uploaded it to Ancestry - everything looked great, even the profile pictures were in place.
Downloaded it back to RM8.
And there are 250 media items.
Though the user created items (such as photographs) are all there now.

Any ideas ?