TreeShare for Ancestry - Media Download crash

I was importing a tree and it got all the people and info, but froze when downloading media. I now have a bunch (5000+) media files that say “File Not Found.” Is there anyway to resync this tree (media) without starting over?

No, start over, rinse, repeat until you get a clean, complete download.


Only took me about 10 tries!

FTM has a feature that indicates the quality of the Ancestry service via its API and it’s called “Internet Weather”. For several months now it has been mostly “orange” and its guidance is “do not sync”. I think RM faces the same turbulence through the API and that has caused your difficulty.


FTM sync has been down 2 months (Orange) but RM9 can still upload a tree and sync which may indicate they each use a different api. RM also takes much longer to sync but this is probably a programming difference. FTM support keeps muttering about Ancestry not fixing their server loading issues.

My understanding is that you get much better import from a gedcom than an ancestry download.

I have experienced the same thing. Downloaded the file; froze on the media download; and now I have a file with thousands of broken media links. Frustrating. I have chosen to continue to work on the file and sync what I can, but I will eventually attempt to download a clean file. The problem is that I also want to sync to my Family Search file. Having over 25,000 individuals in my file complicates the process I think and frustrates the sync of all three files challenging.

1 Like

I have this exact same problem. No support from RM, and I did do a long chat with tech.

1 Like

Syd, the agent you contacted on Friday still has your ticket. They have been off for the weekend. Please be patient.

Thanks, Renee, I really appreciate your email. Things take as long as they take, I’m just glad to get confirmation that it’s in the queue.
Have a great week.

Hi Renee, do you have a moment to update me about the Ancestry to RM9 on a Mac problem I had a few weeks ago?

///Short story - I downloaded the file, pics were messed up, tech fixed some of it, couldn’t say what problem was, I need to know so I can download in the future, as I don’t think tech wants to do monthly downloads for me.///

There may be “no answer”, and it may be on Ancestry’s end.

Thanks, Renee.


When I tested the download I had no issue with corrupt media. It may have been just an issue with Ancestry at the time when you downloaded. Try doing a new download and see if that works for you.

Did RM ever fix RM9 TreeShare for Ancestry media download problem? It still locks up on the media download. No problem on RM7 or RM8. Been battling with this since last March when I received RM9. Tried to download again last month 15 times no luck. But I did get a partial media download of 9 items only out of 2900 items. But that’s when I disconnected Norton-360 w/vpn and two-step verification. Still no luck.

Thanks, TJ

If this were a RM9 issued to be fixed, pretty much everyone would have the same problem. It is time to consider this may be something more specific to you and your file than to the program.

Have you considered emailing They are in a far better place to diagnose this. They may request access to your file, or even to TreeShare to see if they can replicate your problem.

Fixed: It took me a while to find the problem. It was the anonymous search engine I use DuckDuck Go, then after switching to Google search engine everything worked fine after that.


That’s an unsuspected cause. What could the external browser’s default search engine have to do with the RM TreeShare operation? Could this be merely coincidence? Does the issue resurface if you reset the browser’s default to DuckDuckGo?

Tried it with 10 different files the downloads and each time with DuckDuck Go the download would crash the downloads. Then with the same files using the Google search engine they downloaded with NO problem at all.

switch and reset search engine, restart PC, do one download at a time, then start all over again for each and every download.

1 Like

Interesting! I am also using DuckDuck Go for my default search engine and TreeShare behaves as expected, or at least it did as of about an hour ago when I was using TreeShare.