Won't Change Fact Types to a Different Fact with the Same Name

I discovered that I have two Election fact types in my database - the built-in one and a user defined one. The user defined one came into my database decades ago via a GEDCOM import. The built-in one had no uses and the user defined one had one use.

In RM7 I was able to change the person’s use of the fact type from the user defined one to the built-in one without difficulty. In RM9 I was not able to make the same change. When I tried to do so in RM9’s Edit Person screen, it kept going back to the user defined one. There was no error message or Access Violation error or anything like that. It simply chose the Election fact type that I had not highlighted instead of the Election fact type that I had highlighted.

I solved the problem by renaming the user defined Election fact to the Flection fact. After the rename, I was able to change the user defined Flection fact to the built-in Election fact without difficulty in RM9’s Edit Person screen. At this point, since the user defined Election fact in RM7 and the user defined Flection fact in RM9 were no longer in use I was able to delete them in both RM7 and RM9 without difficulty.

RM (64 bit), Windows 10 with all updates current

@thejerrybryan I was able to replicate the problem on RM 9

and the birth 2 fact didn’t change UNTIL I click on the highlighted Birth2 again or any other fact-- takes anywhere from a second to abt 10 seconds to respond-- Windows 11–latest update

Whenever I’ve had two facts with the same name I’ve always changed the name on the user created one, so I can tell them apart. I can see now that it also services a purpose in allowing you to change the fact type used. If you are have two facts by the same name the Save button won’t appear when you try to switch to the other fact by the same name. It’s seeing them as the same fact type. So make sure to modify one name when changing a fact type.

I’m not seeing any delay when changing the Fact Type name.