Windows 10 [Oct 2022 Update] + RootsMagic 8 + FamilySearch

We’ve received reports from some users who have installed the Windows 10, October 2022 updates (version 21H1 or 21H2) and have discovered that RootsMagic 8 can no longer log into FamilySearch.

After some investigation, we have learned of a known issue in Microsoft’s update that can break the TLS internet security protocol. This affects not only RootsMagic 8, but many other products, including some of Microsoft’s own software.

We haven’t yet found any workarounds that we or our users can use for this problem but will keep investigating. Hopefully, Microsoft can fix and patch the issue on their end soon.

To be clear, this issue only affects RootsMagic 8 (not previous versions) running on Windows 10 with the latest Windows updates. Windows 7, 8, 11, and macOS are unaffected. And not everyone who has Windows 10 with the update appears to be affected.

If you have Windows 10 and have not yet installed the October 2022 updates, we recommend you hold off on doing so.

If you have Windows 10, have installed the October 2022 updates, and cannot connect to FamilySearch using RootsMagic 8, you may try uninstalling the Windows 10, October 2022 updates to restore functionality.

We (and others) are watching the situation and hope to have a solution soon.

1 Like

I’m a sample size of one, but I have found Windows updates to be profoundly difficult to control. They are not impossible to control, but a great deal of effort and knowledge are required to control them. Microsoft really, really wants all their users to install all their updates immediately.


It was much easier in the past when we had control of when and how update were installed. There were many update that I selected “Ignore this update” to not have it installed.

I guess that updates breaking things is par for the course on both Windows and mac. The mac users are constantly posting about what works with Monterey, Mojave, Toothpick or whatever version of their OS is current.

Thanks, Very new to RM8 and was getting frustrated trying to publish to familysearch,

I was just now looking into removing the Windows update that caused the problem. It doesn’t look very easy.

The update had two parts, an SSU part and an LCU part and I have no idea what that means. The documentation also says that the SSU package cannot be uninstalled. You can uninstall the LCU package, and the directions are not very clear on how to do so. Apparently, it has to be done from the Windows command line rather than from within standard Windows user interface. The directions say the following:

… use the DISM/Remove-Package command line option with the LCU package name as the argument. You can find the package name by using this command: DISM /online /get-packages.

Unless somebody can post some very clear directions, I think I’m just going to live with the problem until Microsoft and/or RootsMagic can provide a fix. And for example, I don’t know if deleting the LCU package will solve the problem or if the problem is in the SSU package which cannot be uninstalled.

1 Like


Maybe I’ve missed something however according to the family search developer tools TLS version below 1.2 is no longer supported by them either. As of march 2021

For those of us who are more techy there is a way to re-enable previous tls versions under inter et opinions. KB5017811—Manage Transport Layer Security (TLS) 1.0 and 1.1 after default behavior change on September 20, 2022

1 Like

This is my understanding. FamilySearch ONLY supports TLS 1.3. Ancestry will support 1.2 and 1.3. The update to Windows 10 breaks TLS 1.3, thus breaking FS support and why Ancestry is still working.

1 Like

Could this be the cause of RM8 not finding FSFT matches? Even when I have entered the information into FamilySearch myself, know and enter the ID into RM8 and have both programs up side by side, the matches do not appear.

1 Like

Could this be the cause of RM8 not finding FSFT matches? Even when I have entered the information into FamilySearch myself, know and enter the ID into RM8 and have both programs up side by side, the matches do not appear.

If you have that Windows 10 update it could be.

Mac users are not troubled by OS updates which all work smoothly but are much less frequent than on Windows. I think you are misunderstanding whatever postings you are seeing from mac users.

I was referring to posts like this one:

Oh dear! RM7 still works on mac Mojave so I warned my spouse she will lose RM if she upgrades the OS. Still using Mojave to keep the Overdrive app functional to put library audiobooks on a 2007 ipod nano (amazing life).

And several others. Just do a search for “mojave”

Yes-that was my post but the problem is the RM wrapper not the mac OS which are just fine.

I don’t think Rwcrooks assigned blame to the OS, RM or the wrapper. He simply stated that people were posting enough that it was apparent when there was a problem. He simply used your post as an example.

Microsoft has released an emergency (out-of-band) update which appears to fix the issue with their previous update. Can any of our adventurous users who are having this problem try downloading and installing this Windows update to let us know if it fixes the issue for you?

Here is info about this update:…/october-17-2022…


There has been something on and off at FS central, yesterday off. The new update means that I can now log in.

But Rooty,
My point was that sometimes OS upgrades cause already installed an functioning programs to stop working, which was what your post was about. That s happens with all OS flavors.

Things can always be programmed to be backward compatible but forward compatibility is mainly luck and the favor of the gods.

Felt adventurous and downloaded the 64-bit fix for 10Pro at 21H2 level and it worked a treat.
Thanks for the heads up.

The 64-bit fix worked for me. Thank you so much!

I had already update to Window 22H2 but installed the 64-bit fix anyway. It took several minutes to install (the green line stalled for a long time). I was then able to download my Family Search info without any trouble.