Error Roostmagic has stopped working

I updated my rootsmagic to latest version. An error popped up saying “rootsmagic has stopped working”. I contacted Rootsmagic but they had no suggestions to fix the problem. Has anyone had the same problem.? I had version 8.1.7 that works. I have Windows 8.1 on my laptop computer. I have deleted rootsmagic and reinstalled using the latest download but still get the same message. Rootsmagic version 8.1.7 works but not very good. If I cancel on the error message then Rootsmagic will work and I can access my files. After closing my file with the red “X” I get a blank screen and have to click on the X again to close the program. When I open the program again I get the same error message “program has stopped working”
It is a bother to go to the setup every time I open Rootsmagic after clicking the “cancel” when program is loading.

It looks like support was a seeing a permissions issue. They wanted to make sure you had the admin login. They advised that you to return to chats and have Jackson remotely view your computer. He is usually here in the morning and early afternoons.

I spent the morning on a chat with Jackson. He said it could be a problem with my windows installation. Rootsmagic 8.1.7 works fine. The problem is when I try to do an update, I get the message “rootsmagic has stopped working”. Jackson suggested I need a computer tech to check my computer. I like rootsmagic but not enough to pay the price to have my computer checked because one program will not work. I had been using Legacy family tree which works fine. Jackson also suggested I post again on rootsmagic community to see if anyone has a suggestion I could try. So here I am hoping someone has a suggestion.
I can access the program if I click cancel in the error window before it completes loading. I get another error “Unexpected Error failed to create instance of Edge browser engine” Choices are "Send Report or “Dont send”
Whichever I select and send or dont send the program opens. When I then close the program and try to reopen it I get the error messages again.
Any help or suggestion. Version 8.1.7 is not a stable version of rootsmagic. I need to have the latest version.

What’s your reasoning for not updating Windows 8.1 ? Support for Windows 8.1 has ended on January 10, 2023. I’m sure that’s not the problem, but RootsMagic 8.2.7 is the latest and runs without problem for most everybody.

Many reasons for not updating. All my programs work except Rootsmagic. I know support has ended for Windows 8.1.

1 Like

You can use Windiws 8.1 for as long as it works.
But my advice would be to never connect it to the Internet.
Security updates are no longer being created and hackers are just waiting for you.

1 Like

Did you check your firewall? I’ve seen reports where the error “Unexpected Error failed to create instance of Edge browser engine” was resolved by adding RM to the exclusions list. If not the firewall check your other security software.

Thanks for the suggestion. I am not sure how to add it to other security software. Jackson did add RM to firefox but can’t remember what he did. He did it quickly so I could not take notes. He did send me a previous update of RM8 dated June 27 version 8.2.0. I installed that with no problems. There are two later versions (8.2.5 and 8.2.6). I would like to have those to try and get a better version if I can’t get the latest one to work.

Thank you

Jackson shouldn’t have given you what he did. We don’t want users on older versions of RM8. Firefox wouldn’t have anything to do with the error you received its a different browser. It’s looking for Edge and the “Microsoft Edge Webview2 Runtime Installer” on the download page should work. You could try installing the Edge browser itself and see if that helps. I think there is a version for Windows 8. With your security software I would recommend you google or contact their software support to see about getting RM8 on the exclusions list.

Not really a solution, just a suggestion: Have you tried doing a complete re-boot of your system? Sometimes that will correct a flaw.

I hope I did not cause any trouble for Jackson by telling I had an earlier version of Rootsmagic 8 from him. At least that version is working. We did install the Edge Browser and “Microsoft Edge Webview2 Runtime Installer”. Windows 8 is not longer supported so I cannot contact them for any help. Since the only version rootsmagic supports is 8.2.7 then I guess I am not going to be able to use the program. I thought I was going to get support when I purchased Rootsmagic 7 to get the free upgrade to Rootsmagic 8. I thought someone might know why a previous version will work but not the latest.

I thank everyone for their efforts in trying to find why the latest version will not work on my Windows 8 laptop computer. The previous version will work but has flaws so will not be using it.

Maybe someday they will come out with another update and then will try again.
Thank you again

The previous version interfaced to the Internet Explorer browser engine which has been deprecated for quite a while. Microsoft Edge and its Webview2 Runtime took its place and RootsMagic had to switch along with all Windows users.

By ‘previous version’, the OP is comparing 8.1.7 to later updates, including 8.2.7. What Jackson did by supplying him with the older version confirms that something did change in a RM8 update (not the upgrade from RM7) which has broken it on Windows 8. Both versions of RM8 use the Webview2 Runtime.

Not all Windows 8 users are having an issue.

I finally found a way to get rootsmagic 8 version 8.2.7 to work on my windows 8 computer. I copied the the rootsmagic.exe file from my computer to a flash drive. The program opens with no error message. If I open it using the desktop rootsmagic icon the program starts to load and then I get the error message. So I am going to keep using the program from the flash drive. I don’t know much about how windows work but it will run the file from the flash drive with no error. Just glad I can use the latest version. Hopefully I can continue to use the method with no problems. I am curious to know if anyone has an answer as to why it will run from flash drive with no errors, but not from the computer hard drive.
Thanks for all the comments and help.

If RootsMagic.exe runs well from a flash drive, it suggests that in a standard setup the program is trying to write to the program folder, i.e. inside C:\Program Files (x86)\RootsMagic 8, or to another location inside C:\Program Files (x86). And that’s a protected folder, that should only be accessed during installation. When the program is run, not as admin, Windows may block access to that folder, and trigger the error.

If this is the case, you can try if installing to C:\Rootsmagic 8, or something similar, helps. You may also try D:\Rootsmagic 8, if that drive is available. Any folder is probably right as long as it’s not inside C:\Program Files, with or without (x86), or C:\Windows.

RM should be installed in the Program Files (x86) folder. You’re not putting the database inside that folder too are you?

Windows 8.1. Isn’t that 32 bit? You have check the amount of disk space? How much memory?

No my data files are on my hard drive (C:\Rootmagic 8 Data). I copied the Rootsmagic.exe files for C:\ProgramFiles (x86) to my flash drive. Rootsmagic will open when I click the exe file on my flash drive. I then open the data file on my computer hard drive. Thanks for you input. As long as it works using my flash drive I will use it that way and wait for another update to see if it will work from my hard drive.


My computer is a 64 bit with 8 GB of ram and 852 GB free space on the hard drive. Thanks for asking.