Unexpected Error, Access error

I don’t know what is on with my RootsMagic8.
I was working on it doing updates to my family tree. I closed it and then went back a very short time later. This is when the issues started.
Now when open RootsMagic, it takes forever to open into the start screen. I am referring to the screen before you pick the data file.

The opening screen for News, Help and Support, and Updates, all say Can’t read via internet.

Also, when I click on “try again” or the refresh icon for the Help and Support, and Updates window, it just gives me a spinning circle and some back again saying “Can’t read via the internet”.

When I click on the refresh icon for the News window, it also gives me a spinning circle and some back again saying “Can’t read via the internet”.

However, when I click on “try again” in the News window, it gives me a message saying, “Unexpected Error, access violation error”. See attached image.

I have closed RootsMagic and shut the computer down and restarted it. I continue to get this issue and error.

I did not add or remove any programs on my laptop. I haven’t done anything except work on RootsMagic and Photoshop.

Has this started happening to anyone else?
I am afraid to use my RootMagic because of this. I fear it may screw the data file up or may cause other issues.

What should I do or how can I resolve this?

I am using Windows 11.


It’s now working correctly again.
I didn’t do anything. I worked on another project on my laptop for about two or three hours.
I tried it just now tried RootsMagic and it is back to normal.


There was an issue with the RM servers late yesterday which caused RM8 to open slowly and the Home page not to load. It was resolved later that night.