Windows 10 Browser needs updating when it doesn't

When I use the web search option in Root Magic 7, and go to any website it won’t allow any saving. I get a pop up saying the browser I’m using is out of date or needs updating or I might need a new browser. Then it will say to use Chrome, which I have also. Nothing I’ve been doing is working. I’ve tried updating, re-installing and restarting the laptop every time I make a change. I’ve added all the Root Magic applications I use to the exception list in the firewall. Nothing seems to help. The browsers I’ve tried, Chrome, Microsoft Edge, and Windows Explorer which is now File Explorer. There’s no way all 3 of these browsers are out of date. It has to be something else. Please help and please be patient as this is my 1st time here and I’m not exactly tech savvy.
Thank You, fallinstarzz50

To avoid this “out of date” message one should checkmark the option “Use external browser” in RM7 and/or “External browser” in RM8:


1 Like

I suspect you are wanting to use the RM7 feature that allows saving of the data you find on a Web site, bringing it automatically into RM. The automatic saving feature requires the use of RM7’s internal browser. But RM7’s internal browser is broken. Therefore, you must use the “Use External Browser” option. Using an external browser does mean that the search function will work again, but the automatic saving feature will not work using an external browser.

I have not yet investigated the status of this issue in RM8. Is the automatic saving feature available in RM8’s version of WebSearch? I see that there is a check box to select internal or external browser. Does the internal browser feature work in RM8?

Similar web search questions:

With similar answers. Internal display of web search just doesn’t always work in RM8. Have to tick external.

Thank you for taking the time to assist another Root Magic Subscriber. I’m going to take your advice and try it now. Wish me luck only because I’ve had browser issues before with something else on Root Magic 7 and 8. But, I’m unable to tell any specifics at this point. I will be keeping track of it now though if it occurs again.
Thank you again. Lana

Thank you again for informing that RM7 has browser
issues and were only able to use external browsers, because it worked! Hooray for that. I mentioned i would keep track if it happened elsewhere. Well, unfortunately it did. It happens every time I try to backup my Tree to either Dropbox or… Can’t recall the other one offered besides saving it to your hard drive, which is the only method Im able to do at this point because it says my browsers isnt up to date. I took screenshot. Any help is extremely appreciated and i thank you.
P. S. Apparently new users can’t upload anything. Oh well, guess I need to be patient.

The backup to Dropbox is also broken in RM7 due to a change in Dropbox itself. If you wish to backup to Dropbox, you can backup to a folder and choose Dropbox as the folder to use.

Ok. Thank you for the information. I appreciate your prompt response and your willingness to help. I am only using RM7 because I couldn’t catch on how RM8 worked. RM7 I just bought 3 months ago and just got use to it. But, I’m starting to think everything is broke in RM7 and I better start learning RM8 rather I like it or not. The older you get the harder it is to learn new things.
Thank you again, Lana

RM8 is using outdated IE for internal browser. I hope it gets updated to Edge as websites aren’t liking IE. External browser works as it uses your modern default browser.

Edit: RM 8.1.1 now uses Edge!

1 Like

in my opinion RM7 is a very stable program. I work on genealogy full time and rarely have encountered error messages, except now and then when using FamilySearch. I find the pedigree view easy to use and so much easier on “old” eyes than RM8 which is prettier, but harder on the eyes. The notes are easier to compose and edit in RM7, and I use the spell check feature a lot which is missing from RM8 for now. I find the sources easier to use as well. But I keep following this forum and may return to RM8 in the future when the bugs and missing features I have been used to are incorporated into the new version. I did lose some user defined facts on going back to RM7 via gedcom.

I do hope that Bruce will consider keeping both RM7 and RM8 available for purchase.
The intuitive nature of the various RM versions prior to RM8 have made them very useful in introducing new researchers to genealogy as a hobby and the use of using a computer program for genealogy work. I find little intuitive with RM8. It makes me think of when I occasionally tried to use TMG.

Hello, this is Lana. Thank you for your response. I’m always appreciative when offered help in anyway. So, I thank you again.
I’m new here and reading everyone’s issues are over whelming! Between RM7 and RM8 and all their quirks, I’m wondering if there will be a day when everything works correctly?
I’m unable to save any backups to Google Drive and Dropbox still. It says my browser isn’t secure and i need to switch to a different one. I’m using RM 7 and I’ve updated Edge to the new Chromium and i have Internet Exployer 11 now and Google Chromes been updated. Spent all weekend almost trying to get drivers updated also. Also added RM 7 to the Firewall Exceptíon List. When it was all said and done, I still wasn’t able to use either one of those apps for backups. I wanted to pull my hair out and scream. I’ve just given up because that’s too stressful as well. Lol . . Must be the holidays…But if you have any suggestions I’m open and willing to try as I love RM 7.
Thank you for taking the time to listen to me rant and complain, Lana

Forget Backup to Gdrive or to Dropbox in RM7. If you have updated RM to v7.7.0.0 (or latest version if I got the numbers wrong), you’ve done all you can do. Instead, you can revise your RM Program Settings so that the default Backup folder is one inside your local Dropbox, Google Drive or OneDrive folder. Then simply use the conventional Backup function to save to the local folder and the background cloud sync will take care of copying it to your cloud folder.