When Do the Save and Cancel Icon's Appear in the Note Editor

This isn’t actually a question, but I couldn’t quite figure how else to formulate the title for this message.

The RM8 note editor uses icons for Save and Cancel rather than words. The Save icon is a checkmark and the Cancel icon is a circle with a slash across it. Until very recently, these icons did not appear until and unless I had made a change to the note I had just opened. This provided a visual cue as to whether or not I had made a change in the note. The icons now appear immediately after opening a note. Therefore there is no longer any visual cue as to whether the note has been changed or not.

Neither RM7 nor any of its predecessors has any such visual cue. I always wanted the note editor to work more like a word processor or text editor with respect to Save and Cancel. With word processors and text editors, there is nearly always a Save and a Cancel and an Exit. In this model, Exit always “just works” without producing any warning if the file has not been changed and Exit gives a warning if the file has been changed without doing a Save. So I was much hoping for this feature in RM8.

Well, RM8 had this feature - sort of. The way it worked in RM8 was not identical the the very useful behavior of Save and Cancel and Exit in word processors and text editors. But at least RM8 did not show the Save and Cancel icons before anything was changed in the note. Now it presents the icons from the beginning. I don’t remember when the behavior changed. Was it on or on In any case, could we get back the behavior where Save and Cancel don’t show up until and unless the note has changed?


Jerry, I just figured out where the indicators are (at least in version 8.1.0, which I just updated to):
If you change something and haven’t saved it yet, a dot appears to the left of the field that has been changed. In this screen shot, I cut text from the Detail Comment field, and pasted it to the Page Number field.

I know about the dots. I’m talking about while you are still in the Note Editor itself. You can’t see the dots while you are in the Note Editor. It’s while you are in the Note Editor that you can’t tell if anything has been changed because the Save icon is always on inside the Note Editor unless you have clicked it, whether anything has been changed or not. Unless I’m remembering incorrectly, this is fairly new behavior in RM8 that wasn’t there in the beginning. That’s what I’m asking about, and it’s very confusing.

After you unslide from the Note Editor, the dot does tell you correctly whether something was changed or not. But after the unslide and the dot has come on, you can’t tell if you clicked Save before the unslide or not. I guess the reason you can’t tell if you clicked Save before the unslide or not is that it doesn’t really matter. Clicking Save didn’t actually Save anything. All it really did was turn off the Save and Cancel icons. You still have a chance to cancel after the unslide, even after you already clicked Save. As I said, it’s very confusing. But confusing or not, It would be helpful to know whether I have changed something or not while I’m still in the Note Editor.

RM7 didn’t tell you if you had changed something or not while you were still in the Note Editor, but RM8 did until recently. This is a very basic feature of virtually every text editor and word processor in the world. So I wish it would be supported properly in the RM8 Note Editor.

I understand your point and I agree with you. I did notice, however, as I was adjusting fields in a citation, and typed the same data that was there previously, the save button disappears as there was nothing to save.

I have seen the same thing. If you “change” a note to what it already was, the Save button goes away. It’s just when you first open the note that the Save button is there.

There is a new version of the Note software to fix the Paste problem. I wonder if the new version of the Note software introduced the new behavior of the Save button.

If my memory serves, this behavior was commented on in the Facebook group before the latest update. It might have been the update that included the character map and aided the use of diacritics that caused this changed.

It has been a Source of confusion for years. A search of the fb group turned up nothing on RM8 but this goes back to RM6…

Yes, I agree it is confusing when you click on Note in the edit screen and the check mark automatically appears even when you haven’t entered anything. It worked correctly when RM8 was released where the check appeared after entering data.

1 Like