Unexpected Error: "Instance of "Tabulmage" not created" - RM9

I am a new RootsMagic user. I downloaded RM8 and then downloaded my Ancestry tree, but didn’t have a chance to do anything beyond that. I upgraded to RM9 after RootsTech 2023, which seemed to go fine. It is in MY DOCUMENTS folder, same folder as RM8. I went to download my tree from Ancestry (I’d made changes since the RM8 download) and received the “Unexpected Error” message, above. The program locks up with updating message in a circle, and only about 2 generations of my Ancestry tree downloaded. I sent this to Tech Support, and followed up with more detail on when it occurred. I believe they are looking at the problem, but the only response I’ve received is to delete the file and try downloading again. I updated to the latest version, 9.0.1, and started the download from Ancestry again, and received the same error message and probably about the same amount of data from Ancestry. I am on a Mac, running the latest version of Ventura. Has anyone else run into this, or have any suggestions to get me up and running? Thanks!

Have you tried restarting the Mac since you last downloaded the Ancestry tree?

I had, but thought I’d give it another try. So, I deleted all the tree and media files from My Documents, did the newest update to 9.0.2, and shut down my Mac. When I restarted awhile later I started the Ancestry download again. I really thought it was going to make it this time, as I watched the download of the tree and then the media file download both reach 100%. Then I closed that window from the Ancestry tree share to view the Pedigree page, and at that point I got the same “tabulmage” error again. What is that anyway?!? Again I could see that the Pedigree page was not complete, and was overlaid with the “updating views” icon that is just sitting there. I am beyond frustrated with this and the time I’ve spent trying to get this to work!

I actually don’t know what that “tabulmage” error is. If you open a support ticket and share the Ancestry tree with the agent we can test if we get that same error.


A screenshot would be helpful if its doable.

1 Like

I haven’t been able to be at my computer for several days, so this afternoon I thought I’d try it again. I got all the same results, unfortunately. After I delete the Ancestry downloaded files from my hard drive and start the download again, it actually appears that the download completes, and the side-by-side comparison of Ancestry to RootsMagic names does look complete, as far as I can tell. But when I close that box to see the RootsMagic pedigree screen, it is missing most of my names and I get the error message again. So, as I think about this, I wonder if the problem is not with the download, but with the RootsMagic display. I’ve attached the error message and the Pedigree display, which should have names in all boxes on this screen and following screens (which I cannot get to because of the “updating views” icon). I did submit a tech support report on March 4th, but they apparently haven’t figured it out yet.

I did submit a support ticket on March 4, and it was assigned, but no resolution yet.

You’re not the only one to have experienced it but they do seem rare and only on Macs, I believe. There was at least one other report in the Facebook group. You might want to connect with that person to see if your systems have anything in common, whether her problem has been resolved, …

Thanks, Tom. As soon as I am approved for the Facebook group, I will check this out!

I submitted a support request March 13 and Jackson responded March 14. It was request #123642.
“We are aware of this TabuImage error and working to find the solution. What operating system version do you have and what version of FTM are you using? What destination format did you set from FTM on the gedcom?”
I gave Jackson my information.

So while it’s not a widespread problem, neither is it an isolated one.

I had to recover a RM9 corruption by restoring from a backup. After restoring, all the media links were broken (as expected) and I dutifully ran the fix links tool, immediately exited from RM9, came back in and hey presto received the Tabulmage error reported here. By trial and error I found that fixing the media links was the cause of this problem, and further it was a problem only after I restored the media folder that contained all the primary people images. So I repeated the restore process, but after fixing the media links but before exiting RM9, I opened a few images (not the thumbnails) of people’s primary image. My Mac showed some strange displays of the person image but after 15 seconds settled down and showed the person image as expected. Then when I came back in to RM9 there was no Tabulmage error !! It looks as if you have to let the Mac/RM9 adjust to the new person images and then it knows what to do in future.

Anyway - just thought this might help others if they get hit with the dreaded Tabulmage problem.

I wish I could test using your file, but I don’t know how I would do it without the images.

Tabulmage error received on my Mac running latest OSX and latest RM9. Here’s how I finally fixed the problem with the help of Jackson in RM tech support.

Continued. FIX: rename all media files to eliminate special characters. Rename the media folder, Rename the main database RMtree. Start RM9, open the database, publish multimedia report, use report (in excel) to correct naming conventions in media link inside RM., and finally run Fix media links. Use tools to rebuild, compact, and correct phantom records. Yes it took all of the above to eliminate the error and get running properly. Detail: I did most of corrections using excel Duplicate conditional formatting and using formula to find special characters for via internet search.
Hope this works for you.

Thank you, Rich. This is all a bit overwhelming for me - who hasn’t used any software for genealogy except Ancestry online. I guess I need to step back and figure out how to start again with RM9.

Or check out some competing programs. You should pick the software that best fits your way of working. That may be RM, Family Historian, FTM or another. Most of these have trial packages available.

It’s worth investigating up front instead of a year down the road.

Based on the responses that others have shared one simple thing you might try is to look at your media file names and the names of the folders that contain your media to check for non alphanumeric characters such as ( , ’ , *, $, etc. Rootsmagic uses several of these special characters when storing the file path details in the multimedia table and it makes sense that this could create problems if the same characters appear in the file or folder name. If you use special characters in your folder or media file names, hopefully there’s not lots of them and it might be worth following the steps in the fix @rich_holden_1 posted. Perhaps someone could help you to rename everything if you’re not comfortable with it.

I hope this is not hijacking the thread, but another special character that can sometimes cause problems in file names is blanks. I recently had reason to use TreeShare to download another user’s Ancestry tree to which I had access.

I don’t know the why’s and wherefore’s, but every filename downloaded with the tree was packed with blanks. The files were downloaded to a folder under OneDrive and OneDrive does not support blanks in file names. OneDrive offered to replace all the blanks with underscores for me, and doing so would have broken all of RM’s media links. And by the way, OneDrive is about as mainstream as it gets these days when it comes to Windows computers.

It may be just because I started using computers in the mid-1960’s when the characters that were legal in file names were very restrictive. But I have never put anything into file names except letters, numbers, and the occasional underscore. That strategy has alway served me well. Lots of special characters will work just fine 99% of the time. And you can say that you use special characters in your file names all the time and you have never been burned. But that 1% of the time when special characters in file names fail can be a real killer.

It is only leading or trailing spaces that OneDrive cannot handle. It works fine for me with a file name such as 1950 Census (US)_
Restrictions and limitations in OneDrive

1 Like