Unable to transfer, or link, media files in RM8 from RM7

I’ve tried several times, including deleting the new RM8 file and starting over. Some of the media makes it, but not all. I have roughly 2,000 media files and am missing most of the files on everyone that I have checked thus far (approx. 20 individuals). Any suggestions? Hope I don’t have to manually relink, especially since the drag and drop is inoperative.

1 Like

If you are seeing a “media file not found” message then the link is broken and it’s easy to fix. Go to Media and select “Fix broken media links” under the 3 dots. If your media files are structured, it’s fastest to use the 2nd option to search drive or a folder and let RM search subfolders (rather than searching your entire system). If, on the other hand, you don’t see any indication that your media was tagged to the fact or source or person, then there was an issue with your import. This should not happen if you imported from a RM7 file. I don’t use gedcoms (I don’t believe they include media references). You always want to import from a rm7 file if you have one.


I ran into this same issue and resolved it by starting over, converting my RM7 file, this time making sure I saved it in the directory where my RM7 media file directory was.

1 Like

Gedcom import works for media links. This is how I moved my FTM 2019 file to RM8 for testing. You just have to fix missing media in the media window and tell it which folder to search with subfolders checked. Works fairly well.

RM is better than FTM in that you can manage media in subfolders much better. FTM fights you on that so well that I gave up and had no subfolders.

1 Like

I did it as you described and it didn’t work. Thanks though. I thought it was the answer. I’ll post a picture or two to show what I am having difficulties with.

More info. Hopefully this will explain the situation better. I am not getting any error messages. The transfer resulted in far fewer media files being transferred.

Here is an example, where 27 files are on an individual in RM7:

Here is the result in RM8:

Yes. Picture helps. Are you assuming that media was lost because you don’t see the equivalent to your RM7 screenshot? RM8 does not have the equivalent view of the media album or “All Media for a person” screenshot that you provided. So you cannot compare that rm7 screen to anything in rm8, at this time. In your example, you need to check where the rm7 media was attached - the events, sources, citations, etc. to see if the media is there in rm8.

1 Like

It’s more like the number of media items showing as being associated with the individual is lower in RM8. I had it organized in RM7 so I can see what media applies to whom, and then lost most of them in RM8. They still exist on my computer under my directory, just not connected to the person. What I would like to avoid is having to manually relink these items, of course. It’s like RM8 has no way to look at RM7, acknowledge those files are under a specific person, and then link those to the person in RM8. Hope that helps. Thanks for your comments too!

You are correct. “The number of media items showing as being associated with the individual is lower in RM8”. That is true and, by itself, is not indicative of a problem, because RM8 does not show the all media associated with the individual; it doesn’t have the media album concept for a person, at present, so you cannot see that summary of all of the media files associated with the person and their life events like you can in RM7. At the person level, rm8 only shows what rm7 calls ‘general media’, not ‘all media’. (In other words, if you attach media to the person in rm7 you should see it attached to the person rm8. If you attach media to the person’s birth event in rm7, you won’t see it at the person level in the rm8 because that “all media” view does not exist, but it still should be attached to their birth event and can by viewed by clicking on media for that event.) Net, there is currently no rm8 equivalent to the rm7 screenshot you posted. That’s an enhancement that’s been requested but did not make it into the initial release.

So, you may have a “view” problem not a db problem – ie all the media links are there; you just cannot see an album for the person. I suggest comparing the rm7 Database Properties (File, Properties) with the File Properties listing on the RM8 Home screen. All the numbers should line up, including number of media items and media links. If they do, all your media links should be fine. You can test by spot checking a few specifics at the event level, or source level. If the numbers don’t agree then I suggest running db tools in rm7 and import again. If there’s still a discrepancy you may want to open a support ticket.

To be fair, rm8 has introduced additional media linking capabilities (for example at the citation and task level) so the concept of a person media album may become a bit different. RM8 does have a Scrapbook report that you may find helpful but I don’t believe the scrapbook includes media from a shared event. But, for now, I’m not aware of an at-a-glance view that you can use to compare to the rm7 media album specific to a person.

Thanks. It appears that you have found exactly where I am at, which is RM8 and RM7 agree on the numbers and I will have to adjust my expectations for seeing media on a per person level. I’ll wait for future changes or manually link the items. I appreciate the detail you provided.

1 Like

I tried to convert a RM7 file into RM8. It did not bring PDF media into RM8. I have tried several times and have not been successful in

This worked for me, but I have an issue with the little check boxes [like the one for subfolders], none of mine show that they are selected when I click on them [but they work!].

My import from RM7 to RM8 also failed to bring over the media and media fix did nothing. However, I am very new to RM and re-downloaded my ancestry file with all the media into RM8. Seemed faster than messing about.