Unable to Shut Down RM8 After Access Violation Error

  1. Deleted my RM8 database.
  2. Recreated my RM8 database via import from RM7. (Steps #1 and #2 are something I do every day.)
  3. There was an immediate access violation error.
  4. Deleted my RM8 database.
  5. Recreated my RM8 database via import from RM7.
  6. There was an immediate error message that said that there was a recent access violation with a recommendation to shut down RM8 and restart it.
  7. Upon trying to shutdown RM8, it would not shutdown. Instead the error message about an recent access violation appeared with a a recommendation to shut down RM8 and restart it.

Step #7 then became in “infinite” loop which had to be broken by shutting down RM8 with Windows Task Manager. By “infinite”, I mean that every time I tried to shut it down the same error message appeared and it would not shut down. It’s not like the error message appeared repeatedly on its own,

Recovery was to delete the RM8 database from outside of RM8, to run the database tools in RM7, and to import RM7 again from RM8. The database tools ran normally in RM7 without reporting any errors. This time it all seemed to work fine. My biggest concern in this situation was that “infinite” loop. And how did the notion of a “recent access violation” survive the deletion of my RM8 database and its recreation?


Once RM8 creates an access violation error that may mess up OS memory beyond what RM8 uses and not be tied to a particular database. On mac AVs usually required a Force Quit of RM8 (windows task manager) and were caused by almost any action so there was no user discernible pattern. However most mac AVs were cured 2 updates ago in September.

Are you keeping your master file in RM7 and just importing to RM8 to test it? I continue with FTM 2019 but use a gedcom import to RM8 as an untrustworthy helper tool.

Yes. The reason is to test RM8 and also to try to develop personal workflows to get my work done in RM8. Not everyone agrees, but I find many basic tasks to be harder in RM8 than in RM7. I do understand and respect that I shouldn’t expect to be able to use RM8 exactly the same way I used RM7. But it’s frustrating that there are so many things that seem harder in RM8 than in RM7. In fairness, there are some basic tasks that actually are easier in RM8 than in RM7, but they are in the minority. I import from RM7 to RM8 every morning. Everything I do in RM7 during the day and evening I also do in RM8.

I was primarily reacting to the fact that after after the Access Violation, RM8 was warning me to shutdown RM8 and restart. So I did. The only way to shutdown was to force the shutdown with Windows Task Manager and restart… That’s because each attempt to shutdown resulted in the warning to shutdown again and it didn’t shutdown. Hence there was a loop until I forced shutdown again with Windows Task Manager. There was not a new Access Violation after the restart. Instead, after the restart there was a memory of the previous Access Violation that I couldn’t get rid of.

My personal thought is that AV error trap, recovery and reporting has been compromised in the latest release ( I have seen multiple times where clicking the send report button resulted in RM termination. I am not sure but I do not think the report was uploaded to RM.

Sometimes I can quit RM using the Mac OS Activity Monitor’s Quit option but usually I need the Force Quit option.

1 Like

Best to use force quit to be sure you get all processes. This is bad news since earlier updates did seem to fix the inability to report the av crash. That was a perfect loop: RM8 crashed and offered to report to Bruce but if you said yes then you were completely locked up. A fatal bug that could not be reported.

Jerry: sounds like av mess is still happening on Windows as bad as it was on Mac. I use RM8 too little to confirm such issues are really gone but AVs used to happen every other twitch or blink and now do not. My problem with RM8 is that it is still buggy and incomplete and does not show me my data nearly as well as FTM. It does have some good tools.

I have to agree with GG_022422-- been on RM8 since the beginning–have experienced very few access violations or errors UNTIL I downloaded the latest version 2 days ago–then started having multiple violations along with file not backed up error and another time the program just closed on its own…

thejerrybryan-- once you force RM8 to close using task manager, did you try rebooting your computer? just a thought

No, I did not reboot. I just ran the database tools in RM7, deleted my RM8 database, and reloaded the RM8 database from RM7.

1 Like