Access Violations

Aug 10, 2023Why I am suddenly getting “Access Violation” errors as I close? Started 3 days ago. RM9 I am in — Access Violation and an OK.

Windows or Mac? Which version of Windows or Mac?

Did you make any significant changes to your computer or your RM system immediately before this problem started happening?

Have you run all four of RM’s database tools?

If the problem is totally repeatable, then it surely would be helpful to the entire RM community to open a trouble ticket with the RM HelpDesk and submit your database to them for testing.

Jerry: RM9.0.6 is the mac version. Bruce now has different versions for mac and windows after fixing a mac only bug a while back.

My RM9 closes fine with a prompt to skip backup but running the database tools is a good first step. Also restore a backup prior to the issue and see if that works. Unfortunately RM9 lacks a list of changes which is helpful in FTM where you can reset things back to a particular date (like windows system restore).

Yes, as Rooty declared it is the Mac version.
I have made no significant changes at anything accept the regular updates. I have been working at merging several trees within a single data base for the pasts four months and have not had any issues until this past week. Except for a “error message” which seemed to just tell me it was time to back up everything I had been working on. Since as soon as I have gone out and come back in it is fine. That usually happens after about seven or eight steady hours.

I decided that I needed to wait until the end of a heavy day of working on my tree, to check it out. Although, I did close a couple of times earlier in the day. As soon as it was mentioned to use the database tools I did them. I had done one of them recently. Everything came out fine on them. And, I have just finished for the day and it was back. This was one from the other day.

I can not guarantee at being able to repeat it as it is not something in my control. It only appears to happen after several hours of work.

Run the tree count tool. Merging often gives undesired results that remain hidden. Perhaps what you experience is just an accumulation of many small program glitches that over time kill RM9. When I recently tried to really use RM9 it would crash erratically after several normal actions and hops around windows and people.

I run the tree count daily. I have a number of broken off branches that I have been mending as I go. Started with 6 pages of them and I am down to about 20 lose ones. I know there are a few that may never connect.
Wish there was a way of marking problem areas to come back to, without using all the colours. I have also used symbols in the suffix area. Helps to pinpoint an issue.


You could make a group of all the people who are not in your tree. Make a new group. As a part of making the group you could first mark everybody in your database and then unmark everybody who is in your tree. Everybody still marked at this point would be the people who are not in your tree.

Having made the group, you could filter the sidebar index or the People List view to see just the people who were not in your tree. But now that RM9 has multiple color sets, you could use one of the color sets just to delineate the people who were or were not in your tree. Make the people in your tree one color and the people not in your tree a different color. The difference would stand out like a sore thumb. This would not disturb and colors in any other color set, and you could still make a group. Also, you could search on the colors.

I’ve been getting a similar access error message in the Mac version of RM. I’m also using version As far as I can tell, after closing the error, everything is still OK in the database. But it’s nerve-wracking, not knowing what is going on.

The error message seems to pop up randomly.

I haven’t had it happen in the last two days. I don’t usually do a total shutdown of my computer, but I did a total restart and it hasn’t appeared again (knock on wood). Just saying in case that might be for you as well. And, yes it is nerve wracking.

If shutdown helped, try a safe boot and then back to normal startup. I shut down once a week and often do a safe boot and then a normal startup. Instructions differ for intel and M macs.