Access Violation Error RM9.1.2

Receiving this error multiple times on various screens, including clicking on the people tab without even drilling down into a person:

I have windows11, current, no onedrive or similar, file just moved from RM7 a few days ago, ran all the db tools. Open to suggestions!

Was just getting ready to move to RM9 off of RM7 due to the “important upgrade notice” regarding FamilySearch and Ancestry . Think I will hold off a bit longer until RM9 is stable.

Open a support ticket with a backup of your database and steps to reproduce.

Tried that, unfortunately my single experience was unsuccessful (#120588). The folks chipping in here on the forums seem to result in answers that work best for me. I will say that I have been using RM9 in parallel for over a year and did not see a single access violation error until I updated to RM9.1.2 though I freely admit I am not an RM9 power user so it is certainly possible the error and the update was a coincidence

So what are the steps that cause this error for you as we might know a work around…

Invariably it is when I click on one of the carets (is that what they are called?). For the one below, the error occured following running all of the db tools, not connected to the internet, onedrive actually closed, and a fresh reboot of the system (win11) 64bit version of RM (now 9.1.3).

Fairly repeatable, though sometimes I will need to click 5-10 different of them before the Access violation pops up.
Again, this is a fresh import from RM7 which I have also run the db tools available before export.


Confirming this issue has been reported to development.

Yes, I was able to use the navigation arrowheads in Descendants view to produce a similar fault:

Thanks for confirming repeatability. Question to those who understand databases, does an access violation risk corruption of data/database?

In layman’s terms, the underlying environment for access violation errors involves pointers within reserved portions of the computer’s memory that are set aside as boundaries for each program to differentiate the actual programming code from the data it is operating on/with (ie. not file access, but rather memory access).

Yes, there is some probability of corruption. One is if it happens midway through adding a new person to the database. This has resulted in a name record with an ownerid of 0. Unknown spouses in the FamilyTable have the same number so that name appears in some views and reports. That corruption is reversible with a SQLite query that the developers should incorporate in the program.

I also have always seen this same error dialogue on macOS, Windows, and on Linux with Wine. Not only on 9.1.2, but also on 9.1.3.

You Might read thru this thread posted earlier in the year

After Jerry mentioned this, I went in to see if I could repeat the error— I can repeat the error in 4 clicks
The database opens in Pedigree view , switch to Family View and click on the person, then switch to Descendant View and click the chevron to move up the line and it every database I have EXCEPT the one that opens in Family View–still haven’t had it occur the there-- I would go from Family View - highlight the person then go to Descendant View and hit the up arrow for the person-- no error – even better if I go down one level first-- I also played around with it some more since you posted this and if I open the database in Descendant View, it also does NOT seem to happen ( but please note that I only tried these ways for a short period of time) …
Worth a try to have your database open directly into descendant view—

I will also note that sometimes when I would close out of the database after using these workarounds, then I would get the error message or one time when I opened up the next database ( it probably opened in pedigree view)

Thanks everyone for all the help and guidance. I am sure since there is risk of data corruption The Rootsmagic dev team is on it, especially since they appear to be pushing to get us to use RM9 now. Think I will hold off a bit though moving from RM7 to RM9 until this issue is resolved.

RM8 is dead and unsupported. RM9 is the only version for mac users but windows people can still run RM7. Development tolerated access violation errors for most of the time RM8 and 9 were available so I am not sure how urgent they would consider further fixes. They do warn you to force quit RM when this occurs which should avoid saving a corrupted file.

Yes _ I definitely agree with you @Rooty that Development tolerated all the errors including argument out of range etc BUT
how long should we have to wait for a fix??? They jumped right in on the Mac problem with Sonoma and High Sierra --I completely understand and they definitely needed to do that–in fact I applaud them for doing so in a reasonable time frame — they have worked on Tree share and Family Search-- great-- BUT what abt those of us who have access violations and argument out of range that are totally repeatable by others–some of these were 1st reported in RM 8 beta-- guess the every day user isn’t as important–sorry just blowing off steam!!! no need to reply

First rule of any fix is to make sure the fix doesn’t cause other issues. If it does then it doesn’t get released in an update.