Access Violation errors with version (installed 10 Apr 2024)

Good day - - - I installed the update this afternoon and have started receiving access violations when I attempt to enter a place name (tried with several events and still receive the error). I have run the tools to clean files, re-index, compact… still receive the error.

Running Windows 11 and Chrome (both current)
Sample message below

1 Like

I also tried to get the most recent download from the RM site and restarted. No luck. Still the same error.

My description was a bit incomplete in that the symptoms are not limited to the place names, but occurs with people names, descriptions in other fields. Not just when entering a new item, but changing the spelling in the description associated with any item. I also should have mentioned that I did close the program restarted the computer.

I do hope my piecemeal approach to describing the problem didn’t complicate things

Does this happen when you start a new database from scratch?

I’m having a problem with RM 9.1.4 too. I downloaded the second iteration of it yesterday (10 April) at about 5:00PM Irish Time.

When I try to run the Database Tools, the program hangs after the Integrity check has run (apparently successfully), and I have to use Force Quit to exit RM.

I wanted to run the DB Tools not becase of any error message received but because I had been tidying up my file and that had involved the merging of several individuals.

So far, everything else seems to be fine.

This is happening under both Mac OS 14.2.1 (on MacBook) and 14.4.1 (on iMac)

UPDATE: I tried uninstalling and re-installing 9.1.4, but it made no difference. Just hope I don’t get any error messages that actually requite me to run the Database Tools beforethe problem is fixed!

Also having problems with changing a place name after a I downloaded the latest update - 9.1.4. Have restarted computer and still receiving the Access Violation error.

Same problems as above trying to change a place or note causes a Access Violation and RM continues to pop up the violation and the program has to be closed. Re-start makes no difference. Windows 10 64-bit version

Mr. Dog: you asked if this was when I start a new DB from scratch. It is with the existing datafile. So, this morning I created a new file from scratch and received the same error on the first entry. Thanks for asking

I’ve got a handful of these AV reports now but cannot recreate it. I need to figure out what is common between those reporting this issue. Are you all on Windows? Are you running the 32 or 64-bit versions? So far I have Windows 7, 10 and 11 seeing this. So its not specific to an operating system. Are you using two monitors?

The one Mac issue noted here using the Database Tools is something else, and not new to 9.1.4. It has been reported to development. When it freezes click on something outside of RM and then come back and it will be unfrozen.

1 Like

64-bit; Windows 11; two monitors. Existing file that has performed alright for years, but occur on a newly created file. Happens in name field, place fields, description fields. Other than doing the installation, I did not make any configuration changes.

I am seeing these in 32-bit Windows randomly and with no obvious repro steps. Most times, the function completes, but sometimes this error blocks execution.

Thanks Renee.
The DB Tools problem never happened to me with previous versions of RM, but your tip seems to work.

tried each database tool in mac sonoma and after the selected tool runs nothing else can be selected. you have to click another program and return. This was not a problem in earlier versions.

As a matter of fact, I am using 2 monitors. Windows 11. 64 bit version. I have tried to download directly from the RM website but still have the issue.

What if I delete the current RM program and completely install the version directly from the website. I won’t lose my data, will I?

Rooty, there’s a workaround for the database tools issue on mac. Click once to select the next tool, then hit “return”. That will run the tool. Rinse and repeat. that should work for now.

It’s been reported and Development is aware.

1 Like

I’m with you on this, simply chirping in with “me too” without any added relevant detail adds little or nothing to the collective diagnosis. Mixing problem reports in the same thread also does not help.

There are 3 different builds for 2 different OS and there are also the corresponding UK specific builds.

The minimum detail should include the OS and if applicable whether it is the 32 or 64-bit version. In this case, the download source should also be included, or

To contrast those having this issue, I updated from the first iteration, got the AV notice, and saw the comments about the missing .dll. When it was re-issued, I downloaded the 64-bit version and have had no other violations. I am running Windows 11 Home build 22631, two monitors.

Because my main computer is a laptop with a small screen, I have noted the confirmed issue of tabbing to fields in the custom Add screen when scrolling is needed.

I am also having the same problem ‘access violation’ having just installed the latest version today.
I am running Windows 11, 64-bit version.

Besides what the info you have asked for and the suggestions by @Austin , they should say WHAT VIEW THEY ARE WORKING IN–FAMILY VIEW, PEDIGREE, DESCENDANT VIEW–I haven’t had any problems since updating BUT know there is one way that an access violation occurs with as little as 3 - 8 clicks using DESCENDANT VIEW-- basically it comes down to going from a person up one level by the way of his father ( using the chevron/ arrow next to the father)- just a thought as I also can’t replicate their errors by what has been posted…