RM 9 Access Violation fault

In RM 8 I had this error keep occuring when I had made a lot of changes to the Ancestry tree and then run tree share.

Since I upgraded to 9 there is a c700 person tree on Ancestry that I downloaded into a first RM 9 tree, I did the problem list, and all the other tools, duplicates, tree count etc. I then ran all the database tools and no issues were reported. The tree was then backed up with media.

I then added quite a few people and associated citations etc to the Ancestry tree and then ran tree share in RM 9, that is when the errors started, initially it looked and performed OK, then when I got through about 2/3 of the changes and additions the access violation error kept happening.

Perhaps you have a slow internet connection? RM8 had a timeout issue for me especially with media included when I was on 15Mbs down/3 up service although FTM had no such issue.

I’m on Win11 Home 22H2 - OS build 22621.1413, and using the 64-bit version of RM

I have the access violation error when I try to run the Compare tool. It will get to a certain number (usually 460) and then gives me an access violation error, then recommends I shut RM9 down. I’ve done the whole “submit diagnostic/error” whenever the issue occurs, but that doesn’t fix my problem in the meantime.

  • To troubleshoot, I tried running Compare using a different database/file altogether - same issue.
  • I’ve uninstalled RM9, deleted the folders, shut down system, then reinstalled. Same issue.
  • I’ve even installed on a different drive altogether in case stray files would point to the old location and add to the chaos. Still had the issue.

My 1Gb cable is a bit overkill for RM interfacing with Ancestry

Run the database tools under File, Tools. Make sure only one database is open in RM when you try to compare it against another. Make sure both databases are not inside a folder syncing with the cloud, like OneDrive, GoogleDrive or Dropbox.

I compared two different files (400…50 people) and no crash. These are small unrelated files with no common people. Mac M1 Pro all software current.

when I duplicated the 50 person file and modified it the compare tool ran but showed differences for identical unchanged people. When the two changes were corrected they showed both bad and good data rows. So no crash but bad comparison.

The Access Violation errors kept occurring on my PC so I installed 9 and updated it on my Laptop and had the same Access Violation Errors occur.

Yesterday I installed RM 9 on my Wife’s iMac running Big Sur and downloaded her family tree from Ancestry and ran through all the Tools including Database Tools with no issue.

Today after doing some work on her tree on my iPad I started RM 9 on the iMac and initiated Tree Share.

After about 1/2 hour RM 9 crashed.

Started it again and Access Violation Errors are present.

So this is three different computers all running the latest version of RM 9 and all running projects on three different Family Trees, and all giving Access Violation Errors.

Surely there is something wrong with the way RM is structuring and working with its database?

How are you editing on the iPad?

@Biggles has previous said that his primary tree is on Ancestry and he uses the iPad to work on it on their site.

I use my iPad to work on our Ancestry Trees.

Currently, the next day I start up the applicable computer and work on the appropriate Roots Magic 9 family tree project first viaTree Share with the Ancestry tree, then I error check and then I use the database tools, finally I backup with media.

RM 9 Tree 1 is on my PC
RM 9 Tree 2 is on my Laptop
RM 9 Tree 3 is on my Wife’s Mac

All have RM 9 and all have the Access Violation error

RM 9 has crashed the Mac today, no other app was running at the time.

This message posted via my iPad

1 Like

Do you get it consistently doing the same thing or does it seem to be random. You’ll have to log what you were doing just prior to each incident to see if there is any such pattern

I checked/did everything mentioned, still have the issue. In case this info helps with troubleshooting:

On both the desktop and the laptop, RM is not located in a cloud-syncing folder. (Nor do I have any cloud/redundancy programs running in the background.)
I have run all of the Tools in order before running Compare – but I still get the error.

On the laptop, the RM is on the C drive (SSD) and my data is on the D drive (HDD). On the desktop, both RM and data are on the D drive (HDD). So basically, different setups – but still same issues occurring.

For now, I’ve stayed away from the Compare tool coz I don’t want my file to get corrupted from how often I get the violation errors.

Do you only have the one database open in RM when you go to File, Tools, Compare? That is when you will select the second database to open.

Well it is many weeks later and I have a brand new PC, hardly any software on it but there is now a fresh copy of RM9.

Just been updating my Family Tree and whilst performing a Tree Share yes than damn Access Violation error is still there.

So that is three separate Windows PC’s and an iMac, all have the Access Violation Error.

Has my original fault been corrected? No

Has the RM Tech advised me of the results of him examining my database? No.

Please get you act together and sort out the bugs.

I do have a new one, a birth date of a new person was 1911 and when RM imported that person their birth date became 1921.

I am having what appears to be the same problem myself.
The jpeg is the screen cap. I was using Treeshare with RM 9. Windows 11.
AV 2023-06-04 234816
In the progress of running all of the tools again. I have run them several times each day that i use RM but have never seen any problem.