Access Error when viewing/doing edits with sources

The updates since October have greatly improved my usage experience of RM8, and it is as fast, if not faster than RM7 on my Mac. Except for having a little trouble exiting FamilySearch Person Tools, I mainly observe random Access Errors, obliging me to restart the app so as to not get into more trouble. As before, these occur when viewing/doing edits with sources and notes. I am reminded of my old programming days when it was necessary to declare memory size, and access errors would occur when the buffer was overrun. Anyone else observe this phenomenon?

Access violation errors are a new fundamental feature of RM8 which has managed to port windows behaviour to the mac (spread the pain?).

I find RM8 to be very slow to open and load and it locks up the mac until it has creaked it’s way open. RM7 on mac was very slow but it had the excuse that it was a windows xp program inside a fake windows environment.

Very generous to be able to share the pain with Windows users (I bore with that for more decades than I care to admit). :wink: Curiously, I have not experienced the degree of slowness that you suffer - fortunately for me, I guess! Mysteries never cease!

Slowness of RM8 may depend on the mac model. I have a 7 year old 2014 MBP 13 with a dual core intel room heater cpu. More recent macs with the latest OS or the M1 chip may do OK despite RM8’s poor programming.

Ah so. Then you have no one else to blame but yourself. :grinning_face_with_smiling_eyes:

2 Likes

confused–I am to blame for a poorly written mac program?

Have to use my current older mac for several more months and 2014…2015 MBP risk permanent bricking if updated to current OS.

Well, if you’re expecting the computing world to conform to your 2014 standards, you’re bound to be disappointed. :blush: I’m suspicious that my clinging to my 32bit standard is messing with my RM8 file access performance. Apparently nobody else is having my problem.

Many mac users I tutor…train are still using 2008 models and 2015 was the last year you could buy a functional mac until 2021 M1 macs (bad keyboards/touch bar).

Macs remain functional a long time but the models before 2016 are ruined by current os upgrades. However, I am surprised anyone but Windows can still be using 32 bit software. My standards are current except for my Catalina OS but that will get fixed with a new mbp 14" this summer.

Do not worry about your 32 bit affecting RM8. Everyone has speed and access violation crash errors all the time. The AVs seem related to poor cpu interaction rather than RAM memory issues but may have multiple causes with non standard mac program conformity.

Well, that’s reassuring - sparing me updating to Monterey. I still use Picasa for photos, and I’m stuck at 32 bit (but considering putting my Mojave in a Parallels VM and updating my mac to Monterey - if there’s a compelling reason). So, looks like I’ll stay with RM7 for the heavy lifting. Have a happy holiday!

Are you now, or have you ever been a software developer? If the answer is no, I truly doubt you have the skills to determine whether it is poorly written. Now, if you actually mean poorly designed, I am with you on that. For example, if it has non-standard keyboard shortcuts for a Mac, then it is a design issue, not a programming issue. It is no secret that I think RM8, from a GUI standpoint, is an extremely poorly designed program. However since a minority of people are having certain issues, I fail to see that is is badly written. If it were, pretty much everyone would have those issues.

on mac most have speed and crash issues unique to RM8.

Experienced users are the best judge of how software looks and performs in the real world. Programmers( and packaging engineers) have limited tunnel vision in design choices and often seem to never use their products. Ignoring crashes and remaining bugs, RM8 interacts with mac users in a non-standard way. Some of this is probably deliberate design choices (ie need to specify media file type before import) but others are a failure to conform to mac os standards. Shortcut keys are not much of an issue between mac and windows.

Agreed! However Bruce stated that he and Michael wrote software that they would like to use. Either they like bad stuff, or …or who knows. There is an interesting book called ‘Why Software Sucks’ by David Platt. When I was teaching Intro to Programming classes, it was required reading. More devs need to read it. Its central point was ‘you are not your user’. You need to pay attention to how your user uses the software.

As for “most have speed and crash issues unique to RM8”, no, it isn’t most. It is a small group of users. The one thing that small group has in common is old hardware, as you have now admitted to.

As for bugs, what, specifically, are you claiming to be a bug? Set aside the crashing issue for a minute, what else is a bug in your world? Generally the lack of a preferred feature, or an annoyance in the location of a feature is not a bug. It is bad design. Your example of having to enter a file type for media…not a bug! Bad design, at least for Macs from what you say. I refuse to develop for Macs due to hoops that Apple has, so I am unaware that one of the Mac ‘standards’ involves automagically knowing what format a media item is and dealing accordingly. I googled and could not find a refence to this being a requirement in Mac software, so I have to take your word as you are so knowledgeable in regards to developing apps for Macs.

1 Like

Access violation crash on creating a new RM8 file from a FTM gedcom. Was able to report it but seems to occur every time a new file is created. 2nd attempt to do the same thing after quit and restart does work. uploading a new tree to ancestry did work without media but would be very slow of any large tree.

Interesting! I just created a GED from FTM2019. It contains 41,525 people, 2000 sources, just over 10k citations, 3000 media. I accepted all of the default items in the GED export and the defaults in the RM8 import. Took about 45 seconds to complete. This on a 7 year old Dell PC running Windows 10 Pro with a third generation i7 processor, 16 GB of RAM.

I might just try an Ancestry upload later today, with the new RM file, just to see. TreeShare has always been way slower than I like, but I hardly call that a bug!

Thanks, guys. Your conversation is almost enlightening as it is entertaining. :blush: Now, can you give me a little illumination on how, in the same environment, RM8 regularly gives me access violations slaps (typically during/after doing something with sources, and in close association with FamilySearch People Tools) while RM7 goes merrily along without a whimper?

Try RM8 import of that large gedcom and upload to ancestry with and without media. Curious to see your results. My small 370 people tree with 500 media items bombs due to timeout errors but works with out media taking about 5 minutes on a slow 15mbs down…5mbs up connection.

media file type spec in RM8 is a design flaw not a bug. Those Apple OS hoops you dislike are the reason mac software is so reliable and malware free but apparently developers can ignore them if not selling through the app store.

I think you run RM8 on a mac while RM7 lives in a windows xp fake environment (crossover) or a virtual windows environment (parallels). The fake windows hiccups with your mac but RM7 is happy inside the windows not mac environment. It is the botched port to a native mac app that gives us those lovely AV errors.

1 Like

Ah so, a crossover environment! How clever! It loves it in there! And I’m so happy to have it.:grin:

I did do a RM8 import, from FTM2019. Which is what I described above. It worked just fine. As for the Ancestry upload, going to go start that now.

Ok, FTM GED imports in 48 seconds. Once imported into RM8, the Ancestry upload took 62 minutes and completed just fine. For giggles, I uploaded the FTM file to Ancestry and it actually took 65 minutes, but again, it worked.