Bug Feedback and details on longstanding issues

  1. Upload to ancestry fails if you have a moderate sized database and a slow internet connection. RM8 does a few % upload and then gives a “you are not signed in to ancestry” error. Clearing the error and continuing goes another 1 or 2% and repeats the error. Smaller files do work. This is a timeout error for the ancestry connection and needs fixing.
    macbook pro 2014 16GB ram 256 ssd; centurylink dsl 40 down/5 up;
    files 800mb 370 people 450 media-fails; 200mb 50 80 works.

A 50GB backblaze fresh backup to the cloud on this same system worked flawlessly although it took 30 hours.

At my local Toyota dealer on the 50 Mb up/down guest network the large database worked in 4 minutes. You folks have a timeout issue with ancestry and RM8.

  1. RM8 gives the dreaded access violation error often with the file menu: create/load/import. This is the perfect bug since if you click the send report to RM8 button the program locks up and never sends a bug report.

  2. RM8 is very slow to open and load a file on a 2014 intel mac on Catalina. 15 seconds for a modest file that takes FTM 2019 2 seconds and is instantaneous in macfamilytree. The program clearly needs code tweaking to speed this up. Perhaps on a M1 apple silicon mac it would be fast but is not on an intel room heater chip.

  3. how do you add a topic tag? Only 3 are listed and none are appropriate.

  1. The 3 topic tags are the only tags that can be chosen when posting in this forum.

RM8 is sooo slow to open and load a database on a mac that I am 3 other programs down the road doing unrelated tasks when RM8 suddenly interrupts me as it finally opens. Most annoying and the only dog in my 25 non-apple programs.