Access Error when viewing/doing edits with sources

did you try the upload with media included? If it worked then this is another windows ok mac not bug.

Of course I did! 4,000+ pieces of media. This particular file is a little larger than my initial test import. This file has 42,218 people, 16,257 families, 80685 events, 5798 places, 2697 citations, 4170 media items, 4575 media links. TreeShared to Ancestry in 62 minutes, synced from FTM2019 to Ancestry in 65 minutes. Everything was accepted as default. Trees were both set to private.

If it is a Mac only bug, then in theory, you should find a Windows computer and try the same process. If it uploads ok, then maybe you have a bug. If it crashes, then you have a problem with your file. However, if it were a Mac specific bug, I am pretty certain that every Mac user would be carping about it in the various RM forums. I would also be interested in what happens if you found someone with a newer Mac and tried this upload. If it works on the newer Mac, then you have an issue with either the file or your hardware, not the software.

no mac user has any interest is using a windows pc and others have reported this issue. Any file problem is created by RM8 import and the failure is a timeout error.

Mac users are not commenting much on RM8 because most have left years ago and the few remaining have developed very low expectations. I am at the stage where RM8 is a modestly useful helper tool for FTM and there is little value in these forums so I will probably drop them.

Alas, but thanks for your help. I have valued the perspective.

I think it is more because you are afraid that it will turn out to be your problem, not the software.

As for Mac users, you would be very wrong. There are now and have been quite a good size number of them commenting throughout the beta testing and community preview sections. I would say the proportion is rather equivalent to the proportion of Mac users to Windows users.

Surely you have a friend, at least one, with a newer Mac that would let you do a quick install and test. I am sure that if you have friends, at least half of them do use Windows machines.

I’m feeling reassured, thanks. And 'tis the season. :blush:

I’m still hoping for better in the New Year. “Hope springs eternal …” Alexander Pope.

Yes, I’m getting frequent access violations on Windows 10. As someone else pointed out, sources seem to be an issue. Another cause is navigating through profiles too fast, especially in pedigree view. Haven’t tried creating a new file or exporting recently.

Thanks for sharing. There is comfort in knowing I’m not alone. :blush:

1 Like

Now, children, play nice. :blush:

1 Like

Asking a customer who bought production-level software for their Mac to go find a Windows PC to test on is really excessive. As long as the customer has one of the supported versions of mac OS [macOS Sierra (10.12), High Sierra (10.13), Mojave (10.14), Catalina (10.15), Big Sur (11) or Monterey (12)] the software should just work. Blaming the customer is the wrong approach.

I tested RM 8 during the community test period, going long enough to get a crash or two and then stopping because the software was not ready for deep testing. It now crashes on me several times a day when entering source information, but I haven’t bothered saying much here because I didn’t think anyone cared.

I did finally vent to RM Support, who have given mostly helpful and productive answers (I still think they need to remove the instructions to do virus scans, CCleaner, etc. from their FAQ, as that is also blaming the customer). I am otherwise working with them now to try to find repeatable sequences to produce crashes.

If it wasn’t a dead end, I’d go back to RM 7 running under Crossover or Parallels. I never had a problem there. If I wasn’t sharing the database with my sister who uses RM on Windows, I’d go look for other programs. Instead I’ll just deal with the crashes and hope they get fixed eventually.

I care! What helpful and productive answers would you be willing to share? I’ve gone back to RM7 until I can get better reliability from RM8.

1 Like

No, it is not excessive. It is called troubleshooting. The more you can narrow the problem down, the better the chance of finding out what is broken. Rooty’s issue is not the same as yours and I expect that it is a completely different problem from your issue. I suspect this because the same error situation happens to me on Windows when entering sources. So I am pretty sure that error is not Mac specific, nor file specific, unlike Rooty’s issue. You also seem to have missed that in addition to the Windows machine, I suggested he try a newer Mac as he has admitted to having rather old system. For all we know, his upload issues could be due to a network card dropping packets, which would specific to his system and something that can be ruled out by testing on other machines.

Rootsmagic has used that old malware, cleaner, firewall wives tale for over a decade for many problems and it probably just carried over to the new mac version.

Do your crashes seem related to bad CPU access or to memory problems? My mac shows lots of free memory but high steady CPU usage by RM8 unlike all other programs once loaded.

Perhaps you could share with your sister via gedcoms and change to another program to wait out RM8 settling down. Hopefully Bruce wants a stable product to show and sell at Rootstech 2022 (or 2023).

That’s an interesting thought. I’ve not thought about monitoring CPU and memory since my old Windows days! Ah, that takes me back! I’ll check it out, thnx.

It isn’t just Rootsmagic that does this. It may surprise you that there are many, many programs that offer that same advice. Even FTM has it on their troubleshooting page for Mac issues.

The FAQ advice to scan for malware and install CCleaner is advice for everyone in the FAQ, not just Mac users, and is a real bad case of blaming the customer and making them do needless work before opening a support ticket.

The crashes happen when closing windows after adding sources. I haven’t checked CPU usage.

I finally have things set up with FreeFileSync and Google Drive to share the database and media files so we can share the database (on a check-out basis, we don’t edit the same file). If the crashes were bad enough I’d just go back to RM 7 under Crossover for me and Windows for her. I’m bugged about the crashes but not enough to switch to completely different programs.

Before calling support, Rootsmagic expects their users, many of whom are non-technical, to do the following:

  1. Run the RM database tools. This is good advice as it can clear up issues in Rootsmagic.
  2. Scan their computer with their AV software.
  3. Install CCleaner and run the cleanup tools.
  4. Install malwarebytes and scan

The last three steps are a lot of work for customers, especially the non-technical ones, when Rootsmagic itself is still flaky. It may be fine in special cases once RM Support has looked at the problem, but it’s a huge burden as general advice. The FAQ should recommend the database tools and then have users contact support.

Telling Rooty to get a newer Mac to test on isn’t much better than telling him to get Windows. Big burden on the customer.

I didn’t tell him to get either Windows or a new Mac. Surely he has a friend or acquaintance that has a Mac. I am betting that if he knows at least 3 people, he knows someone that has a Windows machine. If he can’t/won’t at least try it, then he needs to stop flapping about it being buggy software. The assumption is quite clear…it is his file or hardware. If it were a general bug problem, then it would be a much more prevalent issue than it is. Trust me, there are enough Mac users in the three major support channels that there would be some noise being made…and that just isn’t happening except a few rare occurrences. Believe it or not, some of his issues could be as silly as an invalid character in the pathname (yes, it happens even on Macs).

Rooty thinks FTM works well. Guess what? FTM tells you to update your computer, it tells you to create a new user profile, it tells you to start in safe mode to by pass AV software and other background bits, and that is off the Mac support pages…All of these are hoops to jump through. None of what you mention is specific to RM. Those very same suggestions can be found on the support pages of literally hundreds or thousands of software packages. The particular steps have been around since I did tech support for The Learning Company (which included the precursor to RM, known as Family Origins, as well as FTM) back in the late 1990’s.

You apparently have a Mac, can you import a GEDCOM, can you TreeShare a small file? Have you tried it? Do you get errors?

I have consistently received access errors on my M1 Mac Pro lap book after a number of efforts to unsuccessfully engage the programmers for a fix. The attempt to update the database at a family holiday reunion was a bust. I shall be reverting back to Windows this week. At this time, I do not recommend using the Mac