TreeShare Sync Upload Issues -- Any progress on resolving this?

I use TreeShare to upload data from RootsMagic to my Ancestry tree.

I currently cannot get RM8 to connect to my Ancestry tree on my laptop. I keep running into “out of memory issues”. I have an open ticket on the problem.

I have 4 meg of memory on my laptop and have the virtual memory maxed out.

I’ve tried running RM8 in safe mode with networking support to connect it to my Ancestry tree.

Desktop computer – where TreeShare works
RM8 version
Windows 10 Home
Intel Core i7 - 10700 CPU @2.90GHz

Laptop - TreeShare does not work
RM8 version
4.0 GB RAM
Virtual Memory set at 6144
Intel Celeron CPU @ 1.83 GHz
Windows 10 Pro

I tried booting my laptop to safe mode with networking yesterday to again try TressShare. It again crashed. The error message recorded in Computer Management says

Faulting application name RootsMagic.exe version, time stamp: 0x616456ef
Faulting module name KERNELBASE.dll, version 10.0.19041.1288 time stamp 0x3e55bd0b
Exception code 0x0eedfade

My tree stats:
People 20058
Families 6605
Events 63216
Places 8362
Sources 5057
Citations 21512

REMEMBER: I am NOT trying to download from Ancestry. Instead I upload from RM to Ancestry when I have changed someone.

Any Suggestions on what else to try?

There is a known bug with trees larger than approximately 15,000 people. It is not a computer memory error, as I have 32GB RAM installed with 24GB free when running. TreeShare does not work. This bug was also shared on the Facebook group. No one has chimed in from RM to acknowledge, nor if they will fix, or when.