RM9 Day One Observations

I use RM7 and tried RM8 but found it too much of a learning curve at the time, however for $20 I just couldn’t resist trying again with RM9. I have now spent a few hours with it and maybe it wasn’t as painful a learning curve as I had anticipated. As it is a completely new application it does not interfere (almost - see below!) with RM7 and that is reassuringly the same as ever… However I plan to use RM9 going forward. I just need to try out setting up the portable version and trying it in another machine.

Meanwhile I have already encountered a few points that I’ve noticed with RM9 and list them below:-

I was running version 25/02/23 32 Bit (on a Windows 10 64 bit machine - the reason I did this was not sure if I put it on a pen drive would the 64 bit version work on 32 bit guest machines).

  1. After importing my RM7 file four people had a problem icon (and also come up in the ‘Problem Search’) with an error ‘Missing Surname’- yet they have a surname. I tried re-editing it etc. The only way to remove the error was to click ‘Not a Problem’. The same people in RM7 do not have the error flagged up. I have also some people reported to have missing given name - and again they do have one.

  2. Some facts have the icon to tell me there are notes - but the note is empty. How can I clear the icon? If I create a new note and then go on to delete the text the icon still remains.

  3. Theme Colour. If I use settings/display and change the Theme Colour I was getting an Unexpected Error Access Violation message and it sends a report back to RM. This seems to have stopped happening.[this has not happened since using the 64bit version of RM9]

  4. Font Scaling. If I change the font scale I get an Unexpected Error Access Violation message and it sends a report back to RM. [this has not happened since using the 64bit version of RM9]

  5. RM8 Features (the Wiki does not show RM9 features) claim : Open up to 3 Edit Person screens at the same time - but in RM9 if I open one then click on another the first one disappears… [NOTE!! I have now found the answer to this - the screens are active but minimise - I can see tabs for each one at the bottom of the screen - I didn’t spot that before!]

  6. I had RM9 and RM7 running at the same time. When I closed RM9 (after an access violation advised me to) RM7 also went off the screen but was still running in the background and I had to use task manager to close it then re-start. [this has not happened since using the 64bit version of RM9]

  7. Check for Updates - no message to say ‘You’re up-to-date’. Nothing - is it working?[Note - since going from 32Bit to 64bit version when I click the ‘Check for Updates’ button it now flips to my Home screen and I can see in the bottom RHS a box for Updates information.]

  8. Where do I ‘Set Relationships’? [I have now discovered the ‘Edit Button’ top right of the ‘People’ view!]

  9. When I use Alt-Tab to go to other applications when I come back to RM9 it is sometimes (but not all) no longer using the full screen.[this is still happened since using the 64bit version of RM9]


I don’t doubt your observation that your scenario happened, but it really sounds impossible. There should be no interaction between RM7 and RM9 other than that RM9 imports the RM7 database. After that, the interaction should be zero. Did you try Alt-Tab to get the RM7 screen to come back up?

Hi Jerry

Yes I did try Alt-tab, and also closed all other programs - but couldn’t get it back up on the screen even though it was sitting in the task bar at the bottom running. I have since installed the 64bit version of RM9 (I originally used the 32Bit version because I wasn’t sure if the 64bit would work from a memory stick in other machines). Since using the 64bit version I am not getting the Access Violation Errors and so RM9 closes down cleanly and RM7 is as you say not affected.

Many thanks for your reply though.

There is some interaction between RM8 and 9 on mac. I uninstalled 8 before installing 9 but overlooked the RM folders dumped into my home folder. The AMT folder contains files ending in -8 that are created by RM8 and 9. RM7 on a mac would not interact because it is inside a fake windows bottle.

RM7 didn’t have the Missing Surname or Missing Given Name options for Problem Alerts. It is new in RM9 and that is why you are only seeing it there. You need to check all names for the person, including alternate names for the person. Highlight each name and check that the given and surnames appear in the correct fields. What is typical being found is the given and surname have been combined into the given name field. It is working as designed so you can fix this error.

1 Like

Confirming this has been reported to development.

Alternate name was correct in FTM file but after gedcom import did all end up as given name. Corrected. How would I find the not a problem list to take this person off it?

Thanks rzamor1 - That all makes sense - the surnames were missing in the Alternate Name for the persons. They were imported from another GEDCOM and the fact had been used to enter a ‘nickname’ or alternate spelling of the surname. I understand this now. Very interesting!

Rooty - The ‘Not a Problem List’ can be found when you are in the ‘People’ view - click the ‘Tools’ icon top right and the list is at the bottom :-1:



Thanks for doing that

I have intentionally used the the idea of only showing Given (or Surname) and it documents, by omission, what it is being shown. I would hate to go through all the trees and ‘fix’ something that in my mind is not broken. Maybe some granularity on the situation for marking these problems?


The setting from Problem Alerts that appear on the person tools is under Settings, General Settings, Problem Options.

1 Like

Thanks so much for the help on this problem. :sweat_smile: