Shortcut Editing Keys missing in RM9

Cntrl-X, Cntrl-C, and more seem to be missing from the just installed RM9. Tried rebooting without any change.

There are a lot of missing shortcut editing keys missing from RM8. I’ve been disappointed with RM8 and wondering if I want to spend the money for version 9. Will it just be more aggravation? At this point, I wish I had stayed with RM7.

Yes, this is a SERIOUS issue. Figured at some point I’d have to commit to something past V7. So, have been playing with it today.

  1. Can’t save a fact by doing Alt-O as in V7. It’s a real pain to have to take your hands off the keyboard and use the mouse to click the check mark.
  2. Tried a citation for a military record. Process seems a little clunky, but the real killer is not being able to copy the completed footnote to transfer it over onto my document image! Not by highlighting and Ctrl-C or by right clicking (does nothing).
    No doubt there are other similar issues revolving around this same thing, but these two are really a problem for me.
1 Like

After some more fiddling around with RM9, I have decided to delete my RM9 file from my computer (so I don’t inadvertently use it again) and go back to using RM7 until this issue in particular is resolved. It’s simply a showstopper for me. RM9 will stay on my computer, I just won’t being using it yet for real research work. As updates come out, I can still play with it to see if it’s in a state for me to commit to it.

Yes, I had backed up every RM7 file I had before downloading RM9, so I’ve lost no ground or important information during my playing with RM9.

1 Like