RM9 Arguement out of Range

“Argument out of Range”
Hi, it’s me again. After the previous conversation about the same topic in RM8. I decided to purchase the upgraded version of RM9, thinking that would cure the problem. I am colour coding a previous tree, scrolling down through the right hand side index. Unfortunately the same thing is happening again. It seems cyclic, by that I mean after scrolling between 35-40 names the Argument out of range crops up, I have counted my indexing a few times more and it happens around that number? Frustrating then having to close the program down and restart numerous times. I have used all the database tools frequently to no avail. I’m currently using RM9 currently up to date. My chipset is based on a 64 bit program. I’d like to know if anyone else is having the same problem, and possibly when the developers/programmers might come up with an answer to help eliminate this issue. Unless someone can advise me to the contrary. Thank you in advance.

This list issue has been reported to development. After so many times in and out of a list the error will come up.

So once the error occurs, does it happen every 3 clicks after that or does it take another 35-40 to happen?

Technically you should restart the program right after the error occurs-- usually when the argument out of range occurs for me is somewhere between 650-1000 clicks-- then it is 3 clicks before it happens again BUT there was a time that it would happen like you every 40-60 clicks and then would happen again in another 40-60 clicks

Suggest you run all the database tools ( just in case) then shut down RM and reboot your computer–in one instance rebooting the computer did slow the error down…

I have NOT used color coding a lot BUT when picking the people to color code have you tried using the RootsMagic Explorer instead of the right hand side index?

besides the same list as in the right side index panel, if you click on MARK–it gives you other options


Suspect ( but don’t know) that you would get farther or maybe eliminate the error this way

Thank You Nancy for your reply. Most Welcome. How do I get to using the RootsMagic Explorer? Where is it situated I cant seem to find it or the Mark or Unmark. If you wouldn’t mind pointing me in the right direction, ill give it a try. Yeah you’re correct in your assumption of clicks, I was just counting the names, not clicks, but very similar for me also. Its just getting to me in having to close everything down all the time. I wouldn’t mind if it was random, but like you’ve said its every time after those series of clicks accumulating I the message.

Kind Regards


Thank you Renee for your kind comments. Much appreciated. Hope something happens soon.

Kind Regards


how I got to the Roots Magic Explorer was to click on color coding under the pencil–pick your color and give it a set name— then on right side you see

pick people selected from a list and click on Apply highlighted color to people selected above-- the ROOTSMAGIC EXPLORER will pop up and Mark is right under the name RootsMagic Explorer in the screen shot above— you can use one of those under mark or manually check the persons you want then hit select-- you can always go back in and add more if you missed someone…

And yes it is very annoying when you are trying to get something done to constantly have to shut down-- I add a Mouse Clickr and use that–so I know to shut down at abt 650 clicks…

Great got it thanks so much. I may add a clicker to do the same. Great advice.


Hi Nancy, just a quick update. I tried what you suggested and it completely worked all the way through the tree without any argument out of range. So I thought I’d try going back to the original name index, and within the prescribed amount of clicks it came back again. So in my reckoning there must be a count of some sort attached to the name index, don’t know why?

Thanks again.



Support told me that I was receiving the argument out of range error coming from the list manager. Development is working on this issue.

Glad you were able to get the color coding done without any problems…