New ERROR just started "Argument out of range"

Just this week, started on Sunday and has contiuned till today. I go to click on a person, and this error pops up. It does not self submit to RM, it is not allowing me to submit, and I have to either click on the ok tab or the X to get the error window to close, and then I can contiune working. It does not have the error pop up each time, I can do maybe one edit and it happens, or I can do 20 plus edits and then it happens.

Anyone know what this error is? Or how to fix it? Or how to stop it?

I have searched for this error in book, online under RM and online in general. I get a ton of hits online, but it does not help me, I do not understand most of the information.

EDIT: I just found a April 2022 RM forum post for “Unexpected Error Argument out of range”, which was freezing up the persons program. They had the option to send error report in. They had to do the old control alt delete to unfreeze. But there was NO answer to a fix at all, and no further.

No fix for this yet. See Renee’s post on what to do!

Arguement out of range

2 things you can do to slow it down is

  1. once the error happens, close out all your RM files you have open ( backup or skip backup is up to you)— then reopen them-- the error will happen again but it might be a while longer…
  2. When you close out your RM files, reboot your computer then reopen files-- again error will happen but might give you a little more time to work before it does…

Thank you. I see the prior post, and have somewhat been doing just that. I like you mention, “No fix for this yet”, which kinda tells me they know about it and will fix it? But the program does not send the error to them, nor will it let me send it.

Thank you so much for the answer back. It has been driving me nuts working around it. I kinda have been doing everything you mention. Very first time, I got out of program and went to my last save backup prior to this happening, I save everyday. BUT … just as soon as I opened up the last saved file, the error happened. So its in the program, and just getting saved data does not fix it. But I have been backing out, and have been rebooting. So far the program has not locked up or frooze, like I read in the 2022 posting. And as mentioned “No fix for this yet.”, so my fingers are crossed that they know and a fix is in the works.

1 Like

You will see from the other thread that I have been having these too. In fact I had another one after my last post.

So far none of the errors have been caused by editing anything, just moving between people. The first time, this was moving between people on the Family Screen; all the subsequent occasions were caused by moving between people in the index. It is interesting that your errors seem to be triggered by the same thing.

Recently, I have been filtering the index on a group (set by criteria) as I work though my file clearing up some rubbish from Ancestry. Are you doing anything similar?

Hello Alan, mine just started happening this past weekend, nothing to do with Ancestry. Mostly on the Family Group screen, and just moving the cusor from person to person and clicking on a new person, ERROR! After checking here and making the post, with the help given, I was already doing most all suggestions, but just not working on the pinning it down part.

Following Nancy’s line I have been taking note of it. So far for me, in a one hour time span, after using the tools and reboot, I made it for about fifteen minutes, and had two errors in the next 30 minutes. Had to take a break, (family dinner) so I lost the time track part. On returning, I did the tools, reboot and started again at 1905 hours, and (knocking on my head) no errors as of yet, it is just now 1938 hours. I have been on the same family today of parents and nine children, and branching off to the kids of each child doing editing and adding of sources. (again no ancestry).

“Argument out of range” issues won’t be fixed until we can recreate it. We need a copy of the database and the steps to reproduce it. You can open a support ticket to start the process.
https://support.rootsmagic.com/hc/en-us/requests/new

Hi Renee,

I opened a suppport ticket, but each time I try to upload my database (56,000 people and c250mb) I get a time out error. This happens after only a few seconds after my PC has been using lots of network, ie really sending something. On my support ticket, I asked whether there is another way to send the file to you, but the agent hasn’t responded to that.

On what caused the problem, I can only re-state that it has happened to me when I repeatedly move between people, sometimes in the Family screen but more often in the Index. Most of my error message have come when I have had the index filtered using a group defined by criteria. Yesterday, I finished the exercise using this group and stopped using it. I was hard it it on RM for several hours after that with no more errors. If I continue error-free, I may go back to using the group for a while to see whether I get more errors again.

The support agent tells me that this happens on Mac (despite my writing in the ticket that I am using windows.) I am not using a Mac.

I think 250 meg is a little extreme for only 56000 people but have you tried uploading a backup file instead? The compression should shrink the file size considerably.

Thanks for the suggestion.

I must confess that I was surprised by the size of the file, 5kb per person seems like a lot.

The file was created from a download from Ancestry, and I have a mirror file on RM7 created the same way. @rzamor1 recently advised me to drag and drop the RM7 file into a new database because I had lots of very high RIN numbers (coming I think from the problem in Treeshare loading children with duplicate names). The original RM7 file was 390mb and the drag and drop copy is 350mb, so the RM9 file is almost 30% smaller than the smaller of the two RM7 files.

Anyway, the RM9 backup file is only 74mb - which makes me wonder what RM9 is doing with the extra 175mb it is using. However, even this timed out on upload to RM support.

My antivirus is running a full scan at the moment and hogging loads of resources; I will try the backup file again after it has stopped. If that fails, I will make a copy on dropbox paste a link to it in the support ticket.

Alan

An RM backup file is a zipped-up version of the database. You can literally extract the database with .ZIP unarchivers.

How many media items? The thumbnails are stored in the database and will take up a large portion.

How many media items? The thumbnails are stored in the database and will take up a large portion.

Hadn’t thought of the thumbnails. There are 54,000 media items, so they probably do explain a large proportion of the file. Presumably they aren’t saved in the backup, so they would explain much of the difference with the size of that.

Thanks for the explanation.

The thumbnails are, because they are stored in the database file. The backup is a ZIP compressed file, hence the reduction in file size.

Also, everyone of these TreeShared images has a record not only in the db MediaTable but also in the AncestryTable linking it to its Ancestry parent. There is significant expansion in db file size as a result of TreeShare.

Okay @TomH --I’m CONFUSED as typically you send support a gedcom— which only shows an icon on the person ( at least the one I have received) or does using Treeshare make it totally different then if I just added my own media?

Support rarely if ever would ask for a GEDCOM; they ask for your .rmgc or .rmtree file.

The difference in the database between adding media directly rather than via TreeShare is the record in the database file’s AncestryTable for the latter vs no such record for the former.

I have had the same problem and have submitted my file to support. This is the correspondence I sent.
I am running RM 9 ver 9.0.3.0 on a Windows 10 64 bit. I never had this on Ver 7 or 8.
Problem: I am getting an “Unexpected error Argument out of range” . I am under the “People List” and when scrolling through the list created by the selected group I get this error. This can occur in different groups that I have selected. It seems that once the error starts it continues. What I mean by that is after I opt to send or not send the error report when I return to scrolling through the list I only move through 2 or 3 more records then it happens again, It continues making scrolling unusable.
I have tried the following to no avail:
Test Integrity no errors
Rebuild Indexes Successful
Clean Phantom Records successful
After repeating this process I still get the error.
The only way to rid the error is to shut down the program and restart it.

Thanks
Daniel Hurley

They could not duplicate the error until I told them it was occurring when I used the arrow keys to scroll through the people list. They are aware of the issue. They emailed me back and confirmed that they could indeed reproduce the error with my database. I have not heard back from support as to the remedy. I was initially told that it may be corruption in my database, but hearing that others are having similar issues makes it likely that the problem lies in the program. I can still use the program, but I am reluctant to work with my data until this gets fixed.

1 Like

I am glad that support has been able to replicate the issue. My ‘argument out of range’ errors all happened when I was browsing through 2800 people members of a particular group looking for issues to fixed. It is insteresting that we were both browsing heavily and suggestive that we had both filtered on a group.

I have now fixed all those issues and stopped browsing so heavily and using the group to filter, and I have not had any ‘argument out of range’ errors in the past couple of days.

Personally, I am not too worried about it corrupting my database; I would be more concerned if the error occurred when adding, amending or deleting data.

I don’t see this issue corrupting your database. We could recreate it on any database if you used the arrow key to go through the People List. You would have to go about 200-300 records before it happened. Didn’t make any difference if there was a group or not. Development has the report.

1 Like